Zen Cart Logo
Forums / Installing on a Linux/Unix Server / Server requirements

Server requirements

Locked

Views: 2,072

Results 1 to 5 of 5
This thread is locked. New replies are disabled.
24 Nov 2008, 11:56 PM
#1
robsnowden avatar

robsnowden

Zen Follower

Join Date:
Apr 2004
Location:
Up t'north, UK
Posts:
264
Plugin Contributions:
0

Server requirements

Hello

I am requesting help please as I have recently moved all my sites to a new dedicated server with a new hosting company and am experiencing some issues in running my stores.

I have had a long chat with the hosting company and whilst they are very helpful they have asked if the support guys here at zencart could tell me if my server is sufficient for running zencart or if 'some additional modules may need to be installed' to make things run smoothly.

I have searched the FAQ as suggested to others with similar questions and I have trawled through numerous posts here but am still in the dark a little.

They have suggested I post this link (my site is https://www.g18.biz/order) with the respectful request that someone who knows what they are talking about (so that discounts me) can take a look and see if all is well with my server specs:

http://www.g18.biz/order/phpinfo.php

I really appreciate your help with this guys (and girls). I really have spent many hours with this today and ask for help as a last resort.

Cheers

Rob

25 Nov 2008, 12:03 AM
#2
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Server requirements

Perhaps you could explain what you mean by "experiencing some issues" ?

25 Nov 2008, 12:14 AM
#3
robsnowden avatar

robsnowden

Zen Follower

Join Date:
Apr 2004
Location:
Up t'north, UK
Posts:
264
Plugin Contributions:
0

Re: Server requirements

Yes of course:

For example I installed a mod today for backing up the site. It is a simple install with very few files to upload. When I try to 'backup the site' from within admin I get:

Warning: require(/home/national/public_html/admin/backup_mysite_backend.php) [function.require]: failed to open stream: No such file or directory in /home/national/public_html/shoppe/admin/backup_mysite.php on line 19

Fatal error: require() [function.require]: Failed opening required '/home/national/public_html/admin/backup_mysite_backend.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/national/public_html/shoppe/admin/backup_mysite.php on line 19

I can confirm that the files are very definitely there and that the necessary file permissions are set correctly.

I have used the debug system from the free software add ons section and it just gives me the same errors.

I have installed this mod a number of times before on the old server I was using without issue.

I set up a new zencart installation tonight on another domain - just to test and it gave same errors

I also tried to install another mod for a new template and got very similar errors.

Does this information help? If you need any more info please ask as I do not know what is relevant and what is not.

Many thanks.

PS: Does it look like the server specs are ok?

Rob

25 Nov 2008, 1:27 AM
#4
website_rob avatar

website_rob

Inactive

Join Date:
Oct 2006
Location:
Alberta, Canada
Posts:
4,572
Plugin Contributions:
0

Re: Server requirements

It would would seem to me that any Hosting company providing you with a Dedicated Server and stating you should you should go the script Forum to see if the script can be used, doesn't really know what they are providing you. The big issue is security and, although I can suggest certain settings for you, who would do them? Seems the Hosting company is not quite sure themselves.

Your Server by the way, should not have a problem running Zen Cart. Contrary to what you stated, the error msgs. you provided are simply stating the files to be found cannot be found. Why? Either they are not where they should be or permissions / ownership are incorrect. No two ways about it.

25 Nov 2008, 3:20 AM
#5
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Server requirements

robsnowden:

Warning: require(/home/national/public_html/admin/backup_mysite_backend.php) [function.require]: failed to open stream: No such file or directory in **/home/national/public_html/shoppe/admin/backup_mysite.php **on line 19
The error message actually is telling you exactly what's wrong:

You're running the script from inside the /shoppe/admin/ folder, but it's looking for files in the /admin/ folder.

So, you've got your site configured wrong, or the addon is using hard-coded paths to find its extra files.

This has nothing to do with your server specs.