Zen Cart Logo
Forums / Built-in Shipping and Payment Modules / Authorize.net AIM Communication Error after moving server to GoDaddy VirtualDedicated

Authorize.net AIM Communication Error after moving server to GoDaddy VirtualDedicated

Locked

Views: 4,041

Results 1 to 7 of 7
This thread is locked. New replies are disabled.
25 Nov 2008, 5:27 AM
#1
snowkrash avatar

snowkrash

New Zenner

Join Date:
Aug 2007
Posts:
65
Plugin Contributions:
0

Authorize.net AIM Communication Error after moving server to GoDaddy VirtualDedicated

Hello,

I just moved from shared hosting to virtual dedicated hosting on Go Daddy to solve the PCI Scan Compliance Issue of not passing the scans, then not being allowed to manipulate the server settings (it's got to be a conspiracy -- but I digress).

So, the move happened, new cert installed and everything's great until you try to pay for a product and you get Communications Error - Please notify webmaster. - Your credit card could not be authorized for this reason. Please correct any information and try again or contact us for further assistance.

Here's the log file for the error:

Nov-24-2008 10:19:17

Comm results: couldn't connect to host

Response Code: Array
(
[0] =>
)
Array
(
[0] =>
)
Sending to Authorizenet: Array
(
[x_login] => *******
[x_tran_key] => *******
[x_relay_response] => FALSE
[x_delim_data] => TRUE
[x_version] => 3.1
[x_type] => AUTH_CAPTURE
[x_method] => CC
[x_amount] => 42.70
[x_card_num] => *******9605
[x_exp_date] => 0611
[x_card_code] => *******
[x_email_customer] => FALSE
[x_email_merchant] => TRUE
[x_cust_id] => 2
****** SOME PRIVATE DATA REMOVED BY MODERATOR ******
[Date] => November 24, 2008, 10:19 pm
[IP] => 24.143.229.179
[Session] => *****
[url] => https://secure.authorize.net/gateway/transact.dll
)

Result: Array
(
[0] =>
)

CURL info: Array
(
[url] => https://secure.authorize.net/gateway/transact.dll
[http_code] => 0
[header_size] => 0
[request_size] => 0
[filetime] => -1
[ssl_verify_result] => 0
[redirect_count] => 0
[total_time] => 0
[namelookup_time] => 3.5E-5
[connect_time] => 0
[pretransfer_time] => 0
[size_upload] => 0
[size_download] => 0
[speed_download] => 0
[speed_upload] => 0
[download_content_length] => 0
[upload_content_length] => 0
[starttransfer_time] => 0
[redirect_time] => 0
)

Using CURL Proxy: [proxy.shr.secureserver.net:3128] with Proxy Tunnel: On

I called GoDaddy, they said it's my fault somehow, and I didn't know what to say to them. Please help, my client is going to kill me, as no one can order -- thanks in advance.

Signed, Desperate.

25 Nov 2008, 6:44 AM
#2
kobra avatar

kobra

Black Belt

Join Date:
Aug 2005
Location:
Arizona
Posts:
31,500
Plugin Contributions:
4

Re: Authorize.net AIM Communication Error after moving server to GoDaddy VirtualDedicated

Move them to a good eCommerce host there some listed in the top nav bar .

Else you have to find and edit the port file on this server(win or linux?) and insure that the port Authorizenet uses is open for bi-directional communication

25 Nov 2008, 6:59 AM
#3
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Authorize.net AIM Communication Error after moving server to GoDaddy VirtualDedicated

snowkrash:

Using CURL Proxy: [proxy.shr.secureserver.net:3128]
GoDaddy made some changes to their proxy configuration recently.
Turn off the CURL Proxy Status in Admin->Configuration->My Store, and try again.

snowkrash:

I called GoDaddy, they said it's my fault somehow, and I didn't know what to say to them.
Once you get it working, call their support department and ask to speak to a supervisor, and tell them about the mess you've encountered and the level of competence and professionalism demonstrated by their support staff. It's useful for them to know so they can improve things in case you need to call in again.

25 Nov 2008, 7:24 AM
#4
snowkrash avatar

snowkrash

New Zenner

Join Date:
Aug 2007
Posts:
65
Plugin Contributions:
0

Re: Authorize.net AIM Communication Error after moving server to GoDaddy VirtualDedicated

UN-fricking-believable

It worked like a charm.

I'm calling them right now. I hate them. Thank you. Will report back.

-Kristin

25 Nov 2008, 7:38 AM
#5
snowkrash avatar

snowkrash

New Zenner

Join Date:
Aug 2007
Posts:
65
Plugin Contributions:
0

Re: Authorize.net AIM Communication Error after moving server to GoDaddy VirtualDedicated

Supervisor says he will alert the VDH support staff. Thank you again. You made my week.

26 Nov 2008, 12:17 AM
#6
gdsupport avatar

gdsupport

New Zenner

Join Date:
Apr 2008
Posts:
14
Plugin Contributions:
0

Re: Authorize.net AIM Communication Error after moving server to GoDaddy VirtualDedicated

Hi Kristin,

Glad to hear this was resolved! I will make sure to reiterate this with our support staff as well.

Sincerely,

26 Nov 2008, 5:33 AM
#7
gdsupport avatar

gdsupport

New Zenner

Join Date:
Apr 2008
Posts:
14
Plugin Contributions:
0

Re: Authorize.net AIM Communication Error after moving server to GoDaddy VirtualDedicated

There is no proxy in the Virtual Dedicated Hosting and Dedicated Hosting networks. When the config file was moved from shared hosting to a Virtual Dedicated server, the proxy was not disabled, causing this error to occur.

On another note, the proxy is no longer necessary when using Go Daddy shared hosting.
http://help.godaddy.com/article/4764

Regards,