Forums / Templates, Stylesheets, Page Layout / Directory index forbidden by rule -- after uploading new template

Directory index forbidden by rule -- after uploading new template

Locked

Views: 3,714

Results 1 to 8 of 8
This thread is locked. New replies are disabled.
25 Nov 2008, 11:19 AM
#1
christophert avatar

christophert

New Zenner

Join Date:
Nov 2008
Posts:
32
Plugin Contributions:
0

Directory index forbidden by rule -- after uploading new template

Having FINALLY managed to load a template onto my zen-cart, i am now unable to open the Online Catalogue page (and so effectively see my 'new site') due to an error, noted in the log as a 'Directory index forbidden by rule.....' error.

(Directory index forbidden by rule: /home/fhlinux139/a/aqua-amore.streamlinenettrial.co.uk/user/htdocs/zencart/)

Any ideas how to solve this problemo..? :lamo:

25 Nov 2008, 11:44 AM
#2
stevesh avatar

stevesh

Black Belt

Join Date:
Feb 2005
Location:
Lansing, Michigan USA
Posts:
19,793
Plugin Contributions:
2

Re: Directory index forbidden by rule -- after uploading new template

Check posts #15 and #16 here:

http://www.zen-cart.com/forum/showthread.php?t=84537

then check with your host.

25 Nov 2008, 11:52 AM
#3
christophert avatar

christophert

New Zenner

Join Date:
Nov 2008
Posts:
32
Plugin Contributions:
0

Re: Directory index forbidden by rule -- after uploading new template

hi thats a totally different problem, i dont have a 500 internal error. mine is a

"Directory index forbidden by rule" error

:mellow:

25 Nov 2008, 12:50 PM
#4
stevesh avatar

stevesh

Black Belt

Join Date:
Feb 2005
Location:
Lansing, Michigan USA
Posts:
19,793
Plugin Contributions:
2

Re: Directory index forbidden by rule -- after uploading new template

OK, read posts #18, 19 and 20 in the same thread.

What I did was search the forums for "forbidden by rule".

25 Nov 2008, 1:01 PM
#5
christophert avatar

christophert

New Zenner

Join Date:
Nov 2008
Posts:
32
Plugin Contributions:
0

Re: Directory index forbidden by rule -- after uploading new template

Hi, i think the above directory index query is specific to 500 error, as the problem still exists without the .htaccess, resulting causing THIS page when i click on the online catlog:

http://www.aqua-amore.streamlinenettrial.co.uk/zencart/index.php?main_page=

the Log says it is due to: "Directory index forbidden by rule"

25 Nov 2008, 3:48 PM
#6
christophert avatar

christophert

New Zenner

Join Date:
Nov 2008
Posts:
32
Plugin Contributions:
0

Re: Directory index forbidden by rule -- after uploading new template

:frusty:

Right so heres the update. I deleted everything, and re-uploaded.

I kept getting a 500 Error, so I checked the log, and put .htaccess_OFF for both admin/includes (which stopped styling) and includes (which stopped pop up preview).

However, I now cannot get to the Online Catlog due to this error:

Directory index forbidden by rule: /home/fhlinux139/a/xxxxxxxxxxxxxx.streamlinenettrial.co.uk/user/htdocs/zencart/

any idea how I can get around this current block?

25 Nov 2008, 4:06 PM
#7
christophert avatar

christophert

New Zenner

Join Date:
Nov 2008
Posts:
32
Plugin Contributions:
0

Re: Directory index forbidden by rule -- after uploading new template

additionally, it once worked (back in the 500 error days), but now does not seem to work anymore, not even before the .htaccess are changed to remove the 500 error....

eeek!

25 Nov 2008, 10:14 PM
#8
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Directory index forbidden by rule -- after uploading new template

"Directory index forbidden by rule" ... is a direct result of a configuration on the server to prevent the ability to browse a directory and list its files.

This can be caused by several things:

  1. Server's apache configuration has rules set to disallow directory index browsing
  2. You have a .htaccess file in that directory which has a rule in it to prevent directory index browsing (is it there but you can't see it because it's hidden?)
  3. You have no index.html file in that directory and thus it thinks it needs to attempt directory index browsing
  4. Your server doesn't have a rule to use index.php if no index.html file is found

Every one of those cases points to unconventional server configuration.

You might get around #4 above by uploading the index.php file that belongs in the root of your Zen Cart site. But, if you've already got that, then all the points I made above apply. And, you'll likely have to sort them all out with your hosting company.
If they cannot or will not sort it out for you, run ...

.
Zen Cart - putting the dream of business ownership within reach of anyone!
Donate to: DrByte directly or to the Zen Cart team as a whole

Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.