Zen Cart Logo
Forums / All Other Contributions/Addons / Back Up My Site PHP Files Error - HELP!

Back Up My Site PHP Files Error - HELP!

Locked

Views: 1,774

Results 1 to 12 of 12
This thread is locked. New replies are disabled.
23 Dec 2008, 12:09 AM
#1
rmkiser avatar

rmkiser

New Zenner

Join Date:
Nov 2005
Posts:
32
Plugin Contributions:
0

Back Up My Site PHP Files Error - HELP!

Hi! i've looked on here and can't find the answer to this problem. I have the Back Up My Site PHP Files installed. Up until yesterday, it worked fine. Now, I get a HTTP 500 error. I have uninstalled and re-installed the add on with no lunch. My permissions are set properly.

I also have the error log add one installed. It is giving me the following error. Any idea of how to get over this or what is causing it?

[22-Dec-2008 18:00:56] PHP Fatal error: Out of memory (allocated 45613056) (tried to allocate 11534336 bytes) in /home/smoky09/public_html/admin/backup_mysite.php on line 92

I know it says it is out of memory. But, is there a way to increase this?

23 Dec 2008, 12:13 AM
#2
barco57 avatar

barco57

Totally Zenned

Join Date:
Apr 2006
Location:
West Salem, IL
Posts:
2,845
Plugin Contributions:
0

Re: Back Up My Site PHP Files Error - HELP!

Thats a subject to take up with the hosting company. I also wonder is it easier to either download the files by ftp or use the backup function in cpanel?

23 Dec 2008, 1:04 AM
#3
rmkiser avatar

rmkiser

New Zenner

Join Date:
Nov 2005
Posts:
32
Plugin Contributions:
0

Re: Back Up My Site PHP Files Error - HELP!

barco57:

Thats a subject to take up with the hosting company. I also wonder is it easier to either download the files by ftp or use the backup function in cpanel?

That's sort of what I was afraid of. I really liked the back up because it zipped everything up. I think my CPanel has a way of backing everything up.

23 Dec 2008, 2:42 PM
#4
mydanilo avatar

mydanilo

Totally Zenned

Join Date:
Dec 2004
Posts:
1,024
Plugin Contributions:
0

Re: Back Up My Site PHP Files Error - HELP!

I just played around with this backup option in cpanel. I used full backup and then ftp'd it to my local pc. I unzipped the files to see and explore what I got. I discovered many files ending in strange extensions like this example file shopping_cart.php0000755.

php0000755 or other numbers get added on to many files. I assume they are the permissions for the particular file. But why is this only happening on some files, and others are just fine ending in *.php as expected.

Kind of inconvenient if part of the backup is screwed up like this. Unusable if I want to compare and merge files. I question if this backup would work if ever restored into cpanel again.

Anybody an explanation for this?

23 Dec 2008, 5:03 PM
#5
stevesh avatar

stevesh

Black Belt

Join Date:
Feb 2005
Location:
Lansing, Michigan USA
Posts:
19,793
Plugin Contributions:
2

Re: Back Up My Site PHP Files Error - HELP!

I just used the CPanel backup and it worked fine, though I used the 'Partial' backup to download the whole 'Home' directory. I'm not sure what the difference is between 'Full' and 'Partial' here, since all the important stuff is in the 'Home' directory.

23 Dec 2008, 8:19 PM
#6
mydanilo avatar

mydanilo

Totally Zenned

Join Date:
Dec 2004
Posts:
1,024
Plugin Contributions:
0

Re: Back Up My Site PHP Files Error - HELP!

Have you actually looked at the files it created? Did you unzip them on your hard drive? Dig into some folders like includes/languages/english and see if the same thing happens like I mentioned.

23 Dec 2008, 9:13 PM
#7
stevesh avatar

stevesh

Black Belt

Join Date:
Feb 2005
Location:
Lansing, Michigan USA
Posts:
19,793
Plugin Contributions:
2

Re: Back Up My Site PHP Files Error - HELP!

Yes, and yes. I checked the filenames and opened several PHP files in different directories, and all seems well.

23 Dec 2008, 9:56 PM
#8
mydanilo avatar

mydanilo

Totally Zenned

Join Date:
Dec 2004
Posts:
1,024
Plugin Contributions:
0

Re: Back Up My Site PHP Files Error - HELP!

Good for you, mine are usable but as I said, some extensions get changed. My host does not support this feature and wrote:

"Unfornately the cPanel back feature is developed and controlled by cPanel not HostXXXX or any other company for that matter.

The backup is created to operate to server side backup where the server can read the backup in the format it would need not the format a customer would need.

The only way to download the files from the ftp would be manually and backup the database using phpmyadmin or the using the DB backup mod for zen cart form the downloads.

We only offer the backup feature we do not maintain it."

I found this a bit odd but whatever...I guess I have to keep ftp'ing the whole thing file by file to my PC.

23 Dec 2008, 10:09 PM
#9
skipwater avatar

skipwater

Totally Zenned

Join Date:
Jun 2008
Location:
Washington, DC
Posts:
775
Plugin Contributions:
1

Re: Back Up My Site PHP Files Error - HELP!

rmkiser:

[22-Dec-2008 18:00:56] PHP Fatal error: Out of memory (allocated 45613056) (tried to allocate 11534336 bytes) in /home/smoky09/public_html/admin/backup_mysite.php on line 92

I know it says it is out of memory. But, is there a way to increase this?

Have you seen this thread it talks about low memory and how to fix.
http://www.zen-cart.com/forum/showthread.php?t=95376

23 Dec 2008, 10:13 PM
#10
website_rob avatar

website_rob

Inactive

Join Date:
Oct 2006
Location:
Alberta, Canada
Posts:
4,572
Plugin Contributions:
0

Re: Back Up My Site PHP Files Error - HELP!

mydanilo:

I just played around with this backup option in cpanel. I used full backup and then ftp'd it to my local pc. I unzipped the files to see and explore what I got. I discovered many files ending in strange extensions like this example file shopping_cart.php0000755.

php0000755 or other numbers get added on to many files. I assume they are the permissions for the particular file. But why is this only happening on some files, and others are just fine ending in *.php as expected.

It is not the norm for cPanel to add anything to a file name. It is (or supposed to) copy files verbatim, including the names.

Have you confirmed the file in your Hosting does or does not have the additional file name text?

Any idea what version of cPanel is being used? (your cPanel Home page tells you the version)

Is PHP running as CGI or APACHE? (use Zen Cart Admin to see)

rmkiser, the last question is for you as well.

If PHP is run as CGI then you can alter amount of memory used.
If PHP is run as APACHE then nothing you can do.

24 Dec 2008, 3:25 PM
#11
stevesh avatar

stevesh

Black Belt

Join Date:
Feb 2005
Location:
Lansing, Michigan USA
Posts:
19,793
Plugin Contributions:
2

Re: Back Up My Site PHP Files Error - HELP!

Another way that worked for me is to use the CPanel File Manager to compress the public_html folder (or whatever directory you want) into a zip file, and download that via FTP. Ten seconds to zip, 40 seconds to download.

26 Dec 2008, 1:29 PM
#12
mydanilo avatar

mydanilo

Totally Zenned

Join Date:
Dec 2004
Posts:
1,024
Plugin Contributions:
0

Re: Back Up My Site PHP Files Error - HELP!

stevesh:

Another way that worked for me is to use the CPanel File Manager to compress the public_html folder (or whatever directory you want) into a zip file, and download that via FTP. Ten seconds to zip, 40 seconds to download.

This is it! :clap:
Beautiful. I will back up my files this way from now on. Very fast and easy to do. Checked some files in the zip and they seem to be correct with the right extensions (*.php) and not some other stuff added as I previously reported.

So if you want to backup your files to your local computer and use them for file merge or edits, this is the way to go.