Zen Cart Logo
Forums / General Questions / cant get into my admin error showing

cant get into my admin error showing

Locked

Views: 1,785

Results 1 to 14 of 14
This thread is locked. New replies are disabled.
9 Jan 2009, 12:21 AM
#1
cathshandcrafts avatar

cathshandcrafts

New Zenner

Join Date:
Aug 2008
Posts:
14
Plugin Contributions:
0

cant get into my admin error showing

i recently put my website down for maintence work and was able to get into it but for over a week now this error message has being showing and i cant get into my admin at all

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, [email protected] and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.


Apache/2.2.11 (Unix) mod_ssl/2.2.11 OpenSSL/0.9.8i DAV/2 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 Server at cathshandcrafts.com Port 80

can anyone help me please

thanks
mags

9 Jan 2009, 12:24 AM
#2
kuroi avatar

kuroi

Totally Zenned

Join Date:
Apr 2006
Location:
London, UK
Posts:
10,475
Plugin Contributions:
11

Re: cant get into my admin error showing

Talk to your webhost about directory and file permissions. What are they allowed to be? What are yours? Also check whether you have a .htaccess file on the site and if so, try temporarily disabling it (e.g. by changing the name to .htaccessOFF)

9 Jan 2009, 12:28 AM
#3
tony_sar avatar

tony_sar

Totally Zenned

Join Date:
Jul 2006
Location:
Montreal, Canada
Posts:
2,276
Plugin Contributions:
0

Re: cant get into my admin error showing

also , if you have modified any core files or any file that zc loads that might have corrupted.
is not just your admin , shows the same for your store as well.

9 Jan 2009, 12:40 AM
#4
cathshandcrafts avatar

cathshandcrafts

New Zenner

Join Date:
Aug 2008
Posts:
14
Plugin Contributions:
0

Re: cant get into my admin error showing

thanks for the advice guys

tony sar how do i go about doing that

mags

9 Jan 2009, 12:48 AM
#5
cathshandcrafts avatar

cathshandcrafts

New Zenner

Join Date:
Aug 2008
Posts:
14
Plugin Contributions:
0

Re: cant get into my admin error showing

here is the down for maintence permissions

Mode User Group World
Read x x x
Write x
Execute
Permission 6 4 4

9 Jan 2009, 12:54 AM
#6
kuroi avatar

kuroi

Totally Zenned

Join Date:
Apr 2006
Location:
London, UK
Posts:
10,475
Plugin Contributions:
11

Re: cant get into my admin error showing

Your down for maintenance file is fine and working. It's not showing because your Zen Cart is being blocked by the server before it can get to this file. It's the rest of your files and folders that I'm suggesting you take a look at. Especially any that you have uploaded recently as part of your maintenance.

9 Jan 2009, 12:56 AM
#7
tony_sar avatar

tony_sar

Totally Zenned

Join Date:
Jul 2006
Location:
Montreal, Canada
Posts:
2,276
Plugin Contributions:
0

Re: cant get into my admin error showing

did you modify any files when you had your store in maintenance mode ?
as Kuroi suggested you may want to rename your .htaccess so perhaps apache will show more of the error then what is now being thrown by the server.

9 Jan 2009, 12:58 AM
#8
cathshandcrafts avatar

cathshandcrafts

New Zenner

Join Date:
Aug 2008
Posts:
14
Plugin Contributions:
0

Re: cant get into my admin error showing

i am trying to find that access file now i havent uploaded anything new or changed anything only the down for maintence

mags

9 Jan 2009, 12:59 AM
#9
kuroi avatar

kuroi

Totally Zenned

Join Date:
Apr 2006
Location:
London, UK
Posts:
10,475
Plugin Contributions:
11

Re: cant get into my admin error showing

Has your webhost changed anything, such as the security settings on their server, while you were down for maintenance?

9 Jan 2009, 1:03 AM
#10
cathshandcrafts avatar

cathshandcrafts

New Zenner

Join Date:
Aug 2008
Posts:
14
Plugin Contributions:
0

Re: cant get into my admin error showing

he might of done i did email him but have heard nothing back yet i have tried a couple of the sites that i know got the hosting off of him and they all seem fine

i dont seem to have a htaccess on my cpanel control at all i cant find it

mags

9 Jan 2009, 1:53 AM
#11
tony_sar avatar

tony_sar

Totally Zenned

Join Date:
Jul 2006
Location:
Montreal, Canada
Posts:
2,276
Plugin Contributions:
0

Re: cant get into my admin error showing

.htaccess are files located in some of your zencart folders for example , you have htaccess in Includes and Admin folders.

9 Jan 2009, 4:26 PM
#12
cathshandcrafts avatar

cathshandcrafts

New Zenner

Join Date:
Aug 2008
Posts:
14
Plugin Contributions:
0

Re: cant get into my admin error showing

Here is my htaccess file for admin

$Id: .htaccess 1105 2005-04-04 22:05:35Z birdbrain $

This is used with Apache WebServers

For this to work, you must include the parameter 'Options' to

the AllowOverride configuration

Example:

<Directory "/usr/local/apache/htdocs">

AllowOverride Options

</Directory>

'All' with also work. (This configuration is in the

apache/conf/httpd.conf file)

The following makes adjustments to the SSL protocol for Internet

Explorer browsers

<IfModule mod_setenvif.c> <IfDefine SSL> SetEnvIf User-Agent ".*MSIE.*" \ nokeepalive ssl-unclean-shutdown \ downgrade-1.0 force-response-1.0 </IfDefine> </IfModule>

Fix certain PHP values

#<IfModule mod_php4.c>

php_value session.use_trans_sid 0

php_value register_globals 1

#</IfModule>

to turn off register_globals

php_value register_globals 0

can anyone tell m is there anything wrong there
thanks
mags

18 Feb 2009, 10:46 AM
#13
draki avatar

draki

New Zenner

Join Date:
Feb 2009
Posts:
2
Plugin Contributions:
0

Re: cant get into my admin error showing

Hi there,

I have the same problem. Since yesterday cannot log into admin section, everything else works perfect.

I didnt change anything on my zencart, it was working ok since I installed it 2 weeks ago. Well ok, I had that 500 error maybe two times before, for no reason, but it went away without any help.

I have contacted to my hosting admin but he cannot help me, he said that whenever I want to login to admin page the server cpu going 100% for 30secs, and then showing me that error.

I'm using latest zencart without any modifications.

31 Mar 2009, 3:19 AM
#14
ukrik avatar

ukrik

New Zenner

Join Date:
Feb 2008
Posts:
25
Plugin Contributions:
0

Re: cant get into my admin error showing

I had the same problem and i fixed it by giving permission to admin folder, in my case "755".

OWNER: read, write, execute
GROUP: read, execute
PUBLIC: read, execute

hope it helps