Zen Cart Logo
Forums / Installing on a Windows Server / 1064 You have an error in your SQL syntax ... TYPE=MyISAM

1064 You have an error in your SQL syntax ... TYPE=MyISAM

Locked

Views: 129,676

Results 1 to 5 of 5
This thread is locked. New replies are disabled.
16 Jan 2009, 3:02 AM
#1
rocket707 avatar

rocket707

New Zenner

Join Date:
Jan 2009
Posts:
4
Plugin Contributions:
0

1064 You have an error in your SQL syntax ... TYPE=MyISAM

Here is the full error:
1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'TYPE=MyISAM' at line 1
in:
[CREATE TABLE ccbmx_upgrade_exceptions ( upgrade_exception_id smallint(5) NOT NULL auto_increment, sql_file varchar(50) default NULL, reason varchar(200) default NULL, errordate datetime default '0001-01-01 00:00:00', sqlstatement text, PRIMARY KEY (upgrade_exception_id) ) TYPE=MyISAM;]

This happens just after I try to install and click Save Database Settings in the DB Setup step. I have given the all permissions to everything and cannot figure out why it is giving me this error. Any help would be appreciated.

16 Jan 2009, 9:19 AM
#2
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: 1064 You have an error in your SQL syntax ... TYPE=MyISAM

What version of Zen Cart are you trying to install?
What version of MySQL is on your server?

17 Jan 2009, 12:20 AM
#3
rocket707 avatar

rocket707

New Zenner

Join Date:
Jan 2009
Posts:
4
Plugin Contributions:
0

Re: 1064 You have an error in your SQL syntax ... TYPE=MyISAM

1.3.8 - It was the one at the top of the list. I downloaded it about a week or so ago.

MySQL 5.1

Thanks.

23 Feb 2009, 4:25 AM
#4
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: 1064 You have an error in your SQL syntax ... TYPE=MyISAM

Your version of MySQL probably requires that you edit the /zc_install/sql/mysql_zencart.sql file and replace every occurrence of TYPE=MyISAM with ```
ENGINE=MyISAM


The next version of Zen Cart will already incorporate this MYSQL5-specific change.
24 Feb 2009, 3:22 AM
#5
rocket707 avatar

rocket707

New Zenner

Join Date:
Jan 2009
Posts:
4
Plugin Contributions:
0

Re: 1064 You have an error in your SQL syntax ... TYPE=MyISAM

As luck would have it I finally figured it out last night... You are right though... Changing it from Type to Engine worked and everything is up and running.

Thanks...