Forums / General Questions / Security error after upgrade to PHP5

Security error after upgrade to PHP5

Locked

Views: 953

Results 1 to 10 of 10
This thread is locked. New replies are disabled.
23 Jan 2009, 10:38 PM
#1
mark_kidd avatar

mark_kidd

New Zenner

Join Date:
May 2008
Posts:
74
Plugin Contributions:
0

Security error after upgrade to PHP5

I'm hoping someone has seen this issue before -- after an upgrade from PHP 4 to PHP 5, I am receiving the error:

Warning Warning: I am able to write to the configuration file: /home/appalsho/public_html/store/includes/configure.php. This is a potential security risk - please set the right user permissions on this file (read-only, CHMOD 644 or 444 are typical). You may need to use your webhost control panel/file-manager to change the permissions effectively. Contact your webhost for assistance. See this FAQ

I have confirmed in my control panel that the permissions are 644. What else could be causing the error?

You can see it in action a http://appalshop.org/store/

23 Jan 2009, 10:48 PM
#2
barco57 avatar

barco57

Totally Zenned

Join Date:
Apr 2006
Location:
West Salem, IL
Posts:
2,845
Plugin Contributions:
0

Re: Security error after upgrade to PHP5

Set the permissions on the includes/configure.php to 444

Mike
AEIIA - Zen Cart Certified & PCI Compliant Hosting
The Zen Cart Forum...Better than a monitor covered with post-it notes!

23 Jan 2009, 11:05 PM
#3
mark_kidd avatar

mark_kidd

New Zenner

Join Date:
May 2008
Posts:
74
Plugin Contributions:
0

Re: Security error after upgrade to PHP5

barco57:

Set the permissions on the includes/configure.php to 444

That doesn't seem to help. Do you know of anything else to try?

Edit: I should add that the CSS is no longer being applied to the store as well. Gah.

23 Jan 2009, 11:23 PM
#4
Kim avatar

Kim

Obaa-san

Join Date:
Jun 2003
Location:
West Coast, North America
Posts:
26,668
Plugin Contributions:
0

Re: Security error after upgrade to PHP5

What version of Zen Cart?

Please do not PM for support issues: a private solution doesn't benefit the community.

Be careful with unsolicited advice via email or PM - Make sure the person you are talking to is a reliable source.

23 Jan 2009, 11:26 PM
#5
mark_kidd avatar

mark_kidd

New Zenner

Join Date:
May 2008
Posts:
74
Plugin Contributions:
0

Re: Security error after upgrade to PHP5

Kim:

What version of Zen Cart?

1.3.8a - sorry not to have included that in the OP. I guess my heart rate is still a little high.

23 Jan 2009, 11:53 PM
#6
Kim avatar

Kim

Obaa-san

Join Date:
Jun 2003
Location:
West Coast, North America
Posts:
26,668
Plugin Contributions:
0

Re: Security error after upgrade to PHP5

Should we ask who the host is? Make sure you are the file owner too.

Please do not PM for support issues: a private solution doesn't benefit the community.

Be careful with unsolicited advice via email or PM - Make sure the person you are talking to is a reliable source.

23 Jan 2009, 11:54 PM
#7
mark_kidd avatar

mark_kidd

New Zenner

Join Date:
May 2008
Posts:
74
Plugin Contributions:
0

Re: Security error after upgrade to PHP5

I have been able to get CSS working right by some blunt surgery to /includes/.htaccess, but I'm still puzzled over the permissions warning.

edit: This is running on a VPS, so I suppose I only have myself to blame if there is a configuration mistake with the server. I do however have a server administration package so I can get some help if need be.

In answer to your second question, I'll see if a chown to my cpanel/ftp login and then a permissions change will make a difference.

edit2: Chowning and reapplying permissions doesn't seem to make a difference.

23 Jan 2009, 11:58 PM
#8
mark_kidd avatar

mark_kidd

New Zenner

Join Date:
May 2008
Posts:
74
Plugin Contributions:
0

Re: Security error after upgrade to PHP5

ls -l configure.php

-rw-r--r-- 1 (my user name) (my user name) 3180 Sep 7 16:28 configure.php

24 Jan 2009, 4:58 AM
#9
website_rob avatar

website_rob

Inactive

Join Date:
Oct 2006
Location:
Alberta, Canada
Posts:
4,572
Plugin Contributions:
0

Re: Security error after upgrade to PHP5

Setting permissions to 444 will solve the problem but you cannot use your FTP program to make the change. Try using your Hosting Control Panel.

The learning is in the doing.

Potent Products

24 Jan 2009, 5:30 AM
#10
stuff4toys avatar

stuff4toys

Totally Zenned

Join Date:
May 2007
Location:
SW Florida
Posts:
1,062
Plugin Contributions:
1

Re: Security error after upgrade to PHP5

YUP, I did the same thing.

If you have cPanel, go to the File Manager and "Change Permissions" to 444

That'll fix it.
JOhn ><>

Newest Site: ChargerPros - Stuff4Toys