Forums / Installing on a Linux/Unix Server / install zen-cart 1.38 on server with suse 8.2 and php 4.3.1 installed

install zen-cart 1.38 on server with suse 8.2 and php 4.3.1 installed

Locked

Started by wolf11 on 4 Feb 2009, 1:53 AM · Views: 3,126

Results 1 to 2 of 2
This thread is locked. New replies are disabled.
4 Feb 2009, 1:53 AM
#1
wolf11 avatar

wolf11

New Zenner

Join Date:
Feb 2009
Posts:
1
Plugin Contributions:
0

install zen-cart 1.38 on server with suse 8.2 and php 4.3.1 installed

workaround:
suse 8.2 has php 4.3.1 installed and you'll get an error on installing zn_1.38 "update to php >=4.3.2"

go to this uri:
ftp://ftp.rediris.es/volumes/vol1/ftp.suse.com/pub/people/poeml/mod_php4/8.2-i386/

and download
mod_php4-4.3.3-4.i586.rpm
mod_php4-core-4.3.3-4.i586.rpm
mod_php4-devel-4.3.3-4.i586.rpm

copy these files to an unused directory (e.g. www/srv/htdocs/your_account/files/temp) on your server
login as root change to this directory and type

rpm -U --test *.rpm

if you haven't installed mhash, you'll get this error:

error: failed dependencies:
libmhash.so.2 is needed by mod_php4-4.3.3-4
libmhash.so.2 is needed by mod_php4-core-4.3.3-4

k, let's get mhash 0.8.17 from sourceforgenet:
http://sourceforge.net/project/downloading.php?group_id=4286&use_mirror=mesh&filename=mhash-0.8.17.tar.gz&20740289
unpack the tarball to an directory change to this and type (as r00t):
./configure --prefix=/usr
make
make install

do another:
rpm -U --test *.rpm
and you'll get the same error cause:

sometimes RPM is just plain stupid. You see, only software that was installed with RPM gets added into the database of installed software. This means that if you've used some other method for installing a certain program, RPM doesn't know the program exists on your system. In this case RPM complains about failed dependencies even when the needed program does exist on your system and there are no failed dependencies!

If you know the needed files are there and RPM is just being stupid, you can ignore the dependencies. Use the --nodeps option if you want to tell RPM not to check any dependencies before installing the package:

rpm -i software-2.3.4.rpm --nodeps

kkk, lets do it:

look in usr/lib and you'll find the files @libmhash.so.2 (the symbolic link to libmhash.so.2.0.0
if so, type (in the directory where you saved the 3 mod_php4_* files e.g. www/srv/htdocs/your_account/files/temp) ):

rpm -Uvh mod_php4-4.3.3-4.i586.rpm mod_php4-core-4.3.3-4.i586.rpm mod_php4-devel-4.3.3-4.i586.rpm

now you are able to install zen-cart 1.38
youl'll get 2 errors:

first error:

your_install_directory/includes/classes/db/mysql/query_factory.php/
go to zeile 47
change:
$sql = "SET NAMES utf8";
to:
$sql = "SET NAMES utf-8";

second error:
goto zeile 623 in:
your_install_directory/zc_install/sql/mysql_multilingual_2.sql
change:

ENGINE=MyISAM DEFAULT CHARSET=utf8 AUTO_INCREMENT=144 ;

to:
TYPE=MyISAM AUTO_INCREMENT=144 ;
(this is a workaround,isry, didn't found the syntax "DEFAULT CHARSET=utf8"for php4).

have fun

gruss
wolf
(sry for my bad english)

4 Feb 2009, 8:33 AM
#2
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,515
Plugin Contributions:
176

Re: install zen-cart 1.38 on server with suse 8.2 and php 4.3.1 installed

Keep in mind that PHP 4 is now obsolete and no longer supported.
Future versions of Zen Cart (v2.0 and newer) will only support PHP 5.2 and newer.

.
Zen Cart - putting the dream of business ownership within reach of anyone!
Donate to: DrByte directly or to the Zen Cart team as a whole

Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.