Zen Cart Logo
Forums / General Questions / ** BIG PROBLEM! ** 1034 Incorrect key file for table

** BIG PROBLEM! ** 1034 Incorrect key file for table

Locked

Views: 2,506

Results 1 to 6 of 6
This thread is locked. New replies are disabled.
19 Mar 2009, 12:20 PM
#1
robertkramers avatar

robertkramers

New Zenner

Join Date:
Jun 2008
Posts:
2
Plugin Contributions:
0

** BIG PROBLEM! ** 1034 Incorrect key file for table

I have had Zencart for a number of years now and it never gave me any issues. My hosting provider by the looks has upgraded MySQL and now i get this error

"1034 Incorrect key file for table 'zen_customers'; try to repair it" even when loggin into admin panel.

I have tried repairing this in PHP my admin, but i dont get any luck at all. It returns and says

Table Op Msg_type Msg_text
planes_zc1.zen_customers repair Error Incorrect key file for table 'zen_customers'; try ...
planes_zc1.zen_customers repair error Corrupt

I have also tried REPAIR TABLE zen_customers USE_FRM;, and that returns and says "Failed reparing incompatible .FRM file".

I have tried almost everything, and this error really does screw the whole website.

Any help is greatly appreciated.

Cheers

19 Mar 2009, 2:18 PM
#2
Kim avatar

Kim

Obaa-san

Join Date:
Jun 2003
Location:
West Coast, North America
Posts:
26,627
Plugin Contributions:
0

Re: ** BIG PROBLEM! ** 1034 Incorrect key file for table

Might scroll down the page and read the Similar threads for solutions.

19 Mar 2009, 2:47 PM
#3
tshooters avatar

tshooters

Totally Zenned

Join Date:
Dec 2005
Posts:
1,037
Plugin Contributions:
2

Re: ** BIG PROBLEM! ** 1034 Incorrect key file for table

Had this problem the other day when PHP was upgraded on the server. The data center either restored or rebuilt the table from
the backup that was done previous to the upgrade. Contact your host/put in a trouble ticket.

24 Mar 2009, 2:35 PM
#4
effesus avatar

effesus

New Zenner

Join Date:
May 2008
Posts:
3
Plugin Contributions:
0

Re: ** BIG PROBLEM! ** 1034 Incorrect key file for table

I got same problem, I contacted my hosting and got fixed in 10 minutes

28 Mar 2009, 10:54 AM
#5
robertkramers avatar

robertkramers

New Zenner

Join Date:
Jun 2008
Posts:
2
Plugin Contributions:
0

Re: ** BIG PROBLEM! ** 1034 Incorrect key file for table

Thanks very much for your help! Yes contacted my host and fixed in 5 mins!

28 Mar 2009, 11:00 AM
#6
schoolboy avatar

schoolboy

Totally Zenned

Join Date:
Jun 2005
Location:
Cumbria, UK
Posts:
10,327
Plugin Contributions:
0

Re: ** BIG PROBLEM! ** 1034 Incorrect key file for table

Always good to hear stories about hosts that are (relatively) quick to fix problems...

... points clearly to the need to make sure you're hosting with a good company BEFORE you sign up with them.