Forums / Installing on a Linux/Unix Server / Damned if I do, damned if I don't

Damned if I do, damned if I don't

Locked

Views: 1,275

Results 1 to 6 of 6
This thread is locked. New replies are disabled.
24 Mar 2009, 9:27 PM
#1
plumloopy avatar

plumloopy

New Zenner

Join Date:
Apr 2006
Posts:
66
Plugin Contributions:
0

Damned if I do, damned if I don't

I recently upgraded my Apache on my dedicated server.

I have four Zen installations for four domains. Two are more recent and two are older, 1.301 & 1.27. The newer installs work fine after I CHMOD'ed my config files to 444 and they're humming with PHP5. The older ones won't work with either PHP5 or PHP4 for seemingly entirely different reasons.

Before you simply suggest that I upgrade, I expect upgrades would take me several days because when I originally designed these carts, I didn't follow the rules for customization. For my time, I would not be paid either.

When I enable PHP4, I get database errors like my Config files are wrong. When I enable PHP5 I get the "Fatal error: Call to a member function Execute() on a non-object in /home/tabletop/public_html/shop/includes/functions/sessions.php on line 61" error but the cart mostly works. This says to me that my MySQL data in config is just fine.

I'm TOTALLY cool with just running PHP4 for now - but the carts are unusable ad my config MySQL stuff looks fine! What else could cause those DB errors?

PL

24 Mar 2009, 9:36 PM
#2
plumloopy avatar

plumloopy

New Zenner

Join Date:
Apr 2006
Posts:
66
Plugin Contributions:
0

Re: Damned if I do, damned if I don't

UPDATE: 1.27 cart doesn't seem to work under either circumstance. I get a 500 Internal Server Error either way.

24 Mar 2009, 10:09 PM
#3
plumloopy avatar

plumloopy

New Zenner

Join Date:
Apr 2006
Posts:
66
Plugin Contributions:
0

Re: Damned if I do, damned if I don't

I created a test install of 1.301 in another directory and this is the result of the system inspection. Please note "PHP API Mode = cgi" and "MySQL Version = Unknown." According to my cpanel, MySQL is version 4.1.22-standard:

Webserver = Apache/1.3.41 (Unix) mod_log_bytes/1.2 mod_bwlimited/1.4 mod_ssl/2.8.31 OpenSSL/0.9.7a
HTTP Host = https://www.thetabletop.com
Path_Translated = /home/tabletop/public_html/testinstall/zc_install/index.php(SCRIPT_FILENAME)
Server Free Disk Space = 51.85 GB
PHP O/S = Linux
PHP API Mode = cgi Click here for more info
PHP Max Execution Time per page = 30
Register Globals = OFF
MySQL Support = ON
MySQL Version = Unknown Click here for more info
PHP Version = 4.4.9
PHP Safe Mode = OFF
PHP open_basedir restrictions =
PHP Sessions Support = ON
PHP Session.AutoStart = OFF
PHP session.use_trans_sid = OFF
Suggested SQL Cache Folder = /home/tabletop/public_html/testinstall/cache
PHP magic_quotes_runtime setting = OFF
PHP GD Support = ON
GD Version = GD bundled (2.0.28 compatible)
PHP ZLIB Compression Support = ON
PHP OpenSSL Support = ON
PHP cURL Support = ON
PHP Upload Support = ON upload_max_filesize=2M; post_max_size=8M
PHP Upload TMP dir =
PHP XML Support = ON
PHP FTP Support = ON

View PHPINFO for your server

24 Mar 2009, 11:59 PM
#4
yellow1912 avatar

yellow1912

Totally Zenned

Join Date:
Oct 2006
Posts:
5,422
Plugin Contributions:
0

Re: Damned if I do, damned if I don't

If you get 500 error on a php running as cgi server, usually the problem lies in folder/file permission. For example, general setting requirement is: 644 for files and 755 for folders.

I no longer provide installation support on forum for all my modules. However, if there are real bugs with the modules please feel free to contact me

25 Mar 2009, 12:04 AM
#5
kobra avatar

kobra

Black Belt

Join Date:
Aug 2005
Location:
Arizona
Posts:
31,500
Plugin Contributions:
4

Re: Damned if I do, damned if I don't

UPDATE: 1.27 cart doesn't seem to work under either circumstance. I get a 500 Internal Server Error either way.
Are you also using SUExec & phpSUExec??

Try renaming your .htaccess file or preserve locally and delet on the server

Zen-Venom Get Bitten

25 Mar 2009, 1:44 AM
#6
plumloopy avatar

plumloopy

New Zenner

Join Date:
Apr 2006
Posts:
66
Plugin Contributions:
0

Re: Damned if I do, damned if I don't

Yes - you were right. It was a permissions issue for the 2.7. Either my previous setup was tolerant of my permissions (I may have 777'd everything when I set it up three years ago) OR permissions got changed when I updated apache. I tend to think the latter because I had to change at least one file's permission on every cart!

Thanks!

PL