Forums / General Questions / bad luck today... 403 forbidden error

bad luck today... 403 forbidden error

Locked

Views: 1,827

Results 1 to 5 of 5
This thread is locked. New replies are disabled.
1 Apr 2009, 2:57 AM
#1
customk1 avatar

customk1

Zen Follower

Join Date:
Mar 2009
Location:
Cornelius, NC
Posts:
334
Plugin Contributions:
0

bad luck today... 403 forbidden error

well, crap. :frusty:

so, i was in my cpanel file manager, when my computer lagged a bit, and a single click became a drag and click or something of the like... needless to say, my public_html folder got into my mail folder. i moved it right back, but now when i try to go to my page in any way shape or form (admin, subfolders whatever) i get:

Forbidden
You don't have permission to access / on this server.

Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.
Apache/1.3.41 Server at https://www.customk9design.com Port 80

my permissions on the public_html are 750, and 755 on catalogzen

here is the site:
https://www.customk9design.com/catalogzen

"Be the Change you wish to see in the World..." -Gandhi

1 Apr 2009, 3:10 AM
#2
kobra avatar

kobra

Black Belt

Join Date:
Aug 2005
Location:
Arizona
Posts:
31,500
Plugin Contributions:
4

Re: bad luck today... 403 forbidden error

If you have filezilla - connect and select from the top menu

view > remote list view > select/check > owner group

Group should be "99" for public_html which is owned by Apache(nobody)

If not, you will have to have your host reset(chown) the folder

Zen-Venom Get Bitten

1 Apr 2009, 3:19 AM
#3
customk1 avatar

customk1

Zen Follower

Join Date:
Mar 2009
Location:
Cornelius, NC
Posts:
334
Plugin Contributions:
0

Re: bad luck today... 403 forbidden error

kobra, i do have filezilla... and i did just backup everything to my hd, just in case... so i can breathe a little better.. (i had "most" everything already but still....)

im not seeing the commands in filezilla youre describing though...
im using 3.2.3.1

in view, i have:
refresh
filename filters
directory comparison
syncronised browsing
X filelist status bars
X quickconnect bar
X message log
X local directory tree
X remote directory tree
X transfer que

? im sure im missing something obvious...

"Be the Change you wish to see in the World..." -Gandhi

1 Apr 2009, 5:49 AM
#5
customk1 avatar

customk1

Zen Follower

Join Date:
Mar 2009
Location:
Cornelius, NC
Posts:
334
Plugin Contributions:
0

Re: bad luck today... 403 forbidden error

kobra,

after your post, i started doing some more digging, thanks to you pointing me in the direction of permission settings etc...

i found this post on a filezilla site:
"At a minimum, the public permissions need to be set to 4, otherwise no one can view your pages and images. You do not need write permissions for public or group. That could allow hackers to replace your files.

The default permissions typically are:

644 - images
644 - html scripts
755 - directories"

since my public_html had been set to 750, i changed it back to 755 (i ASSSUME thats what it was before?)

anyways, that did the trick, thanks for your help, as always...
:clap::clap:

"Be the Change you wish to see in the World..." -Gandhi