Zen Cart Logo
Forums / General Questions / trying to find what causing sudden "Internal Server Error" messages

trying to find what causing sudden "Internal Server Error" messages

Locked

Views: 1,352

Results 1 to 6 of 6
This thread is locked. New replies are disabled.
11 Apr 2009, 7:26 AM
#1
artycles avatar

artycles

New Zenner

Join Date:
Sep 2006
Location:
Loch Victoria Australia
Posts:
45
Plugin Contributions:
0

trying to find what causing sudden "Internal Server Error" messages

Apologies in advance if I'm doubling up, I've done quite a lot of searching and can't find any references to this problem.

Firstly - I'm running 1.3.8
It's been running fine I haven't done anything major in ages
The only changes I've made recently have been to add some attributes and apply them to a couple of products. Before logging off etc, I checked that they were working etc and logged out (and back in) to make sure they were still ok.

Went to do some more alterations to products on Thursday and am now receiving the message I've posted below

Obviously some file has become corrupt or something.
I've checked the error log on my cpanel and it gives info like date and time, IP address of user, and "file does not exist" and then the files (I've only put in the last bits of the address) ...public_html/robots.txt
......public_html/404.shtml, .....public_html/500shtml etc.

My question is how do I go about finding out which files are corrupt or do I have to do a reload of the last backup?

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, [email protected] and inform them of the time the error occurred, and anything you might have done that may have caused the error.
More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

11 Apr 2009, 7:46 AM
#3
artycles avatar

artycles

New Zenner

Join Date:
Sep 2006
Location:
Loch Victoria Australia
Posts:
45
Plugin Contributions:
0

Re: trying to find what causing sudden "Internal Server Error" messages

Thanks for your speedy reply Dr Byte, I did read this yesterday, but as my messages were different I didn't think it applied to this instance. When it happened on Thurs. I emailed my web host to ask if there had been any changes etc, and he thought it was Zen Cart

this was his reply


Sorry that I can't shed much light on this problem of yours. The Internal Server Error happens when there is a problem with a file that does not allow the combination of database and other files to "gell".

The error log is to be found in your cPanel but currently has no entries. It usually makes an entry because a file that it looks for, is missing, so that doesn't seem to be an issue. Most likely, a line of code in an important file has been changed or corrupted

Not sure which way to go - see if reloading my Zen Cart? or doing a backup?

11 Apr 2009, 8:22 AM
#4
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: trying to find what causing sudden "Internal Server Error" messages

artycles:

Not sure which way to go - see if reloading my Zen Cart? or doing a backup?
Reloading is unlikely to make any difference other than wipe out your product data and thus mask the real problem.

Your host is only partly correct in his response. He's not wrong, he's just incomplete.

As I said in the article I linked to, it's likely a result of certain characters or phrases you've used in your product description content which are forbidden words according to your hosting company's general server security. And, since when you "submit" any edits to your product page, the description is also submitted and subjected to parsing of the content you posted. And, when that flags a forbidden-content rule, the server throws a general "500 internal server error".
That security system is called mod_security.
The very general error is displayed because if it was a hacker submitting the forbidden content, you wouldn't want them to know exactly why the problem occurred, or else they'd find specific ways around it.
I'm not surprised that it doesn't show in the server logs... in many cases it would, but sometimes mod_security violations don't show in the log that "you" get to see, but will show in the logs that the host can see, related to mod_security matters.

Anyway, that's the long way of saying ... did you even try what I suggested in the post I referenced?

11 Apr 2009, 9:03 AM
#5
artycles avatar

artycles

New Zenner

Join Date:
Sep 2006
Location:
Loch Victoria Australia
Posts:
45
Plugin Contributions:
0

Re: trying to find what causing sudden "Internal Server Error" messages

I'm working my way through it Dr Byte. I'm not too cluey when it comes to all this sort of stuff, it takes me a while.
I just wanted to clarify the above stuff. I certainly hadn't discounted the link you gave me. Just a learning curve I'm going through. Thanks once again. I'll keep you posted.

Cheers.
K

11 Apr 2009, 9:26 AM
#6
artycles avatar

artycles

New Zenner

Join Date:
Sep 2006
Location:
Loch Victoria Australia
Posts:
45
Plugin Contributions:
0

Re: trying to find what causing sudden "Internal Server Error" messages

OK, Had a few abortive attempts and finally got it to work on the second phrase quoted in the thread.

Cheers,
Thanks for the help It's really appreciated

K:clap:.