Zen Cart Logo
Forums / General Questions / Urgent - Site down

Urgent - Site down

Locked

Views: 2,212

Results 1 to 16 of 16
This thread is locked. New replies are disabled.
14 Apr 2009, 11:46 PM
#1
pdxdoug avatar

pdxdoug

Zen Follower

Join Date:
Jan 2008
Location:
Portland, Oregon USA
Posts:
356
Plugin Contributions:
0

Urgent - Site down

I edited a define page, saved it and then when I try to access the site I get nothing, nada, zip. Can still log into the admin end and everything seems fine.

www.broadwayfloral.com
nav bar reads: http://www.broadwayfloral.com/index.php?main_page=

Looking at the page source in Firefox nothing loads at all.
The debug utility won;t work because nothings loaded.

Any help quickly would be immensely appreciated!

14 Apr 2009, 11:47 PM
#2
haredo avatar

haredo

Totally Zenned

Join Date:
Apr 2006
Location:
Texas
Posts:
6,180
Plugin Contributions:
0

Re: Urgent - Site down

Pd,
admin panel/ tools/ define page editor/ click in the drop drop to view the .php file to edit

  1. Was it the define_main_page.php???
14 Apr 2009, 11:53 PM
#3
kuroi avatar

kuroi

Totally Zenned

Join Date:
Apr 2006
Location:
London, UK
Posts:
10,475
Plugin Contributions:
11

Re: Urgent - Site down

I'm seeing a "500 Internal Server Error" reported. Check with your web host to whether they have made any changes to their security settings.

It's also possible that by editing the define page you inadvertently changed it's permissions to something unacceptable to your host's security approach (some server configurations don't like 777 on php files).

14 Apr 2009, 11:55 PM
#4
pdxdoug avatar

pdxdoug

Zen Follower

Join Date:
Jan 2008
Location:
Portland, Oregon USA
Posts:
356
Plugin Contributions:
0

Re: Urgent - Site down

No, it was the privacy page. Main page is fine.

15 Apr 2009, 12:01 AM
#5
pdxdoug avatar

pdxdoug

Zen Follower

Join Date:
Jan 2008
Location:
Portland, Oregon USA
Posts:
356
Plugin Contributions:
0

Re: Urgent - Site down

Kuroi,

I had changed permissions on the privacy page prior to editing and since it was going to be an extensive edit, I'd made a backup locally. Once the site went away, I restored the page from the backup.

What else would give a 500 internal server error? Other Zen sites on the same VPS are fine, so it's something that happened to this installation.

15 Apr 2009, 12:07 AM
#6
kuroi avatar

kuroi

Totally Zenned

Join Date:
Apr 2006
Location:
London, UK
Posts:
10,475
Plugin Contributions:
11

Re: Urgent - Site down

I doubt that the privacy page would cause this as the code for that shouldn't be invoked on the home page. I'm afraid I'm no expert on hosting, though there are a few folks in this forum who are and will hopefully happen along.

But in the meantime what does the hosting expert for whose services you're paying have to say?

15 Apr 2009, 12:14 AM
#7
pdxdoug avatar

pdxdoug

Zen Follower

Join Date:
Jan 2008
Location:
Portland, Oregon USA
Posts:
356
Plugin Contributions:
0

Re: Urgent - Site down

Error log shows the following:

[Tue Apr 14 17:10:12 2009] [error] [client 98.246.170.122] PHP Fatal error: Call to a member function Execute() on a non-object in /home/pdxbrdwy/public_html/includes/counter.php on line 23
[Tue Apr 14 17:10:12 2009] [error] [client 98.246.170.122] PHP Notice: Undefined variable: db in /home/pdxbrdwy/public_html/includes/counter.php on line 23
[Tue Apr 14 17:10:12 2009] [error] [client 98.246.170.122] PHP Notice: Use of undefined constant TABLE_COUNTER_HISTORY - assumed 'TABLE_COUNTER_HISTORY' in /home/pdxbrdwy/public_html/includes/counter.php on line 22
[Tue Apr 14 17:10:12 2009] [error] [client 98.246.170.122] PHP Warning: dir(includes/auto_loaders) [<a href='function.dir'>function.dir</a>]: failed to open dir: No such file or directory in /home/pdxbrdwy/public_html/includes/initsystem.php on line 22
[Tue Apr 14 17:10:12 2009] [error] [client 98.246.170.122] PHP Warning: include() [<a href='function.include'>function.include</a>]: Failed opening 'includes/auto_loaders/config.core.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/pdxbrdwy/public_html/includes/initsystem.php on line 21
[Tue Apr 14 17:10:12 2009] [error] [client 98.246.170.122] PHP Warning: include(includes/auto_loaders/config.core.php) [<a href='function.include'>function.include</a>]: failed to open stream: No such file or directory in /home/pdxbrdwy/public_html/includes/initsystem.php on line 21

Does this give a clue?

15 Apr 2009, 12:18 AM
#8
kuroi avatar

kuroi

Totally Zenned

Join Date:
Apr 2006
Location:
London, UK
Posts:
10,475
Plugin Contributions:
11

Re: Urgent - Site down

Sort of. Those are completely random errors. All serious but with little in common. They suggest to me that there is a deeper level problem with loading the stuff needed to form a page. I've seen something like this once before and am racking my creaking brains to remember the underlying cause.

15 Apr 2009, 12:21 AM
#9
website_rob avatar

website_rob

Inactive

Join Date:
Oct 2006
Location:
Alberta, Canada
Posts:
4,572
Plugin Contributions:
0

Re: Urgent - Site down

The error msg. you described indicates problems any / all of these areas:

  • incorrect permissions
  • incorrect coding
  • trying to access a file not within your hosting account

Are things back to normal?

15 Apr 2009, 12:26 AM
#10
mprough avatar

mprough

Totally Zenned

Join Date:
Nov 2007
Location:
Woodbine, Georgia, United States
Posts:
4,288
Plugin Contributions:
39

Re: Urgent - Site down

I know you said you didn't edit anything else.....

But....

Check your english.php for a line space at the bottom after the ?>

or any other language files you may have edited.

Thats what this looks like to me, especially because you can still use admin.

~Melanie

15 Apr 2009, 12:44 AM
#11
pdxdoug avatar

pdxdoug

Zen Follower

Join Date:
Jan 2008
Location:
Portland, Oregon USA
Posts:
356
Plugin Contributions:
0

Re: Urgent - Site down

I'm restoring the entire includes directory from a previous backup. Hopefully (fingers crossed).

Thanks.

Before I could finish this post, site came back ... so an edit I made somewhere was the problem. A lesson learned from a previous disaster - ALWAYS MAKE BACKUPS.

Thanks to all.

15 Apr 2009, 2:08 AM
#12
pdxdoug avatar

pdxdoug

Zen Follower

Join Date:
Jan 2008
Location:
Portland, Oregon USA
Posts:
356
Plugin Contributions:
0

Re: Urgent - Site down

It just goes on....

After restoring from includes, admin login doesn't work. Restored from backup admin directory and this is the error:
**
Warning**: require_once(includes/languages/english/header.php) [function.require-once]: failed to open stream: No such file or directory in /home/pdxbrdwy/public_html/admin/includes/languages/english.php on line 652

Fatal error: require_once() [function.require]: Failed opening required 'includes/languages/english/header.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/pdxbrdwy/public_html/admin/includes/languages/english.php on line 652

Line 652 in the admin/includes/language/english file refers to an ez_page define.

What the #@#&!! gives??

15 Apr 2009, 9:07 AM
#13
website_rob avatar

website_rob

Inactive

Join Date:
Oct 2006
Location:
Alberta, Canada
Posts:
4,572
Plugin Contributions:
0

Re: Urgent - Site down

There are times and for various reasons that an FTP upload goes bad.

Re-upload the "/admin/includes/languages/english/header.php" file as the error msg. is telling you it is not there; or only part of it got uploaded.

15 Apr 2009, 7:05 PM
#14
pdxdoug avatar

pdxdoug

Zen Follower

Join Date:
Jan 2008
Location:
Portland, Oregon USA
Posts:
356
Plugin Contributions:
0

Re: Urgent - Site down

Thanks Rob.

It turned out that the last backup copy was bad, so I went back to the next oldest and uploaded it. I keep telling my wife that there is a method to my madness and part of the madness is keeping various historical backups.

That did get both the admin and the cart back online. My guess is that this whole episode may have been due to some flakiness in my internet connection that affected more than just the files that I was editing.

Thanks to all for your advice. It's this community that makes a difference.

15 Apr 2009, 11:24 PM
#15
website_rob avatar

website_rob

Inactive

Join Date:
Oct 2006
Location:
Alberta, Canada
Posts:
4,572
Plugin Contributions:
0

Re: Urgent - Site down

pdxdoug:

Thanks Rob.

It turned out that the last backup copy was bad
Was it just the "header.php" backup that was bad or an entire directory?

FTP downloads very seldom have problems but they do happen. Probably best to download a backup of your Hosting account, which your Hoster should be providing within your Hosting Control Panel. That way you get "everything" in one file.

16 Apr 2009, 2:18 AM
#16
pdxdoug avatar

pdxdoug

Zen Follower

Join Date:
Jan 2008
Location:
Portland, Oregon USA
Posts:
356
Plugin Contributions:
0

Re: Urgent - Site down

Initially I restored the entire includes directory from a 3/24 backup and that fixed the cart when I viewed it within the backend. When I exited the browser and went to log back into the backend, that's when the last posted error occured. The cart itself functioned just fine, now I just couldn't log back into the backend.

So I restored the admin directory from the same 3/24 backup and ended up with the same error when trying to log into the back end.

I then restored only the admin/includes/languages/english.php file from a 2/21 backup and finally could back in log.

Today I made and archived an entire cart backup before resuming my changes.