Zen Cart Logo
Forums / Setting Up Categories, Products, Attributes / Downloads - Don't Forget Apache Settings

Downloads - Don't Forget Apache Settings

Sticky Locked

Views: 25,360

Results 1 to 5 of 5
This thread is locked. New replies are disabled.
1 Mar 2005, 11:18 PM
#1
kosuke avatar

kosuke

New Zenner

Join Date:
Jun 2004
Posts:
15
Plugin Contributions:
0

Downloads - Don't Forget Apache Settings

I've just finished configuring my zen-cart (ver 1.2.2) for downloads. I read the FAQ on it, and read a lengthy post about it in this forum. Both helped, but I still got stuck. Here's how I fixed it. Just want to pass this on and possibly save a few gray hairs for someone.

Everything set up fine per the FAQ. Then I tested it with an order. Got to the final screen and everything was processed, and there at the bottom of the page was my download link. But when I clicked it, I got "Internal Server Error". Sounds like an apache problem to me ......

I run my own server, so tinkering around with apache was no problem. I try to run a fairly secure and restricted server, and it was one of these settings I must of made earlier that was hanging me up. The web home for zen-cart resided in /home/mydomain/www, and I had Apache set up to ignore OPTIONS for anything in /home/*/www. Well, zen-cart needed those OPTIONS.

So in httpd.conf, I added the following to the <VirtualHost> section ...

<Directory "/home/mydomain/www/download">
   AllowOverride Options
  </Directory>
  <Directory "/home/mydomain/www/pub"
  AllowOverride Options
</Directory>

Restart apache and presto, it all worked fine.

HTH someone.

Kevin

28 Jun 2005, 2:01 PM
#2
vnardone avatar

vnardone

New Zenner

Join Date:
Jun 2005
Posts:
10
Plugin Contributions:
0

Re: Downloads - Don't Forget Apache Settings

what if you are not running your own server?

and will my isp do it for me?

5 Oct 2005, 6:06 PM
#3
essentialparadox avatar

essentialparadox

Zen Follower

Join Date:
May 2005
Posts:
89
Plugin Contributions:
0

Re: Downloads - Don't Forget Apache Settings

vnardone - you can try asking them. But it depends what kind of policies they have. I've known some hosting companies are happy to make changes, but some have a strict policy against changing server files (for some reason).

Otherwise I don't know what to suggest. Maybe turning off Redirect will fix it.

Configuration/Attribute Settings

**Download by Redirect
Please make any necessary changes

Download by Redirect
Use browser redirection for download. Disable on non-Unix systems.

Note: Set /pub to 777 when redirect is true

true
false**

If you're not actually having any problems and are just asking hypothetically, I wouldn't worry too much. I don't think this is a common problem.

-Luke

10 Nov 2005, 5:53 PM
#4
IDEASLady avatar

IDEASLady

Totally Zenned

Join Date:
Aug 2005
Location:
Trujillo Alto, Puerto Rico
Posts:
1,440
Plugin Contributions:
3

Re: Downloads - Don't Forget Apache Settings

This is not working for me... ::frust

What file do I need to configure? Can I do the Apache settings in cPanel? going to "Apache Handlers"? :huh:

I have the latest version of ZC. Here is the error:

**Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, [email protected] and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.**

11 Nov 2005, 5:42 AM
#5
ajeh avatar

ajeh

Oba-san

Join Date:
Sep 2003
Location:
Ohio
Posts:
62,757
Plugin Contributions:
1

Re: Downloads - Don't Forget Apache Settings

That is what I meant by your server is not configured with these rights that are in the .htaccess files

I am not an expert on these, unfortunately ...