Zen Cart Logo
Forums / General Questions / trouble after host died

trouble after host died

Locked

Views: 973

Results 1 to 9 of 9
This thread is locked. New replies are disabled.
6 Jun 2009, 11:04 PM
#1
darkangel avatar

darkangel

Totally Zenned

Join Date:
Oct 2007
Location:
Emporia, Kansas
Posts:
1,729
Plugin Contributions:
0

trouble after host died

not sure if this is the right spot but these errors come up when trying to access the admin section of the store

I was able to get the main store up afer her server died then moved her to another server---changing name of database/ dbuser/dbpassword...her host had a high old time with changes I wanna shoot him...lol

these are the errors that I can not figure out where to fix what files...

Warning: session_start() [function.session-start]: Cannot send session cookie - headers already sent by (output started at /home/XXX/public_html/store/admin/includes/classes/table_block.php:181) in /home/XXX/public_html/store/includes/functions/sessions.php on line 108

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/XXX/public_html/store/admin/includes/classes/table_block.php:181) in /home/XXX/public_html/store/includes/functions/sessions.php on line 108

Warning: require(DIR_FS_CATALOG_LANGUAGESenglish/meta_tags.php) [function.require]: failed to open stream: No such file or directory in /home/XXX/public_html/store/admin/includes/languages/english.php on line 50

Warning: require(DIR_FS_CATALOG_LANGUAGESenglish/meta_tags.php) [function.require]: failed to open stream: No such file or directory in /home/XXX/public_html/store/admin/includes/languages/english.php on line 50

Fatal error: require() [function.require]: Failed opening required 'DIR_FS_CATALOG_LANGUAGESenglish/meta_tags.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/XXX/public_html/store/admin/includes/languages/english.php on line 50

6 Jun 2009, 11:33 PM
#2
tony_sar avatar

tony_sar

Totally Zenned

Join Date:
Jul 2006
Location:
Montreal, Canada
Posts:
2,276
Plugin Contributions:
0

Re: trouble after host died

use fix catch key to fix first two warning messages

http://www.zen-cart.com/index.php?main_page=product_contrib_info&products_id=82

and assumeing other warnings indicating missing file in this case , meta_tags.php

located under Includes / english folder

7 Jun 2009, 12:46 AM
#3
darkangel avatar

darkangel

Totally Zenned

Join Date:
Oct 2007
Location:
Emporia, Kansas
Posts:
1,729
Plugin Contributions:
0

Re: trouble after host died

thanks sweety, I will use that little item and as for the other problem of it claiming the file is not in there...I uploaded a fresh one and it still claims that it is not in the includes folder.

now mind you, it says it is looking in the admin/includes directory NOT the includes directory

ideas anyone??

7 Jun 2009, 2:39 AM
#4
tony_sar avatar

tony_sar

Totally Zenned

Join Date:
Jul 2006
Location:
Montreal, Canada
Posts:
2,276
Plugin Contributions:
0

Re: trouble after host died

take a look at your admin / includes / configure.php and make sure everything looks ok
warning is outputting define text .. and not path to file , it suggest that there is something missing in your configure.php file . original define should look like this ..

define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/');

7 Jun 2009, 2:48 AM
#5
darkangel avatar

darkangel

Totally Zenned

Join Date:
Oct 2007
Location:
Emporia, Kansas
Posts:
1,729
Plugin Contributions:
0

Re: trouble after host died

tony_sar you are so right

I guess the host just plopped in the config file from includes to there to so I fixed it.

there were also a lot of files that had extra spaces after the ?> at the bottom that needed to be taken out...once that was done the sessions error left too for the session key fixer did not work...lol

sheesh this stuff makes me jump thru hoops but I still like this store software....

now if oly it could be made to be more merchant friendly---for more than 1 merchant and letting them get info about their sales and such:clap:

7 Jun 2009, 2:46 PM
#7
darkangel avatar

darkangel

Totally Zenned

Join Date:
Oct 2007
Location:
Emporia, Kansas
Posts:
1,729
Plugin Contributions:
0

Re: trouble after host died

Thanks DrByte,

That would have been very helpful had the host told her what he was going to do. Unfortunately for her his site went down, and he just moved her files ---did a few changes including directory nams and database information....then told her what he did. Not a great host in my book but I finally got her store back to operation so she can continue changing the looks.

Fortunately she is still in the setting things up phase with only 2 items in her store for testing the works...but she would have lost all her things she had already changed had we had to reinstall the software.

With everyones help here I keep my store and now hers in behaving order. I just had to go to each and every file in the error message to delete the added spaces after the ?> she still does't know how they got the added spaces...lol They were files i the admin/includes and the includes/ directories that she did not even open.

7 Jun 2009, 5:31 PM
#8
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: trouble after host died

DarkAngel:

I just had to go to each and every file in the error message to delete the added spaces after the ?> she still does't know how they got the added spaces...lol They were files i the admin/includes and the includes/ directories that she did not even open.
That can happen if your FTP program changes the line-endings on the files either during download or upload (or both).
If you believe there are multiple files damaged by line-ending problems (you'll see them as double-spaced when you open them), I recommend replacing those files with good clean originals. Compare them with a tool like WinMerge first to be sure no customizations have been made, and then upload the clean version. That will make life easier when it comes time to upgrade or to install addons that touch existing files, etc.

7 Jun 2009, 7:38 PM
#9
darkangel avatar

darkangel

Totally Zenned

Join Date:
Oct 2007
Location:
Emporia, Kansas
Posts:
1,729
Plugin Contributions:
0

Re: trouble after host died

that is great to knw and thanks...there were some of those that i took the extra empty lines out of, that were doublespaced docs.

some on the otherhand were normal looking. I think I got them all but will keep my eye out and will do that when I put them back.