Zen Cart Logo
Forums / Addon Shipping Modules / Fedex Shipping Module error 1054 only when customore is logged in

Fedex Shipping Module error 1054 only when customore is logged in

Locked

Views: 1,262

Results 1 to 4 of 4
This thread is locked. New replies are disabled.
14 Jun 2009, 2:09 AM
#1
palmyrapantry avatar

palmyrapantry

New Zenner

Join Date:
Jun 2009
Posts:
2
Plugin Contributions:
0

Fedex Shipping Module error 1054 only when customore is logged in

Hello,

This is my first post, so I hope I am posting in the right place.

I have installed the Fedex module on my site . When I test it without logging into the store, everything works fine. However, if I log into a customer account, and then try to either estimate shipping or checkout, I get the following error message.

1054 Unknown column 'products_length' in 'field list'
in:
[SELECT products_length, products_width, products_height, products_ready_to_ship, product_is_always_free_shipping FROM zen_products WHERE products_id = 4 LIMIT 1]

If I turn off the two fedex modules, and then log in, I don't encounter any problems. Also, I am not a programmer so I don't understand what the error message even means. From looking in the forums I assume it has something to do with MySql. I chose zencart because I read it was the easiest one, I hope I'm not in over my head. Does anyone know how I can fix this problem?

When I go to Tools>Server/Version info it says my version appears to be current, and I am running on MySQL 4.1.22-standard-log. I'm not really sure if that information is necessary. If you need more info let me know.

Any help is sincerely appreciated,
Sam

14 Jun 2009, 9:20 AM
#2
kobra avatar

kobra

Black Belt

Join Date:
Aug 2005
Location:
Arizona
Posts:
31,500
Plugin Contributions:
4

Re: Fedex Shipping Module error 1054 only when customore is logged in

Check the similar posts at the bottom of this thread

14 Jun 2009, 5:40 PM
#3
palmyrapantry avatar

palmyrapantry

New Zenner

Join Date:
Jun 2009
Posts:
2
Plugin Contributions:
0

Re: Fedex Shipping Module error 1054 only when customore is logged in

I looked at all the posts at the bottom, but those don't seem to relate directly to this situation.

Why does the module work when nobody is logged in? Why does the module note work when customers are logged in?

Also, how do I fix the problem?

Thank you.