Zen Cart Logo
Forums / General Questions / Warning: I am able to write to the configuration file:

Warning: I am able to write to the configuration file:

Locked

Views: 1,184

Results 1 to 10 of 10
This thread is locked. New replies are disabled.
29 Jun 2009, 4:17 AM
#1
dpet102 avatar

dpet102

New Zenner

Join Date:
Mar 2009
Posts:
76
Plugin Contributions:
0

Warning: I am able to write to the configuration file:

Hey everyone,

I've been going through various threads regarding this topic, and I'm having an issue with this error message.

I got the infamous "red box" on my website (chmod 644). I sent an email to my hosting support to help me out with this (since I'm a virgin with hsphere), and they replied that this error had been fixed and so on.

I don't have any problems logging into my admin, but when I click on the "online catalogue" button (top right corner), I get this "HTTP 500 Internal Server Error".

I need to get this rectified ASAP, and my hosting support, well.... let's not go there.

Can anyone help me with this? What files and where would they be located in hsphere that I need to change?

Working 16 hour days is taking its toll, so please break it down for me.

Much appreciated :)

Dave

29 Jun 2009, 5:08 AM
#2
rjgonzalez avatar

rjgonzalez

Zen Follower

Join Date:
May 2008
Posts:
155
Plugin Contributions:
0

Re: Warning: I am able to write to the configuration file:

Whats d site address?

29 Jun 2009, 5:13 AM
#3
dpet102 avatar

dpet102

New Zenner

Join Date:
Mar 2009
Posts:
76
Plugin Contributions:
0

Re: Warning: I am able to write to the configuration file:

It's https://www.indigodecorative.com

I recently had another issue where the site doesn't even show up.

My web support mentioned that I have to restore files from the latest backup. This is getting more confusing as each day passes.

29 Jun 2009, 5:18 AM
#4
rjgonzalez avatar

rjgonzalez

Zen Follower

Join Date:
May 2008
Posts:
155
Plugin Contributions:
0

Re: Warning: I am able to write to the configuration file:

no error just a white page

29 Jun 2009, 5:20 AM
#5
rjgonzalez avatar

rjgonzalez

Zen Follower

Join Date:
May 2008
Posts:
155
Plugin Contributions:
0

Re: Warning: I am able to write to the configuration file:

make sure you have only one index.php no other index page with it

29 Jun 2009, 5:22 AM
#6
website_rob avatar

website_rob

Inactive

Join Date:
Oct 2006
Location:
Alberta, Canada
Posts:
4,572
Plugin Contributions:
0

Re: Warning: I am able to write to the configuration file:

As the problem seems to have been created by your Hoster, they would be the ones best able to correct.

If changing permissions creates a problem then use this other method; to remove the Big Red Error msg.

around line 24 of /includes/init_includes/init_header.php
define('WARN_CONFIG_WRITEABLE', 'true'); << change to false

Only do the above if you "know" the "configure.php" is set to 644.

29 Jun 2009, 5:31 AM
#7
website_rob avatar

website_rob

Inactive

Join Date:
Oct 2006
Location:
Alberta, Canada
Posts:
4,572
Plugin Contributions:
0

Re: Warning: I am able to write to the configuration file:

Should have said:

Only do the above if you "know" the "configure.php" is set to 444.

29 Jun 2009, 5:32 AM
#8
kiddo avatar

kiddo

Totally Zenned

Join Date:
Jul 2006
Location:
SF Bay Area
Posts:
837
Plugin Contributions:
1

Re: Warning: I am able to write to the configuration file:

you need to chmod 444 that config file.

If you don't have shell access, you probably have some kind of file management tool in your hosting control panel.

29 Jun 2009, 6:37 AM
#9
oseymour avatar

oseymour

New Zenner

Join Date:
Oct 2006
Posts:
33
Plugin Contributions:
0

Re: Warning: I am able to write to the configuration file:

if you are using dreamweaver or any other file management program just right click on the file on the remote server and click manage or edit permissions.

29 Jun 2009, 5:49 PM
#10
dpet102 avatar

dpet102

New Zenner

Join Date:
Mar 2009
Posts:
76
Plugin Contributions:
0

Re: Warning: I am able to write to the configuration file:

Hey everyone,

Thanks for the responses. There were other site issues that I was faced with after my original post, and after restoring a database, things seemed to be working smoother for some reason, and I'm not complaining lol.

It seems okay now, thank you once again.

Dave :smile: