Forums / General Questions / 403 error after changing name of admin folder

403 error after changing name of admin folder

Locked

Views: 1,677

Results 1 to 9 of 9
This thread is locked. New replies are disabled.
3 Jul 2009, 7:32 AM
#1
yz250 avatar

yz250

New Zenner

Join Date:
Dec 2008
Location:
Canberra, Australia
Posts:
83
Plugin Contributions:
0

403 error after changing name of admin folder

Hi, as per the email I received about site security I renamed the admin folder according to the instructions on this tutorial.

https://www.zen-cart.com/tutorials/index.php?article=33

When i tried to access my newly named admin folder I got a 403 forbidden access error. After playing around for a while i decided to change everything back to the way it was originally, however I am still getting the same error.

I cleared my explorer cache, but didnt help. Any suggestions will be appreciated.

3 Jul 2009, 11:25 AM
#2
kuroi avatar

kuroi

Totally Zenned

Join Date:
Apr 2006
Location:
London, UK
Posts:
10,475
Plugin Contributions:
11

Re: 403 error after changing name of admin folder

Did you change the admin/includes/configure.php file to tell your Zen Cart to where you have moved the page?

Is it possible that you changed it wrongly the first time, causing the initial 403 and forgot to put it back, or put it back wrong the second time?

Kuroi Web Design and Development | Twitter

(Questions answered in the forum only - so that any forum member can benefit - not by personal message)

5 Jul 2009, 2:33 AM
#3
yz250 avatar

yz250

New Zenner

Join Date:
Dec 2008
Location:
Canberra, Australia
Posts:
83
Plugin Contributions:
0

Re: 403 error after changing name of admin folder

Thats the only file I changes.

I opened admin/includes/configure.php and changed the 3 instances of admin to "xxxxx". Then I renamed the admin folder "xxxxx" and got the error. Refreshed the screen a few times couldnt get it to work and gave up. I renamed "xxxxx" to admin, same in config.php and still wont work. The screen says....

Forbidden
You don't have permission to access /store/admin on this server.

Any ideas?

6 Jul 2009, 2:18 AM
#4
yz250 avatar

yz250

New Zenner

Join Date:
Dec 2008
Location:
Canberra, Australia
Posts:
83
Plugin Contributions:
0

Re: 403 error after changing name of admin folder

I am still battling with this. I have checked the config file line for line with the original 1.38 file and its spot on. Does it matter what permission settings I have it on? I have tried to access admin on 777 and 444 but neither worked.

Could it be a server side issue? Or related to SSL? I have SSL on admin set to off at the moment.

6 Jul 2009, 4:20 AM
#5
Kim avatar

Kim

Obaa-san

Join Date:
Jun 2003
Location:
West Coast, North America
Posts:
26,668
Plugin Contributions:
0

Re: 403 error after changing name of admin folder

Are you sure there is a / (forward slash) in front and behind the renamed admin directory in your config file?

Please do not PM for support issues: a private solution doesn't benefit the community.

Be careful with unsolicited advice via email or PM - Make sure the person you are talking to is a reliable source.

6 Jul 2009, 9:06 AM
#6
yz250 avatar

yz250

New Zenner

Join Date:
Dec 2008
Location:
Canberra, Australia
Posts:
83
Plugin Contributions:
0

Re: 403 error after changing name of admin folder

Here are the lines I changed. Aside from this, the only thing I changed was to rename the hosted file on the server from admin to something different. Right now, that hosted folder has been renamed "admin", all in lowercase, matching the three instances of 'admin' that appear in the config file. My intention was to revert everything back the way it was when I couldnt get the renaming of the admin folder to work.

Lines 41 - 44 here

define('DIR_WS_ADMIN', '/store/admin/');
define('DIR_WS_CATALOG', '/store/');
define('DIR_WS_HTTPS_ADMIN', '/store/admin/');
define('DIR_WS_HTTPS_CATALOG', '/store/');

Lines 58 - 61

// * DIR_FS_* = Filesystem directories (local/physical)
//the following path is a COMPLETE path to your Zen Cart files. eg: /var/www/vhost/accountname/public_html/store/
define('DIR_FS_ADMIN', '/var/www/html/store/admin/');
define('DIR_FS_CATALOG', '/var/www/html/store/');

This was the only update I made, I didnt play with any other files. I have tried accessing the admin section from a number of different computers and that didnt work either. What on earth could it be?

7 Jul 2009, 2:53 AM
#7
yz250 avatar

yz250

New Zenner

Join Date:
Dec 2008
Location:
Canberra, Australia
Posts:
83
Plugin Contributions:
0

Re: 403 error after changing name of admin folder

Guys I desperately need help with this. I followed the instructions to the letter and it didnt work. I have 40 new items in stock that I need to add to my cart and obviously I cant at the moment. If no-one has any ideas what went wrong can someone please explain my reinstall options.

7 Jul 2009, 4:12 AM
#8
yz250 avatar

yz250

New Zenner

Join Date:
Dec 2008
Location:
Canberra, Australia
Posts:
83
Plugin Contributions:
0

Re: 403 error after changing name of admin folder

Fixed

I had the wrong CHMOD settings. 755 works, anything else doesnt.

7 Jul 2009, 6:40 AM
#9
kuroi avatar

kuroi

Totally Zenned

Join Date:
Apr 2006
Location:
London, UK
Posts:
10,475
Plugin Contributions:
11

Re: 403 error after changing name of admin folder

Glad you got it fixed. This sounds like a feature of how your web host has their security set up.

For others who have similar problems, which files or directories did you have to change to have 755 as their permission level.

Kuroi Web Design and Development | Twitter

(Questions answered in the forum only - so that any forum member can benefit - not by personal message)