Zen Cart Logo
Forums / Installing on a Windows Server / Unable to open store, admin works

Unable to open store, admin works

Locked

Views: 3,290

Results 1 to 12 of 12
This thread is locked. New replies are disabled.
1 Aug 2009, 2:54 PM
#1
rivercity avatar

rivercity

Zen Follower

Join Date:
Jul 2009
Location:
Arkansas
Posts:
178
Plugin Contributions:
0

Unable to open store, admin works

Hello, need a little help this morning, just installed latest ZC, install went smooth, can open the admin section without any problems. When I try to open the store, it opens the login page for the admin section again.

I'm using a dedicated IP address right now as my domain name needs to stay in use until I get this store open and ready to go. I am on a windows server and installed ZC in my wwwroot directory.

Can anyone point me to a forum link or give me an idea where to look for the problem? I've found several posts regarding the admin not working but can't find anything about the store not working.

Thanks for any help.

1 Aug 2009, 3:00 PM
#2
kuroi avatar

kuroi

Totally Zenned

Join Date:
Apr 2006
Location:
London, UK
Posts:
10,475
Plugin Contributions:
11

Re: Unable to open store, admin works

Sounds like a problem with your includes/configure.php file. I recommend checking that there are no references to the admin in there (there shouldn't be any).

1 Aug 2009, 3:06 PM
#3
rivercity avatar

rivercity

Zen Follower

Join Date:
Jul 2009
Location:
Arkansas
Posts:
178
Plugin Contributions:
0

Re: Unable to open store, admin works

Just checked it, don't see anything in it.

Thanks

1 Aug 2009, 3:09 PM
#4
kuroi avatar

kuroi

Totally Zenned

Join Date:
Apr 2006
Location:
London, UK
Posts:
10,475
Plugin Contributions:
11

Re: Unable to open store, admin works

Can you provide the IP address? so that we can see the behaviour.

1 Aug 2009, 3:11 PM
#5
rivercity avatar

rivercity

Zen Follower

Join Date:
Jul 2009
Location:
Arkansas
Posts:
178
Plugin Contributions:
0

Re: Unable to open store, admin works

Here's the IP:
216.151.167.51

Thanks for the help.

1 Aug 2009, 3:15 PM
#6
kuroi avatar

kuroi

Totally Zenned

Join Date:
Apr 2006
Location:
London, UK
Posts:
10,475
Plugin Contributions:
11

Re: Unable to open store, admin works

For me it didn't go to the admin login at first. Instead it resulted in a blank page. Only after I had gone to the admin login did it re-direct there when I left the admin bit off.

That's significant I'm sure, but I don't know how. It does hint that this might be server-related, in which case help might be a bit thin on the ground as you're using a Windows server.

But let's try something else. what happens if you edit the debug definition near the top of your includes/application_top.php file to be true.

1 Aug 2009, 3:21 PM
#7
rivercity avatar

rivercity

Zen Follower

Join Date:
Jul 2009
Location:
Arkansas
Posts:
178
Plugin Contributions:
0

Re: Unable to open store, admin works

Ok, made that change, I'm still going to the admin login here.

1 Aug 2009, 3:25 PM
#8
kuroi avatar

kuroi

Totally Zenned

Join Date:
Apr 2006
Location:
London, UK
Posts:
10,475
Plugin Contributions:
11

Re: Unable to open store, admin works

That would seem to point more strongly to an issue with how your web hosting is setup. If it had started to go into the catalogue, I would have expected to see debug statements being output and any attempt to redirect to your admin blocked by a error message.

This looks as though it's not even starting to go into the catalogue. Is it possible that your IP address is mapped directly to the admin directory?

1 Aug 2009, 3:40 PM
#9
rivercity avatar

rivercity

Zen Follower

Join Date:
Jul 2009
Location:
Arkansas
Posts:
178
Plugin Contributions:
0

Re: Unable to open store, admin works

Do you think it would be better to just switch over from the windows server?

1 Aug 2009, 3:45 PM
#10
kuroi avatar

kuroi

Totally Zenned

Join Date:
Apr 2006
Location:
London, UK
Posts:
10,475
Plugin Contributions:
11

Re: Unable to open store, admin works

Personally I'd never put an open source app on a Windows server. irrespective of what one thinks of the merits of Linux v Windows on a philosophical or technical level, there's just much more testing and feedback about their performance on Linux, leading to a more robust experience and less kinks.

That's a bit off topic, and I can't show causality from your server to the problem, but I'd say yes anyway.

1 Aug 2009, 3:53 PM
#11
rivercity avatar

rivercity

Zen Follower

Join Date:
Jul 2009
Location:
Arkansas
Posts:
178
Plugin Contributions:
0

Re: Unable to open store, admin works

Well, thanks for the help anyway, I think I'll just change it over to a linux server and start over. I've got another one on a linux server and it installed and worked right off the top.

Thanks again

1 Aug 2009, 3:57 PM
#12
kuroi avatar

kuroi

Totally Zenned

Join Date:
Apr 2006
Location:
London, UK
Posts:
10,475
Plugin Contributions:
11

Re: Unable to open store, admin works

Best of luck. Come back if you need more help.