Zen Cart Logo

Blank Main Page

Locked

Views: 1,625

Results 1 to 8 of 8
This thread is locked. New replies are disabled.
8 Aug 2009, 11:05 PM
#1
acehowell avatar

acehowell

New Zenner

Join Date:
Aug 2009
Posts:
3
Plugin Contributions:
0

Blank Main Page

No error message up for me just a blank main page, i can still login to the admin side, but when i try and go to the shop at http://www.dollysdairybar.com/shop it is just a blank page. I tried the debug utitlity and nothing showed up. Any help would be appreciated.

8 Aug 2009, 11:12 PM
#2
kuroi avatar

kuroi

Totally Zenned

Join Date:
Apr 2006
Location:
London, UK
Posts:
10,475
Plugin Contributions:
11

Re: Blank Main Page

Does nothing showed up mean no log file appeared, or that the log file was empty?

Are the any errors being reported in your web hosts error log?

8 Aug 2009, 11:28 PM
#3
acehowell avatar

acehowell

New Zenner

Join Date:
Aug 2009
Posts:
3
Plugin Contributions:
0

Re: Blank Main Page

Actually I couldnt even find where the log was supposed to be, i unzipped the file i download and placed it where it said, reloaded the main page and nothing, no error log generated, nothing showed up on webpage. Also when i put the website maintenance on, it shows as blank page also. I tried a fresh install and it seemed to work but i reverted back to old one because i didnt want to loose my customer info, or product info.

9 Aug 2009, 4:25 AM
#4
aussiesapphire avatar

aussiesapphire

Zen Follower

Join Date:
Apr 2006
Posts:
114
Plugin Contributions:
0

Re: Blank Main Page

I am currently working on a new zencart and have installed a few mods and edits while I get it the way I want.

This exact thing happened to me when I installed the blank sidebox - admin working fine but a complete blank white page on the site. Am being pretty careful with backups, etc so could easily revert back to my last working state.

Turned out to be a really simple thing of uploading an incorrect file to the Languages folder. The blank sidebox just needs 3 files and I had accidentally loaded a duplicate one to the wrong folder. When I deleted the wrong file and uploaded the correct one, everything came back as if by magic.

Maybe something similar for you??

cheers
Leah

9 Aug 2009, 8:57 AM
#5
kuroi avatar

kuroi

Totally Zenned

Join Date:
Apr 2006
Location:
London, UK
Posts:
10,475
Plugin Contributions:
11

Re: Blank Main Page

The debug log files should show up in your site's "cache" folder and start myDEBUG.

If you don't have one then this will ve more difficult to track down. As a start, please would you provide answers to the questions about your installation that come up when you click on the reply button.

9 Aug 2009, 1:16 PM
#6
acehowell avatar

acehowell

New Zenner

Join Date:
Aug 2009
Posts:
3
Plugin Contributions:
0

Re: Blank Main Page

Ok i found the logs and here is the last one.

[09-Aug-2009 04:34:42] PHP Warning: require(DIR_WS_TEMPLATEStemplate_default/common/html_header.php) [<a href='function.require'>function.require</a>]: failed to open stream: No such file or directory in /home/content/d/o/l/dollysdairybar/html/shop/index.php on line 43
[09-Aug-2009 04:34:42] PHP Fatal error: require() [<a href='function.require'>function.require</a>]: Failed opening required 'DIR_WS_TEMPLATEStemplate_default/common/html_header.php' (include_path='.:/usr/local/php5/lib/php') in /home/content/d/o/l/dollysdairybar/html/shop/index.php on line 43

Looks like it is missing a file html_header.php if i am not correct someone please let me know. I will try and replace this.

9 Aug 2009, 1:24 PM
#7
kuroi avatar

kuroi

Totally Zenned

Join Date:
Apr 2006
Location:
London, UK
Posts:
10,475
Plugin Contributions:
11

Re: Blank Main Page

You've read and understood the message correctly (amazing how many people appear to make no attempt to read these message before posting them), however your conclusion is slightly off target.

The problem is actually in the path name being used to try to find the file. The text DIR_WS_TEMPLATES is a PHP constant and should have been expanded to give the root for the path where the file can be found. What we need to investigate is why that constant hasn't been found and used properly.

First place to look is at about line 35 of your includes/configure.php file. Is it defined there, at the end of a block of 8 similar definitions?

9 Aug 2009, 1:27 PM
#8
kuroi avatar

kuroi

Totally Zenned

Join Date:
Apr 2006
Location:
London, UK
Posts:
10,475
Plugin Contributions:
11

Re: Blank Main Page

Also, does you includes/configure.php file start with the following definitions?> define('HTTP_SERVER', 'http://kuroi');

define('HTTPS_SERVER', 'https://kuroi');
define('HTTP_CATALOG_SERVER', 'http://kuroi');
define('HTTPS_CATALOG_SERVER', 'https://kuroi');If so, you have overwritten your includes/configure.php file with your admin/includes/configure.php file, which I suspect would explain your symptoms.