Zen Cart Logo
Forums / Upgrading from 1.3.x to 1.3.9 / Unable to save changes in admin after upgrading from 1.3.7 to 1.3.8a

Unable to save changes in admin after upgrading from 1.3.7 to 1.3.8a

Locked

Views: 5,432

Results 1 to 19 of 19
This thread is locked. New replies are disabled.
17 Aug 2009, 7:08 PM
#1
koesbong avatar

koesbong

New Zenner

Join Date:
Feb 2009
Posts:
30
Plugin Contributions:
0

Unable to save changes in admin after upgrading from 1.3.7 to 1.3.8a

A client asked me to move their zen cart installation from 1 webhost to another.

Old webhost runs 1.3.7 and new one runs 1.3.8a.

These were the steps I took to do the migration:

  1. Installed a local copy of 1.3.7.
  2. Copied the old server's copy of 1.3.7 and database
  3. Got the working copy of old 1.3.7 working locally
  4. Upgraded local 1.3.7 and database to 1.3.8a
  5. Migrate local 1.3.8a to the new server

Everything looks good. I can log in to the admin section but am now unable to save any changes made to the store, like add products, update description, add google analytics code.

Any ideas as to where I can start looking?

Thanks so much!

-koes

17 Aug 2009, 7:15 PM
#2
kuroi avatar

kuroi

Totally Zenned

Join Date:
Apr 2006
Location:
London, UK
Posts:
10,475
Plugin Contributions:
11

Re: Unable to save changes in admin after upgrading from 1.3.7 to 1.3.8a

Some indication as to what happens when you try to make updates would be useful.

17 Aug 2009, 8:11 PM
#3
koesbong avatar

koesbong

New Zenner

Join Date:
Feb 2009
Posts:
30
Plugin Contributions:
0

Re: Unable to save changes in admin after upgrading from 1.3.7 to 1.3.8a

Oh sorry, when you click update or save, it just refreshes the page and no changes were applied.

17 Aug 2009, 8:17 PM
#4
kuroi avatar

kuroi

Totally Zenned

Join Date:
Apr 2006
Location:
London, UK
Posts:
10,475
Plugin Contributions:
11

Re: Unable to save changes in admin after upgrading from 1.3.7 to 1.3.8a

What about other pages such as changing configuration switches, or switching content boxes on and off?

17 Aug 2009, 8:27 PM
#5
koesbong avatar

koesbong

New Zenner

Join Date:
Feb 2009
Posts:
30
Plugin Contributions:
0

Re: Unable to save changes in admin after upgrading from 1.3.7 to 1.3.8a

doesn't work either. any form submission redirects the site to the admin/index.php with no changes applied.

18 Aug 2009, 4:27 AM
#6
koesbong avatar

koesbong

New Zenner

Join Date:
Feb 2009
Posts:
30
Plugin Contributions:
0

Re: Unable to save changes in admin after upgrading from 1.3.7 to 1.3.8a

i thought that i might be able to reproduce it locally, but i haven't been able to.

weird thing is that sometimes i am able to log in to the admin page, sometimes i can't. i haven't been able to log in to the admin on firefox and have been able to on safari.

any ideas?

18 Aug 2009, 4:36 AM
#7
website_rob avatar

website_rob

Inactive

Join Date:
Oct 2006
Location:
Alberta, Canada
Posts:
4,572
Plugin Contributions:
0

Re: Unable to save changes in admin after upgrading from 1.3.7 to 1.3.8a

Did you edit both config files to use the paths and database on the Server?

18 Aug 2009, 4:39 AM
#8
koesbong avatar

koesbong

New Zenner

Join Date:
Feb 2009
Posts:
30
Plugin Contributions:
0

Re: Unable to save changes in admin after upgrading from 1.3.7 to 1.3.8a

yea. i actually made copies of the original config in includes and admin/includes before i made the changes, then overwrote the config back to where they're supposed to be. i can view the site just fine, just can't get into admin. and IF i could get it in the admin page, i can't make any changes at all. it just redirects the page to admin/index.php on any form submit.

18 Aug 2009, 5:41 AM
#9
website_rob avatar

website_rob

Inactive

Join Date:
Oct 2006
Location:
Alberta, Canada
Posts:
4,572
Plugin Contributions:
0

Re: Unable to save changes in admin after upgrading from 1.3.7 to 1.3.8a

it just redirects the page to admin/index.php on any form submit.
That sounds like a permission issue and/or redirection involving an .htaccess file.

18 Aug 2009, 5:46 AM
#10
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Unable to save changes in admin after upgrading from 1.3.7 to 1.3.8a

And, if you recently applied the admin security patch and now all your admin forms are going back to admin home, then you didn't apply the patch correctly, and probably put the files in the wrong places contrary to the install instructions.

18 Aug 2009, 5:54 AM
#11
koesbong avatar

koesbong

New Zenner

Join Date:
Feb 2009
Posts:
30
Plugin Contributions:
0

Re: Unable to save changes in admin after upgrading from 1.3.7 to 1.3.8a

file structure on root:

drwxr-xr-x 21 bigdwest nobody 4096 Aug 18 00:17 ../
-rw-r--r-- 1 bigdwest bigdwest 29 Jul 21 14:31 .htaccess
drwxr-xr-x 5 bigdwest bigdwest 4096 Aug 14 22:17 admin/
-rw-r--r-- 1 bigdwest bigdwest 119218 Aug 12 22:04 admin.zip
drwxrwxrwx 2 bigdwest bigdwest 4096 Aug 14 22:17 cache/
drwxr-xr-x 2 bigdwest bigdwest 4096 Aug 14 22:06 cgi-bin/
drwxr-xr-x 2 bigdwest bigdwest 4096 Aug 14 22:17 docs/
drwxr-xr-x 2 bigdwest bigdwest 4096 Aug 14 22:17 download/
drwxr-xr-x 3 bigdwest bigdwest 4096 Aug 14 22:17 editors/
drwxr-xr-x 2 bigdwest bigdwest 4096 Aug 14 22:17 email/
drwxr-xr-x 2 bigdwest bigdwest 4096 Aug 14 22:17 extras/
-rw-r--r-- 1 bigdwest bigdwest 206 Aug 14 22:07 fantastico_fileslist.txt
-rw-r--r-- 1 bigdwest bigdwest 47 Jul 5 12:06 fantversion.php
drwxrwxrwx 18 bigdwest bigdwest 4096 Aug 14 22:17 images/
drwxr-xr-x 13 bigdwest bigdwest 4096 Aug 14 22:17 includes/
-rwxr-xr-x 1 bigdwest bigdwest 4666 Feb 2 2006 index.php*
-rw-r--r-- 1 bigdwest bigdwest 298684 Jan 14 2009 initial_schema.sql
-rwxr-xr-x 1 bigdwest bigdwest 1518 Feb 28 2007 install.txt*
-rwxr-xr-x 1 bigdwest bigdwest 16672 Nov 27 2007 ipn_main_handler.php*
-rwxr-xr-x 1 bigdwest bigdwest 2124 Jul 20 00:41 jscript_googleanalytics_outgoing.php*
-rwxr-xr-x 1 bigdwest bigdwest 15039 Jan 21 2006 license.txt*
-rw-r--r-- 1 bigdwest bigdwest 336411736 Aug 14 22:15 local-mct-138a.zip
drwxrwxrwx 2 bigdwest bigdwest 4096 Aug 14 22:17 media/
-rwxr-xr-x 1 bigdwest bigdwest 2154 Mar 27 2006 nddbc.html*
-rwxr-xr-x 1 bigdwest bigdwest 4076 Aug 19 2007 nochex_apc_handler.php*
-rw-r--r-- 1 bigdwest bigdwest 305498 Mar 14 2007 old
-rwxr-xr-x 1 bigdwest bigdwest 675 Dec 30 2005 page_not_found.php*
-rwxr-xr-x 1 bigdwest bigdwest 3135 Aug 14 02:07 prefix.php*
drwxrwxrwx 3 bigdwest bigdwest 4096 Aug 14 22:17 pub/

.htaccess on root:
AddHandler php5-script .php

file permission in admin is mostly: -rwxr-xr-x except for the images/ folder

.htaccess in admin:

$Id: .htaccess 1105 2005-04-04 22:05:35Z birdbrain $

This is used with Apache WebServers

For this to work, you must include the parameter 'Options' to

the AllowOverride configuration

Example:

<Directory "/usr/local/apache/htdocs">

AllowOverride Options

</Directory>

'All' with also work. (This configuration is in the

apache/conf/httpd.conf file)

The following makes adjustments to the SSL protocol for Internet

Explorer browsers

<IfModule mod_setenvif.c> <IfDefine SSL> SetEnvIf User-Agent ".*MSIE.*" \ nokeepalive ssl-unclean-shutdown \ downgrade-1.0 force-response-1.0 </IfDefine> </IfModule>

Fix certain PHP values

#<IfModule mod_php4.c>

php_value session.use_trans_sid 0

php_value register_globals 1

#</IfModule>

to turn off register_globals

php_value register_globals 0

.htaccess in admin/includes:

$Id: .htaccess 2996 2006-02-09 00:42:17Z drbyte $

This is used with Apache WebServers

The following blocks direct HTTP requests in this directory recursively

This does not affect PHP include/require functions

Example: direct access to http://server/admin/includes/application_top.php will not work with the following installed

<Files *.php>
Order Deny,Allow
Deny from all
Allow from localhost
</Files>

.htaccess in includes/ :

$Id: .htaccess 1105 2005-04-04 22:05:35Z birdbrain $

This is used with Apache WebServers

The following blocks direct HTTP requests in this directory recursively

For this to work, you must include the parameter 'Limit' to the AllowOverride configuration

Example:

#<Directory "/usr/local/apache/htdocs">

AllowOverride Limit

'All' with also work. (This configuration is in your apache/conf/httpd.conf file)

This does not affect PHP include/require functions

Example: http://server/catalog/includes/application_top.php will not work

<Files *.php>
Order Deny,Allow
Deny from all
</Files>

18 Aug 2009, 5:57 AM
#12
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Unable to save changes in admin after upgrading from 1.3.7 to 1.3.8a

And if you haven't applied the admin security patch, you need to.
And you need to rename your admin folder too.
http://www.zen-cart.com/forum/showthread.php?t=130161

18 Aug 2009, 5:59 AM
#13
koesbong avatar

koesbong

New Zenner

Join Date:
Feb 2009
Posts:
30
Plugin Contributions:
0

Re: Unable to save changes in admin after upgrading from 1.3.7 to 1.3.8a

DrByte:

And, if you recently applied the admin security patch and now all your admin forms are going back to admin home, then you didn't apply the patch correctly, and probably put the files in the wrong places contrary to the install instructions.

so on my local machine, the upgrade went smoothly and i have been able to log in to admin and save changes and such.

i didn't really do the whole find the diff and only change the files with diffs. i made a backup of the config files, then overwrite the 1.3.7 file structure with 1.3.8a. then copied back the config files.

is it very crucial that i only change the files with diffs? i just don't know why it works locally but breaks after i deployed it live.

thanks so much for all the ideas so far.

18 Aug 2009, 6:02 AM
#14
koesbong avatar

koesbong

New Zenner

Join Date:
Feb 2009
Posts:
30
Plugin Contributions:
0

Re: Unable to save changes in admin after upgrading from 1.3.7 to 1.3.8a

DrByte:

And if you haven't applied the admin security patch, you need to.
And you need to rename your admin folder too.
http://www.zen-cart.com/forum/showthread.php?t=130161

will give this a shot.

18 Aug 2009, 6:10 AM
#15
koesbong avatar

koesbong

New Zenner

Join Date:
Feb 2009
Posts:
30
Plugin Contributions:
0

Re: Unable to save changes in admin after upgrading from 1.3.7 to 1.3.8a

what i am confused about is why it works locally but not i nproduction. i am still going to go ahead and apply the admin patch. thanks so much!

19 Aug 2009, 3:36 AM
#16
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Unable to save changes in admin after upgrading from 1.3.7 to 1.3.8a

koesbong:

what i am confused about is why it works locally but not i nproduction.
If they are truly both the same and properly configured then it will work.
https://www.zen-cart.com/tutorials/index.php?article=99

But blindly replacing 1.3.7 files with v1.3.8 files is ... downright errorprone.

4 Feb 2010, 6:17 PM
#17
pcspot avatar

pcspot

New Zenner

Join Date:
Aug 2007
Posts:
31
Plugin Contributions:
0

Re: Unable to save changes in admin after upgrading from 1.3.7 to 1.3.8a

hello,

has this been solved. I am having same problem. i have done the patch according to instructions but still cannot save. i cannot get into categories or edit products. i cannot add specials etc as it does not pull up the product list. how do we solve this?
thanks

4 Feb 2010, 6:47 PM
#18
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Unable to save changes in admin after upgrading from 1.3.7 to 1.3.8a

pcspot:

hello,

has this been solved. I am having same problem. i have done the patch according to instructions but still cannot save. i cannot get into categories or edit products. i cannot add specials etc as it does not pull up the product list. how do we solve this?
thanks
The symptoms you describe indicate that you didn't update the admin version of html_output.php as part of the admin security patch dated June 2009.

17 Feb 2010, 10:02 PM
#19
ledmod avatar

ledmod

New Zenner

Join Date:
Jun 2007
Posts:
18
Plugin Contributions:
0

Re: Unable to save changes in admin after upgrading from 1.3.7 to 1.3.8a

DrByte:

The symptoms you describe indicate that you didn't update the admin version of html_output.php as part of the admin security patch dated June 2009.
This worked out.... I was pulling my hair out cause of this.
Thank you so much!!!

For other people that has the same problem!!!!

http://www.zen-cart.com/forum/showthread.php?t=130161

Make sure to follow the readme file in the zip file..
Most important is that amend the file #5 below...

  1. <YOUR ADMIN DIRECTORY>/includes/functions/extra_functions/security_patch_v138_20090619.php - NEW FILE
  2. <YOUR ADMIN DIRECTORY>/includes/extra_configures/security_patch_v138_20090619.php - NEW FILE
  3. <YOUR ADMIN DIRECTORY>/includes/autoloaders/config.security_patch_v138_20090619.php - NEW FILE
  4. <YOUR ADMIN DIRECTORY>/includes/init_includes/init_security_patch_v138_20090619.php - NEW FILE
  5. <YOUR ADMIN DIRECTORY>/includes/functions/html_output.php - ALTERED FILE