Zen Cart Logo
Forums / Installing on a Linux/Unix Server / After adding shared SSL certificate, checkout no longer works

After adding shared SSL certificate, checkout no longer works

Locked

Views: 1,882

Results 1 to 3 of 3
This thread is locked. New replies are disabled.
20 Aug 2009, 1:58 AM
#1
ryanbalton avatar

ryanbalton

New Zenner

Join Date:
Aug 2009
Posts:
1
Plugin Contributions:
0

After adding shared SSL certificate, checkout no longer works

Hello,

I am running Zencart at http://myertheflorist.com . I am hosted with Doteasy. After testing the zencart without an SSL certificate, and everything working fine, I purchased a shared SSL cert from Doteasy. Now, when I try to check out, I receive a blank page after pressing submit from the first check out screen. The email that I have created a new account goes through fine, but only a blank screen appears in the browser.
My host, Doteasy, says these errors are appearing in my log:

[Tue Aug 18 00:02:22 2009] [error] [client 65.61.193.40] PHP Notice: Undefined variable: body_id in /var/www/html/index.php on line 34
[Tue Aug 18 00:02:22 2009] [error] [client 65.61.193.40] PHP Notice: Undefined variable: zv_onload in /var/www/html/index.php on line 34

Any thoughts? I've dabbled in Web design for at least ten years, but mostly static stuff, dynamic applications like this are fairly new to me.

Thanks!

20 Aug 2009, 12:09 PM
#2
stevesh avatar

stevesh

Black Belt

Join Date:
Feb 2005
Location:
Lansing, Michigan USA
Posts:
19,793
Plugin Contributions:
2

Re: After adding shared SSL certificate, checkout no longer works

Probably at least one problem with your configure.php file. Your product listing page is secured for some reason, but not the rest of your site before login or checkout.

All of your secured pages produce the secure/non-secure error in IE.

20 Aug 2009, 11:46 PM
#3
vger avatar

vger

Past Contributor

Join Date:
Nov 2004
Location:
Norfolk, United Kingdom
Posts:
3,189
Plugin Contributions:
0

Re: After adding shared SSL certificate, checkout no longer works

The links in your root level site are all hardcoded to Shared SSL addresses, and using the temporary URLs you use before repointing the domain - but not afterwards.

On the Zen Cart site your Category links are also all hardcoded to temporary URls, all using the Shared SSL.

  1. The reason you get the error when going to an https page is because you have a graphic stats counter in the footer which is being called in from an http address - get rid of it.

  2. Get rid of all of the hardcoded temporary URLs which all use the shared ssl. For instance:

<li><a href="https://dprhensim69.doteasy.com/~admin78/zencart/index.php?main_page=index&cPath=2_4">Birthday</a></li>

should be (for Categories):

<li><a href="index.php?main_page=index&cPath=2_4">Birthday</a></li>

should be (for your root level site):

<li><a href="zencart/index.php?main_page=index&cPath=2_4">Birthday</a></li>

Vger