Zen Cart Logo
Forums / General Questions / Login & Forgotten Password stopped working

Login & Forgotten Password stopped working

Locked

Views: 1,146

Results 1 to 7 of 7
This thread is locked. New replies are disabled.
26 Aug 2009, 10:23 PM
#1
mattclements avatar

mattclements

New Zenner

Join Date:
Aug 2009
Location:
Milton Keynes
Posts:
102
Plugin Contributions:
0

Login & Forgotten Password stopped working

Hello,
Users can signup to the site & place an order - however when logging in again, or using the forgotten password pages it states it can't find the user.

When debugging i get the following error - not sure if its relevent:

[26-Aug-2009 23:19:16] PHP Warning:  mysql_real_escape_string() [<a href='function.mysql-real-escape-string'>function.mysql-real-escape-string</a>]: Access denied for user 'apache'@'localhost' (using password: NO) in /var/www/vhosts/site123.com/httpdocs/includes/classes/db/mysql/query_factory.php on line 56
[26-Aug-2009 23:19:16] PHP Warning:  mysql_real_escape_string() [<a href='function.mysql-real-escape-string'>function.mysql-real-escape-string</a>]: A link to the server could not be established in /var/www/vhosts/site123.com/httpdocs/includes/classes/db/mysql/query_factory.php on line 56
27 Aug 2009, 6:56 PM
#2
mattclements avatar

mattclements

New Zenner

Join Date:
Aug 2009
Location:
Milton Keynes
Posts:
102
Plugin Contributions:
0

Re: Login & Forgotten Password stopped working

Ok,
I am getting somewhere with this - however I may be failing to understand something.

I reinstalled ZenCart (Customers could login before) - now no user can login. From what I understand this is due to the MD5+Salt Encryption - however both new users, and old users can not login.

The site is currently:
A new install of Zencart + Mods
Old Template
Database import of customers & products from old site.

Any ideas?
Regards,
Matt x

27 Aug 2009, 8:42 PM
#3
mattclements avatar

mattclements

New Zenner

Join Date:
Aug 2009
Location:
Milton Keynes
Posts:
102
Plugin Contributions:
0

Re: Login & Forgotten Password stopped working

Ok - I dont see the first error (apache@localhost) to be the major issue - however I do believe this is something to do with the PHP/MySQL link/query. So you can signup a new user - fill out all the details and so on, once you logout - no logging back in.

Logging in:
Error: Sorry, there is no match for that email address and/or password.

Forgotten Password:
Error: The Email Address was not found in our records; please try again.

This also rules out the password MD5 issues as the Forgotten Password doesn't deal with any MD5 passwords to submit the form.
I belive this is the PHP lookup - however thats where my knowledge ends.

Any help?
Matt

27 Aug 2009, 10:38 PM
#4
ajeh avatar

ajeh

Oba-san

Join Date:
Sep 2003
Location:
Ohio
Posts:
62,757
Plugin Contributions:
1

Re: Login & Forgotten Password stopped working

Has this always happened or did it just start to happen?

What happens if you switch to the Classic Template?

If you load the Debug Tool from the Free Software Add Ons ... do you see any error logs from it?

If you have space, can you make a Test directory with a Test database and load a Clean download of Zen Cart v1.3.8 with the Demo data and test to see if you have the same results to rule out something with the server vs some change, customization or corruption of the files? :smile:

28 Aug 2009, 6:01 AM
#5
mattclements avatar

mattclements

New Zenner

Join Date:
Aug 2009
Location:
Milton Keynes
Posts:
102
Plugin Contributions:
0

Re: Login & Forgotten Password stopped working

This has happened ever since I reinstalled ZenCart to fix some problems & imported customers & products.

Classic Template doesn't work - and as above when I use the debugging utility i get

[26-Aug-2009 23:19:16] PHP Warning:  mysql_real_escape_string() [<a href='function.mysql-real-escape-string'>function.mysql-real-escape-string</a>]: Access denied for user 'apache'@'localhost' (using password: NO) in /var/www/vhosts/site123.com/httpdocs/includes/classes/db/mysql/query_factory.php on line 56
[26-Aug-2009 23:19:16] PHP Warning:  mysql_real_escape_string() [<a href='function.mysql-real-escape-string'>function.mysql-real-escape-string</a>]: A link to the server could not be established in /var/www/vhosts/site123.com/httpdocs/includes/classes/db/mysql/query_factory.php on line 56

I can create a test ZenCart if needed - but this worked before?

Regards,
Matt

28 Aug 2009, 6:21 AM
#6
mattclements avatar

mattclements

New Zenner

Join Date:
Aug 2009
Location:
Milton Keynes
Posts:
102
Plugin Contributions:
0

Re: Login & Forgotten Password stopped working

Fixed! I was using a counter App that was closing the MySQL connection.

Regards,
Matt

28 Aug 2009, 1:14 PM
#7
ajeh avatar

ajeh

Oba-san

Join Date:
Sep 2003
Location:
Ohio
Posts:
62,757
Plugin Contributions:
1

Re: Login & Forgotten Password stopped working

Thanks for the update that you had installed an add on that was causing these problems ... :smile: