Zen Cart Logo
Forums / Installing on a Windows Server / Installed successfully then receiving a 500 error

Installed successfully then receiving a 500 error

Locked

Views: 1,148

Results 1 to 2 of 2
This thread is locked. New replies are disabled.
3 Sep 2009, 7:10 PM
#1
ewatkins avatar

ewatkins

New Zenner

Join Date:
Sep 2009
Posts:
1
Plugin Contributions:
0

Installed successfully then receiving a 500 error

I have installed zen cart successfully on windows 2003 server running php v 5.2.x, I had one instance up for all of last week and now it has turned into a 500 error. I just tried installing a fresh copy on the same server for another client and the install went perfectly, and at the end when it asks to go to the store or the admin, neither one works. In Firefox I am getting a blank screen, in IE a 500 error. What could have happened that would cause a site to go down and a fresh install to install fine and then not work? Both are giving me 500 errors, I have not changed any setting in the configuration files either.

3 Sep 2009, 7:29 PM
#2
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Installed successfully then receiving a 500 error

"500" errors are triggered at the server level, not the Zen Cart level. You'll need to dig into the server's logs to find out what's triggering the 500 errors.
Some IIS versions (especially older ones) can't handle the .htaccess files that Apache would use, and since Zen Cart supplies several .htaccess files to aid with providing security, you may need to remove the .htaccess files and find your own way of providing the equivalent security in your IIS configuration.