Forums / General Questions / '400 Bad Request' Error when trying to preview product

'400 Bad Request' Error when trying to preview product

Locked

Views: 1,098

Results 1 to 5 of 5
This thread is locked. New replies are disabled.
26 Sep 2009, 12:37 AM
#1
epools avatar

epools

New Zenner

Join Date:
Feb 2008
Posts:
4
Plugin Contributions:
0

'400 Bad Request' Error when trying to preview product

Good Morning everyone or whatever the time may be, I am having a problem with the Product decription box in the 'edit product' screen

I do a lot of cutting and pasting into that section and most of the time it works fine, but recently it has been giving me this error when trying to 'preview' the product:

**Bad Request

Your browser sent a request that this server could not understand.
Apache/2.2.0 (Redhat) Server at epools.com.au Port 80**

it was working fine since Saturday (19th) but since Friday (25th) it has been giving me that error for apparently pasting text with things like:

  • bullet points
  • punctuation such as quotation marks and apostrophes
  • text with more then one space between them

This never used to happen as of a week ago the only problem i had before was pasting special characters ie U's with the two dots on the top, i am only able to preview the product after i have deleted all the pasted bullets, I have also noticed that the products which i have previously entered I am not able to "preview" them either.

I called up our hosting company 'Telefa' and they said they had just applied an update and were trying to fix a few errors with permissions. I explained the problem to them and they sent me this reply:

"Please see the response from our server manager:

Zencart and old versions of Joomla have come under a lot of scrutiny recently as they basically keep getting hacked and compromising the server. The guys have been locking these processes out to protect the server and all the other clients on there. You’ll need to advise the client to make sure that the security patches are all up to date as any old vulnerable versions will be blocked as they will eventually get hacked."

I get the idea that installing the latest security patch may help, though we are using Zen Cart 1.3.8a so it may already be on there i'm not exactly sure what he means by "You’ll need to advise the client to make sure that the security patches are all up to date" though.

I would just like to know if anyone has had this problem in the past & also if this is more a problem with hosting rather then zen-cart.

Thank you for your help

Using version: Zen Cart 1.3.8a

Site: https://www.epools.com.au

Hosting Company: Telefa http://www.telefa.com.au/

26 Sep 2009, 12:55 AM
#2
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: '400 Bad Request' Error when trying to preview product

On the issue of your security and patch concerns, I would start with applying the recent security patch: http://www.zen-cart.com/forum/showthread.php?t=130161
All forum members were emailed that information back in June 2009.

.
Zen Cart - putting the dream of business ownership within reach of anyone!
Donate to: DrByte directly or to the Zen Cart team as a whole

Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

26 Sep 2009, 12:56 AM
#3
epools avatar

epools

New Zenner

Join Date:
Feb 2008
Posts:
4
Plugin Contributions:
0

Re: '400 Bad Request' Error when trying to preview product

ah i cee ok

Oh & also another problem we're having is that sometimes when we click on 'preview' it comes up with everything blank and all the description & info is gone from the product for some reason

26 Sep 2009, 12:58 AM
#4
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: '400 Bad Request' Error when trying to preview product

epools:

... recently it has been giving me this error when trying to 'preview' the product:

**Bad Request

Your browser sent a request that this server could not understand.
Apache/2.2.0 (Redhat) Server at epools.com.au Port 80**

it was working fine since Saturday (19th) but since Friday (25th) it has been giving me that error for apparently pasting text with things like:

  • bullet points
  • punctuation such as quotation marks and apostrophes
  • text with more then one space between them

This never used to happen as of a week ago ...

Sounds like your hosting company has set up several mod_security rules which intercept the data you input, trying to ensure that only plain text is entered. Maybe their rules are over-aggressive. You'll most likely have to work with them to get a resolution to your problem.

.
Zen Cart - putting the dream of business ownership within reach of anyone!
Donate to: DrByte directly or to the Zen Cart team as a whole

Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

14 Oct 2009, 8:00 PM
#5
mrpresley avatar

mrpresley

New Zenner

Join Date:
Aug 2004
Posts:
2
Plugin Contributions:
0

Re: '400 Bad Request' Error when trying to preview product

I too am having the 400 Bad Request error. For me it is happening when choosing "Add to Cart". The product does get added and if I go to another page all is fine. But if I let the page continue to hang, it eventually goes to the 400 error.. Here is the strange thing - this ONLY happens if I'm using FireFox.. There are no issues whatsoever with IE 8. I have this running on a dedicated server with WHM/Cpanel (centos 5). I have the default mod_security installed (nothing custom). I do have configserver firewall running ( I tested this same problem with the firewall completely disabled to be sure), and still the problem persists. You can test the problem yourself (if you're so inclined) at http://www.nartec.com

I also have applied the latest security patch and renamed my admin folder. The problem still persists. Any ideas?