Zen Cart Logo
Forums / Installing on a Linux/Unix Server / Moved to new server, ran fix cache, lost admin log-in

Moved to new server, ran fix cache, lost admin log-in

Locked

Views: 2,211

Results 1 to 5 of 5
This thread is locked. New replies are disabled.
26 Sep 2009, 3:45 AM
#1
lyon avatar

lyon

Zen Follower

Join Date:
Jul 2004
Posts:
68
Plugin Contributions:
0

Moved to new server, ran fix cache, lost admin log-in

I have looked at similar threads and had no luck.

I installed a fresh zencart on my new server and followed all the steps in the tutorial. The front end of the cart is up, but not with my old site products and layout, just the fresh install.

When I try and access the admin area I get this error:

Warning: require(/home/content/m/a/g/MYNAME/html/shop/includes/autoload_func.php) [function.require]: failed to open stream: No such file or directory in /home/content/59/4978759/html/shop/MYADMIN/includes/application_top.php on line 149

Fatal error: require() [function.require]: Failed opening required '/home/content/m/a/g/MYNAME/html/shop/includes/autoload_func.php' (include_path='.:/usr/local/php5/lib/php') in /home/content/59/4978759/html/shop/MYADMIN/includes/application_top.php on line 149

(MYNAME & MYADMIN were substituted for my actual names)

I have checked that the database and the configure files both have the DB prefix of "zen_"

Please help. I have been at this since Tuesday. I have not had this much trouble with any other move and can't figure out what I am doing wrong. Thanks for your help.

26 Sep 2009, 3:50 AM
#2
website_rob avatar

website_rob

Inactive

Join Date:
Oct 2006
Location:
Alberta, Canada
Posts:
4,572
Plugin Contributions:
0

Re: Moved to new server, ran fix cache, lost admin log-in

/home/content/m/a/g/MYNAME/html/shop/includes/autoload_func.php

The error msg. is telling you the above file cannot be found. Either it is not there or permissions are wrong.

You should confirm if there and permissions are 644.

26 Sep 2009, 4:15 AM
#3
lyon avatar

lyon

Zen Follower

Join Date:
Jul 2004
Posts:
68
Plugin Contributions:
0

Re: Moved to new server, ran fix cache, lost admin log-in

Website Rob:

/home/content/m/a/g/MYNAME/html/shop/includes/autoload_func.php

The error msg. is telling you the above file cannot be found. Either it is not there or permissions are wrong.

You should confirm if there and permissions are 644.

It's there and the permissions are 644.

26 Sep 2009, 4:15 AM
#4
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Moved to new server, ran fix cache, lost admin log-in

More than that, Rob, is the fact that the paths are wrong ... which means the configure.php file contents weren't updated correctly.

It's looking for this: /home/content/m/a/g/MYNAME/html/shop/(includes/autoload_func.php)
When the server is actually running at this path: /home/content/59/4978759/html/shop/(MYADMIN/includes/application_top.php)

If the documented steps for changing servers had been followed, this would have been less likely to happen: https://www.zen-cart.com/tutorials/index.php?article=100

2 options:
a) redo it following the FAQ documentation, which will build the correct configure.php file content
b) manually edit all the appropriate paths in the configure.php files

26 Sep 2009, 4:26 AM
#5
website_rob avatar

website_rob

Inactive

Join Date:
Oct 2006
Location:
Alberta, Canada
Posts:
4,572
Plugin Contributions:
0

Re: Moved to new server, ran fix cache, lost admin log-in

Good catch on the path differences. :smile: