Zen Cart Logo
Forums / Installing on a Linux/Unix Server / Warning Error after SSL cert install: I am able to write to the configuration file

Warning Error after SSL cert install: I am able to write to the configuration file

Locked

Views: 1,374

Results 1 to 4 of 4
This thread is locked. New replies are disabled.
30 Sep 2009, 1:55 PM
#1
lackew avatar

lackew

Zen Follower

Join Date:
Aug 2009
Location:
Tampa Bay
Posts:
223
Plugin Contributions:
1

Warning Error after SSL cert install: I am able to write to the configuration file

version Zen Cart 1.3.8a

After my SSL Cert installation I now get this at top of page

Warning: I am able to write to the configuration file:
/home/content/d/e/m/demonann/html/shop/includes/configure.php. This is a potential security risk - please set the right user permissions on this file (read-only, CHMOD 644 or 444 are typical). You may need to use your webhost control panel/file
-manager to change the permissions effectively. Contact your webhost for assistance. See this FAQ

But when I apply either CHMODD 444 or 644 I get this page

Warning: main(includes/application_top.php): failed to open stream: Permission denied in /shop/index.php on line 26
Warning: main(includes/application_top.php): failed to open stream: Permission denied in /shop/index.php on line 26

Fatal error: main(): Failed opening required 'includes/application_top.php'
(include_path='.:/usr/local/lib/php') in shop/index.php on line 26
I have also set the appropriate "SSL=true"
HELPPPPPPPPP

30 Sep 2009, 1:57 PM
#2
lackew avatar

lackew

Zen Follower

Join Date:
Aug 2009
Location:
Tampa Bay
Posts:
223
Plugin Contributions:
1

Re: Warning Error after SSL cert install: I am able to write to the configuration file

version Zen Cart 1.3.8a
link your-ehome.com/shop

After my SSL Cert installation I now get this at top of page
"Warning: I am able to write to the configuration file:
/home/content/d/e/m/demonann/html/shop/includes/configure.php. This is a potential security risk - please set the right user permissions on this file (read-only, CHMOD 644 or 444 are typical). You may need to use your webhost control panel/file
-manager to change the permissions effectively. Contact your webhost for assistance. See this FAQ"

But when I apply either CHMODD 444 or 644 I get this page
"Warning: main(includes/application_top.php): failed to open stream: Permission denied in /shop/index.php on line 26
Warning: main(includes/application_top.php): failed to open stream: Permission denied in /shop/index.php on line 26

Fatal error: main(): Failed opening required 'includes/application_top.php'
(include_path='.:/usr/local/lib/php') in shop/index.php on line 26"

I have also set the appropriate "SSL=true"
HELPPPPPPPPP

30 Sep 2009, 5:03 PM
#3
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Warning Error after SSL cert install: I am able to write to the configuration file

Sounds like you're applying permissions to the folder instead of to the specific file.

30 Sep 2009, 6:36 PM
#4
lackew avatar

lackew

Zen Follower

Join Date:
Aug 2009
Location:
Tampa Bay
Posts:
223
Plugin Contributions:
1

Re: Warning Error after SSL cert install: I am able to write to the configuration file

DrByte:

Sounds like you're applying permissions to the folder instead of to the specific file.

Yes I tried to the includes folder and site would not display. Did it only to configure.php