Zen Cart Logo
Forums / Installing on a Linux/Unix Server / Unable to add any products - new installation

Unable to add any products - new installation

Locked

Views: 1,720

Results 1 to 9 of 9
This thread is locked. New replies are disabled.
26 Oct 2009, 11:29 AM
#1
mhaggag avatar

mhaggag

New Zenner

Join Date:
Sep 2006
Posts:
22
Plugin Contributions:
0

Unable to add any products - new installation

Hello everyone!
New Zen-Cart installation on a Linux server (my ISP). Version 1.3.8.
Installation was successful and everything seems to work OK.
You can open my store at:
http://www.ianphone.com/shop/
However, in the admin area, I was able to create some product categories, but when I drill down categories I have created and try to add aproduct, I get the folloiwng error:

Warning: require(includes/modules/product/collect_info.php) [function.require]: failed to open stream: No such file or directory in /home/howtoen1/public_html/ianphone.com/shop/admin/product.php on line 139

Warning: require(includes/modules/product/collect_info.php) [function.require]: failed to open stream: No such file or directory in /home/howtoen1/public_html/ianphone.com/shop/admin/product.php on line 139

Fatal error: require() [function.require]: Failed opening required 'includes/modules/product/collect_info.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/howtoen1/public_html/ianphone.com/shop/admin/product.php on line 139

Any idea what's going on?
Thanks!:frusty:

26 Oct 2009, 11:40 AM
#2
mhaggag avatar

mhaggag

New Zenner

Join Date:
Sep 2006
Posts:
22
Plugin Contributions:
0

Re: Unable to add any products - new installation

OK... never mind... the file collect_info.php was missing in admin/includes/modules/product
I re-ran my FTP lcient and re-uploaded the whole admin directory (with skip option, not overwrite) and the file was added, then the error disappeared and I was able to add products!

26 Oct 2009, 11:43 AM
#3
schoolboy avatar

schoolboy

Totally Zenned

Join Date:
Jun 2005
Location:
Cumbria, UK
Posts:
10,327
Plugin Contributions:
0

Re: Unable to add any products - new installation

This is a corrupted file that was probably corrupted when you FTP'd the zencart files to your server. (It happens quite often - the code gets corrupted during the FTP transfer).

Line 139 of the product.php file says:

      require(DIR_WS_MODULES . $zc_products->get_handler($product_type) . '/collect_info.php');

... and your error message says:

Warning: require(includes/modules/product/collect_info.php)

In plain English:

Hey! What's goin' on? I need this collect_info.php file but it ain't workin' man!

So...

You need to RE-SEND that collect_info.php file to its required location on the server.

In your FTP program, in the LEFT PANE, navigate to the folder where the original file resides.

In the RIGHT PANE, navigate to its corresponding folder on your server.

FTP the file again ... in ASCII mode.

26 Oct 2009, 11:46 AM
#4
schoolboy avatar

schoolboy

Totally Zenned

Join Date:
Jun 2005
Location:
Cumbria, UK
Posts:
10,327
Plugin Contributions:
0

Re: Unable to add any products - new installation

mhaggag:

OK... never mind... the file collect_info.php was missing in admin/includes/modules/product
I re-ran my FTP lcient and re-uploaded the whole admin directory (with skip option, not overwrite) and the file was added, then the error disappeared and I was able to add products!

Ah... you found the fix while I was posting my reply...

26 Oct 2009, 11:48 AM
#5
schoolboy avatar

schoolboy

Totally Zenned

Join Date:
Jun 2005
Location:
Cumbria, UK
Posts:
10,327
Plugin Contributions:
0

Re: Unable to add any products - new installation

I think there's a millionaire in the making in a person who can write a program that turns geek-speak error messages into plain language! :D

26 Oct 2009, 1:24 PM
#6
afo avatar

afo

Totally Zenned

Join Date:
Aug 2004
Location:
New York City
Posts:
6,800
Plugin Contributions:
0

Re: Unable to add any products - new installation

Nah, everyone just needs to come over to the geek side. :laugh:

27 Oct 2009, 8:20 AM
#7
mhaggag avatar

mhaggag

New Zenner

Join Date:
Sep 2006
Posts:
22
Plugin Contributions:
0

Re: Unable to add any products - new installation

Thanks for the help! Now I am getting something else strange. In the admin area, every meny item under the heading "Configuration" generates:
Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Every other heading (Catalong, Modules, Customers etc...) works OK!
Any ideas?

Thanks!

27 Oct 2009, 9:32 AM
#8
tino_schlegel avatar

tino_schlegel

Totally Zenned

Join Date:
Nov 2007
Location:
Melbourne, Australia
Posts:
532
Plugin Contributions:
0

Re: Unable to add any products - new installation

Check your server's error log to see what the actual problem is. And if you cannot solve it post the error.

27 Oct 2009, 2:26 PM
#9
mhaggag avatar

mhaggag

New Zenner

Join Date:
Sep 2006
Posts:
22
Plugin Contributions:
0

Re: Unable to add any products - new installation

tino.schlegel:

Check your server's error log to see what the actual problem is. And if you cannot solve it post the error.

Thanks Tino!!
Yes, you are right, sometimes, it's just a matter of checking error logs!
I found the following in my server error log:
[Tue Oct 27 09:20:07 2009] [error] [client xxx.xx.47.60] File does not exist: /xxxxxxxxxxxxxx/ianphone.com/500.shtml, referer: http://www.ianphone.com/shop/admin/
[Tue Oct 27 09:20:07 2009] [error] [client xxx.xx.47.60] SoftException in Application.cpp:256: File "/xxxxxxxxxxxxxx/ianphone.com/shop/admin/configuration.php" is writeable by group, referer: http://www.ianphone.com/shop/admin/

That's interesting... because configuration.php is writeable, the whole "configuration" menu header (and all the menu items beneath it) in admin was causing an internal Server error.

I changed permissions on that file to 444 and all works fine now!!!

Live and learn! :frusty::ohmy: