Zen Cart Logo
Forums / Setting Up Categories, Products, Attributes / resetting Master Category ID for all products in a category = HTTP 406 error!

resetting Master Category ID for all products in a category = HTTP 406 error!

Locked

Views: 1,852

Results 1 to 5 of 5
This thread is locked. New replies are disabled.
17 Nov 2009, 8:57 PM
#1
bodyjewelrystores avatar

bodyjewelrystores

Zen Follower

Join Date:
Jun 2006
Posts:
123
Plugin Contributions:
0

resetting Master Category ID for all products in a category = HTTP 406 error!

I am trying to reset the Master Category ID for all products in a certain category (the bottom-most option in "Multiple Categories Link Manager").

No matter what category number I type - all I get is a blank page.
I checked for PHP errors and found none, so I checked my HTTP logs, and all these requests show a 406 status code.

This happens both on my dev server (localhost) and on the live website.

Here's a log entry example, from the dev server:

127.0.0.1 - - [17/Nov/2009:22:13:56 +0200] "POST /138store/my_admin_dir/products_to_categories.php?action=reset_categories_products_to_another_category_master&products_filter=3293&current_category_id=412 HTTP/1.1" 406 5

Any idea what is going wrong??
I could probably figure out other ways to do the same thing (a few SQL statements...) but I would highly appreciate it if someone could help troubleshoot this issue.

We're using Zen Cart 1.3.8a with latest patches.

Many thanks in advance.

17 Nov 2009, 11:57 PM
#2
ajeh avatar

ajeh

Oba-san

Join Date:
Sep 2003
Location:
Ohio
Posts:
62,757
Plugin Contributions:
1

Re: resetting Master Category ID for all products in a category = HTTP 406 error!

I cannot reproduce this error ...

Check that you have applied the Known Bug Fixes for v1.3.8 then try it again ...
http://www.zen-cart.com/forum/showthread.php?t=82619

18 Nov 2009, 2:14 AM
#3
bodyjewelrystores avatar

bodyjewelrystores

Zen Follower

Join Date:
Jun 2006
Posts:
123
Plugin Contributions:
0

Re: resetting Master Category ID for all products in a category = HTTP 406 error!

Thanks for your reply. Yes, I had already applied many of those fixes - I just went ahead now and caught a few more that looked relevant, but still no luck.

I've already managed doing this another way, running some SQL queries and then updating products_price_sorter for everything... so this is less urgent now :)

Still, the "HTTP 406" message seems so obscure (never encountered it or even heard about it until today) - guess I'll do some reading up on this one...

18 Nov 2009, 3:02 AM
#4
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: resetting Master Category ID for all products in a category = HTTP 406 error!

That 406 error should have an entry in your webserver's "error_log" file, which will tell you why it gave you a 406 error. Likely a mod_security rule your hosting company has set up.

18 Nov 2009, 3:25 AM
#5
bodyjewelrystores avatar

bodyjewelrystores

Zen Follower

Join Date:
Jun 2006
Posts:
123
Plugin Contributions:
0

Re: resetting Master Category ID for all products in a category = HTTP 406 error!

That was my first thought, after I did some googling... but then I found that my simple dev server (on which the same problem happens) doesn't even have mod_security.

I also cannot find any other info in the logs, only what I posted above... same format on the live site, more or less. I'll talk to our hosts though, they've been good to us so far (it's a Zen Certified host), hopefully this will be taken care of. Thanks.