Zen Cart Logo
Forums / Addon Payment Modules / Authorize.net AIM problem: 502 Bad Gateway error

Authorize.net AIM problem: 502 Bad Gateway error

Locked

Views: 3,039

Results 1 to 4 of 4
This thread is locked. New replies are disabled.
24 Nov 2009, 11:55 PM
#1
mateogp avatar

mateogp

New Zenner

Join Date:
Sep 2007
Location:
Frankfort, Illinois, United States
Posts:
21
Plugin Contributions:
0

Authorize.net AIM problem: 502 Bad Gateway error

Hello all,

I'm rather frusterated with this as ive been trying different ways to fix this all day.

I'm using authorize.net AIM to process my zencart transactions version 1.3.8.

When I go to check out it processes the transaction correctly but instead of returning me back to the shopping cart it gives me a 502 Bad Gateway error. Any ideas on where to look or how to fix this problem?

Ive searched google and these forums for similar problems and i cant find anything :wacko:

Any help would be appreciated!

Zencart version: 1.3.8 Fresh install
No addons

I get these emails from zencart everytime a test transaction is made:
Nov-24-2009 05:48:06

Response Code: 1.
Response Text: (TESTMODE) This transaction has been approved.

Sending to Authorizenet: Array
(
[x_login] => *******
[x_tran_key] => *******
[x_relay_response] => FALSE
[x_delim_data] => TRUE
[x_delim_char] => |
[x_encap_char] => *
[x_version] => 3.1
[x_type] => AUTH_CAPTURE
[x_method] => CC
[x_amount] => 94.95
[x_currency_code] => USD
[x_card_num] => XXXXXXXXXXXXX0027
[x_exp_date] => 0114
[x_card_code] => ****
[x_email_customer] => FALSE
[x_email_merchant] => FALSE
[x_cust_id] => 1
[x_invoice_num] => 21-ZpJgWv
[x_first_name] => Ma
[x_last_name] => Jaj
[x_company] =>
[x_address] => 18909 Meadowview Dr
[x_city] => Moken
[x_state] => Illinois
[x_zip] => 60048
[x_country] => United States
[x_phone] => 6309996666
[x_email] => [email protected]
[x_ship_to_first_name] =>
[x_ship_to_last_name] =>
[x_ship_to_address] =>
[x_ship_to_city] =>
[x_ship_to_state] =>
[x_ship_to_zip] =>
[x_ship_to_country] =>
[x_description] => Tuxedo Rental (qty: 1)
[x_recurring_billing] => NO
[x_customer_ip] => 173.161.47.30
[x_po_num] => Nov-24-2009 05:48:03
[x_freight] => 0.00
[x_tax_exempt] => FALSE
[x_tax] => 0.00
[x_duty] => 0
[Date] => November 24, 2009, 5:48 pm
[IP] => 173.161.47.30
[Session] => 2ccd11e9be1bd472372753faa4b1249f
[url] => https://secure.authorize.net/gateway/transact.dll
)

Results Received back from Authorizenet: Array
(
[0] => Response from gateway
[1] => 1
[2] => 1
[3] => 1
[4] => (TESTMODE) This transaction has been approved.
[5] => 000000
[6] => P
[7] => 0
[8] => 21-ZpJgWv
[9] => Tuxedo Rental (qty: 1)
[10] => 94.95
[11] => CC
[12] => auth_capture
[13] => 1
[14] => Ma
[15] => Jaj
[16] =>
[17] => 18909 Meadowcruise Dr
[18] => Moken
[19] => Indiana
[20] => 60048
[21] => United States
[22] => 6309996666
[23] =>
[24] => [email protected]
[25] =>
[26] =>
[27] =>
[28] =>
[29] =>
[30] =>
[31] =>
[32] =>
[33] => 0.0000
[34] => 0.0000
[35] => 0.0000
[36] => FALSE
[37] => Nov-24-2009 05:48:03
[38] => 222DB3472CC65CBCCA757902A6A27326
[39] =>
[40] =>
[41] =>
[42] =>
[43] =>
[44] =>
[45] =>
[46] =>
[47] =>
[48] =>
[49] =>
[50] =>
[51] =>
[52] =>
[53] =>
[54] =>
[55] =>
[56] =>
[57] =>
[58] =>
[59] =>
[60] =>
[61] =>
[62] =>
[63] =>
[64] =>
[65] =>
[66] =>
[67] =>
[68] =>
[69] => November 24, 2009, 5:48 pm
[70] => 173.161.47.30
[71] => 2ccd11e9be1bd472372753faa4b1249f
[Expected-MD5-Hash] => 222DB3472CC65CBCCA757902A6A27326
[HashMatchStatus] => PASS
)

CURL communication info: Array
(
[url] => https://secure.authorize.net/gateway/transact.dll
[content_type] => text/html
[http_code] => 200
[header_size] => 237
[request_size] => 1088
[filetime] => -1
[ssl_verify_result] => 20
[redirect_count] => 0
[total_time] => 2.5
[namelookup_time] => 0
[connect_time] => 0.094
[pretransfer_time] => 2.406
[size_upload] => 0
[size_download] => 549
[speed_download] => 219
[speed_upload] => 0
[download_content_length] => 549
[upload_content_length] => 0
[starttransfer_time] => 2.5
[redirect_time] => 0
)

RAW data received:
1|1|1|(TESTMODE) This transaction has been
approved.
|000000|P|0|21-ZpJgWv|Tuxedo Rental (qty:
1)
|94.95|CC|auth_capture|1|Ma|Jaj||18909 Meadowview
Dr
|Moken|Illinois|60048|United
States
|6309996666|
|[email protected]|||||||||0.0000|0.0000|0.0000|FALSE|Nov-24-2009
05:48:03
|222DB3472CC65CBCCA757902A6A27326|||||||||||||||||||||||||||||||November
24, 2009, 5:48 pm
|173.161.47.30|2ccd11e9be1bd472372753faa4b1249f

25 Nov 2009, 3:58 AM
#2
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Authorize.net AIM problem: 502 Bad Gateway error

mateogp:

... it gives me a 502 Bad Gateway error. Any ideas on where to look or how to fix this problem?
Everything I've read on "502" errors points to something wrong with either the server or the hosting company's firewall or internet connection.
Maybe they've got a bad proxy server somewhere?
Maybe they've got an equipment failure?
Maybe they've got a software configuration problem somewhere?

I don't think there's much that you can do to fix it, other than log a ticket with your hosting company.
You might want to clear your browser cache and reboot and see if it continues.
Also, check whether the problem occurs from a PC in another neighbourhood over a different ISP connection.

26 Nov 2009, 2:16 AM
#3
mateogp avatar

mateogp

New Zenner

Join Date:
Sep 2007
Location:
Frankfort, Illinois, United States
Posts:
21
Plugin Contributions:
0

Re: Authorize.net AIM problem: 502 Bad Gateway error

Just an update, and a thanks for your reply! I appreciate it.

What a pain that whole thing has been!! I tried and tried and tried and couldnt get past that error, two days wasted.

So I reinstalled everything all over again after backing up my the database, I transferred all the database files over and BAM once again same problem.

So I restored my backup of the new install and just transferred products and their attributes. Reenabled SSL and WOOHOOO its working.

Therefore all I can figure out is it must have been a setting I changed.. and I cant figure out where I changed it. But whichever it was, it solved my problem and I'm a very happy camper now.

I'm glad it wasnt the server because we have our own dedicated server which is very quick and only hosts our sites. No system admin to go complaining too!

Thanks again,
Matt:clap:

26 Nov 2009, 2:40 AM
#4
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Authorize.net AIM problem: 502 Bad Gateway error

If you don't mind sharing a copy of both of your backups (broken and working), I'd like to investigate further just in case there's something we can do to prevent it in the future.
PM me if you're interested.