Forums / Installing on a Linux/Unix Server / urgent help please - broken cuz php 5.2.11

urgent help please - broken cuz php 5.2.11

Locked

Views: 2,421

Results 1 to 14 of 14
This thread is locked. New replies are disabled.
23 Dec 2009, 1:49 AM
#1
deado avatar

deado

New Zenner

Join Date:
Dec 2005
Posts:
36
Plugin Contributions:
0

urgent help please - broken cuz php 5.2.11

Hello heroes,

IMPORTANT AND URGENT HELP PLEASE!
We used to be on FreeBSD 4.8 - zencart 1.3.1 and PHP 5.0.4 - ALL WORKS great and for several years.

We decided to move servers to a newer one,
So now we are on
FreeBSD 7.2
MySql-4.1.25
PHP 5.2.11
and latest ZenCart version 1.3.8a

If I run my existing website, nothing works. when you try to view the website. no frames, no templates
all broken, just plain texts.

I tried a new/fresh install
same happenes, nothing works, even in install process when i reach
ZenCart- Store Setup
It complains as follow:

Store name is empty more info...
Store owner is empty more info...
Store email address is empty more info...
Store email address is not valid more info...
Store address is empty more info...

When ofcourse all the above information are filled.

Again, when i try to browse to the website, I just see plain texts and texts with links..
no frames no template.

PLEASE solution PLEASE, i cannot downgrade to php5.9 I will have to uninstall half of depencies that might break
most of things, apache..etc..:(

note: I have tried the PHP5.3 patch, nothing works, I googled nothing works...

I can send for you the website name/ip.

Please gurus Urgent help,
the deadline time for the old server is 26 December.

-Marwan.

23 Dec 2009, 5:46 AM
#2
tino_schlegel avatar

tino_schlegel

Totally Zenned

Join Date:
Nov 2007
Location:
Melbourne, Australia
Posts:
532
Plugin Contributions:
0

Re: urgent help please - broken cuz php 5.2.11

First of all, i dont think that PhP is the reason for your peoblems.

When you say you just moved from Zencart 1.3.1 to latest version. How did you do this?

Does a new installation of Zencart 1.3.8 works on this server?

23 Dec 2009, 5:57 AM
#3
rodg avatar

rodg

Deceased

Join Date:
Jan 2007
Location:
Australia
Posts:
6,263
Plugin Contributions:
4

Re: urgent help please - broken cuz php 5.2.11

deado:

We decided to move servers to a newer one,
So now we are on
FreeBSD 7.2
MySql-4.1.25
PHP 5.2.11
and latest ZenCart version 1.3.8a
.

That combination should work without any issues.

deado:

If I run my existing website, nothing works. when you try to view the website. no frames, no templates
all broken, just plain texts.
.

OK, so which is it "nothing works" or "just plain texts" ?

The "just plain texts" will probably be a lot easier to solve than "nothing works", and each will have their own unique possible cause.

deado:

I tried a new/fresh install
same happenes, nothing works, even in install process when i reach
ZenCart- Store Setup
It complains as follow:

Store name is empty more info...

This sounds like you are describing two different problems, and although I'd expect more or different errors, this one sounds like your database has missing data. The "just plain texts" problem sounds like you may have missing template files.

deado:

When ofcourse all the above information are filled.

You may know that, but does zencart? In other words, did you correctly edit the configure files when you moved servers so that they contain the new information? Have database tables prefix's been change when moving servers?

deado:

Again, when i try to browse to the website, I just see plain texts and texts with links..
no frames no template.

Did your template files get uploaded to the correct location? Are the file permissions correct?

deado:

PLEASE solution PLEASE,

I don't think we can give you a solution, just a few suggestions for things you need to check.

deado:

i cannot downgrade to php5.9

php5.9? It doesn't exist.

deado:

note: I have tried the PHP5.3 patch,

Didn't you state you were running PHP 5.2.11? I'm not going to say this is fact, but running the zencart 5.3 patch could possibly cause problems if you are only running v5.2.

deado:

nothing works, I googled nothing works...

I just googled "nothing works" and got **102,000,000 **results. One of those is sure to cover your situation:D

deado:

I can send for you the website name/ip.

It could help. At least we'll be able to see 'nothing wotking' and possibly even the "plain texts" and will be able to make a little more sense of it.

Cheers
Rod

NOTE: We are sorry that Rod is no longer with us.
We are grateful for all his contributions to the Zen Cart community.

Ozpost - The Ultimate Shipping module for Australian Merchants. Click these links for its Homepage, or Download from Zen-Cart.com.

23 Dec 2009, 7:04 AM
#4
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: urgent help please - broken cuz php 5.2.11

RodG:

Didn't you state you were running PHP 5.2.11? I'm not going to say this is fact, but running the zencart 5.3 patch could possibly cause problems if you are only running v5.2.
The changes to suit PHP 5.3 will work fine with PHP 5.2, but are unnecessary.
Since they change files that also have other bugfixes posted and thus would require merging, it's not recommended to apply the PHP 5.3 patches unless actually running on PHP 5.3

.
Zen Cart - putting the dream of business ownership within reach of anyone!
Donate to: DrByte directly or to the Zen Cart team as a whole

Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

23 Dec 2009, 1:28 PM
#5
deado avatar

deado

New Zenner

Join Date:
Dec 2005
Posts:
36
Plugin Contributions:
0

Re: urgent help please - broken cuz php 5.2.11

Gurus,

I did several installation to ZenCart since old versions. its the first time I see such problem.
Actually, I bought the zencart manual long time ago, you can say its saved in my brain :)

Forget about moving the old zencart to new server.
Lets talk about fresh installation on the new server, with the specification i wrote above.

1- file permissions are correct.
2- Im now trying on a fresh installation.
3- when you browse the site, "plain texts" mean no frames, no templates..well i sent for you the site:)
4- I applied the patches after I read about it that its okay with previous versions.

I REALLY APPRECIATE YOUR WORK.

23 Dec 2009, 4:55 PM
#6
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: urgent help please - broken cuz php 5.2.11

What's the URL?

Possible related FAQ: https://www.zen-cart.com/tutorials/index.php?article=235

.
Zen Cart - putting the dream of business ownership within reach of anyone!
Donate to: DrByte directly or to the Zen Cart team as a whole

Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

23 Dec 2009, 5:05 PM
#7
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: urgent help please - broken cuz php 5.2.11

You have no stylesheets in your active template, and you are missing language files.
This suggests that you've got a bad upload. Re-upload everything, and double-check that all files upload successfully.

.
Zen Cart - putting the dream of business ownership within reach of anyone!
Donate to: DrByte directly or to the Zen Cart team as a whole

Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

24 Dec 2009, 12:52 AM
#8
deado avatar

deado

New Zenner

Join Date:
Dec 2005
Posts:
36
Plugin Contributions:
0

Re: urgent help please - broken cuz php 5.2.11

DrByte,

Thank you for your followup, I really appreciate it,
1- The link https://www.zen-cart.com/tutorials/index.php?article=235 - didnot help
2- Limit is already configured in AllowOverride in apache.
3- Template and language files, exist and everything has the right permissions.
4- I didnot download and then upload, I have downloaded the ZenCart from the direct link rightaway to the server
using lynx browser.

Now its as its, 2 problems.
1- No stylesheets loading (I guess).
2- during installation always complains as follow :

Store name is empty more info...
Store owner is empty more info...
Store email address is empty more info...
Store email address is not valid more info...
Store address is empty more info...

When ofcourse all the above information are filled.

RodG - Yes i googled this problem, and found out ONLY one link that someone complains as same as my problem
but no one answered him. - I hope its not the case here.

PLEASE i really appreciate your help.

-Marwan.

24 Dec 2009, 9:38 AM
#9
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: urgent help please - broken cuz php 5.2.11

Clearly the software isn't able to find the stylesheet and language files. That could be a permissions issue or a missing-files issue. If you're 100% certain the files are present on the server and in the appropriate locations, then you've clearly got a permissions problem which is blocking access to the files.
Try using a regular FTP program to upload the files after you've unzipped them on your PC.
I'm wondering whether your use of lynx or directly managing files on the server might be creating some group/folder/ownership/permissions problems.
And what happens if you rename all the .htaccess files to htaccess_OFF temporarily?

.
Zen Cart - putting the dream of business ownership within reach of anyone!
Donate to: DrByte directly or to the Zen Cart team as a whole

Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

24 Dec 2009, 8:09 PM
#10
deado avatar

deado

New Zenner

Join Date:
Dec 2005
Posts:
36
Plugin Contributions:
0

Re: urgent help please - broken cuz php 5.2.11

Hello Dr.

I already tried to rename all the .htaccess files to htaccess_OFF temporarily, but the case still as its.
I have even tried to add in apache the line AddType text/css .css maybe it does something
but case still as its..

No stylesheet loading, and still complain :
Store name is empty more info...
Store owner is empty more info...
Store email address is empty more info...
Store email address is not valid more info...
Store address is empty more info...

When ofcourse all the above information are filled.

Anything PHP to do with stylesheet? any Dependencies packages should be installed?
any special configuration in apache.?

I have copied the same httpd.conf from old to new server, so apache should be good to go..

Im lost now..

25 Dec 2009, 12:38 AM
#11
deado avatar

deado

New Zenner

Join Date:
Dec 2005
Posts:
36
Plugin Contributions:
0

Re: urgent help please - broken cuz php 5.2.11

I see this in my zencart log file:
zen_banner_exists() ? preg_match() ? function size() ?

Is this version compataible with PHP 5.2.11 ?

[Wed Dec 23 01:47:31 2009] [error] [client xx.xx.xx.xx] PHP Warning: preg_match() [<a href='function.preg-match'>function.preg-match</a>]: Internal pcre_fullinfo() error -3 in /usr/home/webpages/808shop/808shopv1.3.8a/admin/includes/init_includes/init_file_db_names.php on line 39
[Wed Dec 23 01:47:31 2009] [error] [client xx.xx.xx.xx.xx] PHP Warning: preg_match() [<a href='function.preg-match'>function.preg-match</a>]: Internal pcre_fullinfo() error -3 in /usr/home/webpages/808shop/808shopv1.3.8a/admin/includes/init_includes/init_file_db_names.php on line 39

[Thu Dec 24 22:33:43 2009] [error] [client xx.xx.xx.xx] client denied by server configuration: /usr/home/webpages/808shop/zencart/includes/templates/template_default/css/index.php

[Thu Dec 24 22:36:14 2009] [error] [client xx.xx.xx.xx] PHP Notice: Use of undefined constant HEADING_TITLE - assumed 'HEADING_TITLE' in /usr/home/webpages/808shop/template_default/templates/tpl_account_default.php on line 18, referer: http://xx.xx.xx.xx/template_default/templates/

[Thu Dec 24 22:36:14 2009] [error] [client xx.xx.xx.xx] PHP Notice: Undefined variable: messageStack in /usr/home/webpages/808shop/template_default/templates/tpl_account_default.php on line 19, referer: http://xx.xx.xx.xx/template_default/templates/

[Thu Dec 24 22:36:14 2009] [error] [client xx.xx.xx.xx] PHP Fatal error: Call to a member function size() on a non-object in /usr/home/webpages/808shop/template_default/templates/tpl_account_default.php on line 19, referer: http://xx.xx.xx.xx/template_default/templates/

[Thu Dec 24 22:36:29 2009] [error] [client xx.xx.xx.xx] PHP Fatal error: Call to undefined function zen_banner_exists() in /usr/home/webpages/808shop/template_default/sideboxes/tpl_banner_box.php on line 13, referer: http://xx.xx.xx.xx/template_default/sideboxes/

[Thu Dec 24 22:36:33 2009] [error] [client xx.xx.xx.xx] PHP Notice: Undefined variable: box_id in /usr/home/webpages/808shop/template_default/sideboxes/tpl_information.php on line 12, referer: http://xx.xx.xx.xx/template_default/sideboxes/

[Thu Dec 24 22:36:33 2009] [error] [client xx.xx.xx.xx] PHP Notice: Undefined variable: information in /usr/home/webpages/808shop/template_default/sideboxes/tpl_information.php on line 14, referer: http://xx.xx.xx.xx/template_default/sideboxes/

26 Dec 2009, 2:11 AM
#12
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: urgent help please - broken cuz php 5.2.11

deado:

Is this version compataible with PHP 5.2.11 ?You're suggesting that this is a Zen Cart problem ... but the error message is coming from your PHP configuration, not from Zen Cart:> deado:

[Wed Dec 23 01:47:31 2009] [error] [client xx.xx.xx.xx] PHP Warning: preg_match() [<a href='function.preg-match'>function.preg-match</a>]: Internal pcre_fullinfo() error -3Seems like you've got a configuration problem related to PCRE in your PHP setup.
Possible related article, found by googling: http://lists.freebsd.org/pipermail/freebsd-questions/2009-October/205977.html

.
Zen Cart - putting the dream of business ownership within reach of anyone!
Donate to: DrByte directly or to the Zen Cart team as a whole

Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

26 Dec 2009, 8:40 PM
#13
deado avatar

deado

New Zenner

Join Date:
Dec 2005
Posts:
36
Plugin Contributions:
0

Re: urgent help please - broken cuz php 5.2.11

No No No i didn’t mean at all or suggest its zencart problem!
maybe there are no people complaining from zencart and FreeBSD 7.2-R because its a new release version.

And believe me, my issue will face any new installation, with same specification.
as i setup a virtual server at home as the real one to make
my tests, and guess what? same problems.. take a note box is up to date in all meanings..

ports tree, src tree, patches and bugs.. but probably im the first one to complain.
Because it’s a new release.

However, I get ride of the php errors, but same results no stylesheet loading.

and this post will help many others in future.

The problem somewhere in apache version, mysql, maybe php? but no errors in log anymore..
there is something wrong in packages compatibility.

-Marwan

DrByte:

You're suggesting that this is a Zen Cart problem ... but the error message is coming from your PHP configuration, not from Zen Cart:Seems like you've got a configuration problem related to PCRE in your PHP setup.
Possible related article, found by googling: http://lists.freebsd.org/pipermail/freebsd-questions/2009-October/205977.html

27 Dec 2009, 12:09 AM
#14
deado avatar

deado

New Zenner

Join Date:
Dec 2005
Posts:
36
Plugin Contributions:
0

Re: urgent help please - broken cuz php 5.2.11

OKAY! EVERYONE! - HEADS UP!

UPDATE for everyone facing this problem.

ZENCART will not work with

APACHE2.0 in FreeBSD 7.2-R - this is confirmed on 3 servers by my self.

Seems for somehow apache2 behavior is not stable.


SOLUTION IS (in short words)

INSTALL apache22 NOT apache2.0 - recompile php5, and php5-extensions.

I ran into troubles, i had to de-install apache2., therefore i had to recompile php5 with all extensions back!!!
if you are not aware what you are doing you will run into serious problems.

Zencart will not work with Apache20 and to be specific apache-2.0.63_3
(apache-2.0.63_3 is the most recent from ports tree until today Dec 27 2009)

I donot say here there is a problem with zencart and apache,
its a problem with apache2, NOT zencart.

PS: I have tested the admin area and store first use, I didnot run our live store yet.
If there is anything special I will update this post, otherwise all as i wrote above.

Have fun all.

  • Marwan Sultan