Zen Cart Logo
Forums / Installing on a Windows Server / SSI instruction error in your file.

SSI instruction error in your file.

Locked

Views: 1,637

Results 1 to 9 of 9
This thread is locked. New replies are disabled.
7 Jan 2010, 9:30 AM
#1
monsterness avatar

monsterness

New Zenner

Join Date:
Oct 2009
Location:
Dutch,
Posts:
25
Plugin Contributions:
0

SSI instruction error in your file.

I've got an error when using the installer of zencart.
Saying this:

ERREUR SSI
Erreur SSI dans votre fichier
SSI instruction error in your file.

I've made an compleet zen cart layout, imput on my laptop. Just want to put it online now. Have an old OScommerce shop and want to renew it.

The error pops out when I go to the /zc_install
I've tried using other permissions for the files/maps but didn't help out.
The host is icodia.fr (yes french lol sorry) Think it has something to do with host.

Any help is appreciated

11 Jan 2010, 8:16 AM
#2
monsterness avatar

monsterness

New Zenner

Join Date:
Oct 2009
Location:
Dutch,
Posts:
25
Plugin Contributions:
0

Re: SSI instruction error in your file.

Hm was hoping on a reply so will try to explain it more.
Downloaded a new zen cart pack.
Uploaded it with FileZilla
I went to the url. Intro screen started.
Clicked on the Click here to start installation
Error.
Went directly to the install folder
Error

Tried using the manual install from the FAQ on zen cart
Error.

Deleted everything and retried
Error.

I'm not french myself and tried to figure out the icodia.fr
It has a table with all the packets you can buy and it says qui (yes) with SSI so I really don't understand what's wrong. I googled that SSI but no really hits came op. With zen cart this problem never seems to accur.

11 Jan 2010, 8:29 AM
#3
kobra avatar

kobra

Black Belt

Join Date:
Aug 2005
Location:
Arizona
Posts:
31,500
Plugin Contributions:
4

Re: SSI instruction error in your file.

Is this a linux host?
ZenCart requires php and mysql

If OSC is running then ZenCart ahould also

11 Jan 2010, 1:06 PM
#4
monsterness avatar

monsterness

New Zenner

Join Date:
Oct 2009
Location:
Dutch,
Posts:
25
Plugin Contributions:
0

Re: SSI instruction error in your file.

Yeah I thaught cause it already had OSc installed this should be easy. I don't know what operation system the host is using, can't seem to find it. ;( I think it's windows cause on the website there's alot of windows talk :']

As for the php and mysql.
OSc uses a database, MySQL client version: 4.1.24
And for Php the host supports PHP4 / PHP5
On the host website you have a list of the account you can buy
I have the "web pro" pack and it says it should have the SSI

Oh! and ofcourse thanks for post!

12 Jan 2010, 12:19 PM
#5
monsterness avatar

monsterness

New Zenner

Join Date:
Oct 2009
Location:
Dutch,
Posts:
25
Plugin Contributions:
0

Re: SSI instruction error in your file.

Oh god,

I'm sorry for this but just realised they use BSD

Which is a ##########.

12 Jan 2010, 12:31 PM
#6
monsterness avatar

monsterness

New Zenner

Join Date:
Oct 2009
Location:
Dutch,
Posts:
25
Plugin Contributions:
0

Re: SSI instruction error in your file.

I'm thinkin the ssi isn't set properly.
Do any here have some info about contacting hosts about this matter?
Or can I change these things myself.
Really any input is apreciated, kinda left in the dark here.
andproly it's a linux server, I really don't understand it now lo.

PS: sorry for the load of post couldn't edit.

13 Jan 2010, 5:33 AM
#7
kobra avatar

kobra

Black Belt

Join Date:
Aug 2005
Location:
Arizona
Posts:
31,500
Plugin Contributions:
4

Re: SSI instruction error in your file.

BSD is a *nix based system...
What account manager are you provided with?
Common ones are plesk & cPanel

14 Jan 2010, 3:56 PM
#8
monsterness avatar

monsterness

New Zenner

Join Date:
Oct 2009
Location:
Dutch,
Posts:
25
Plugin Contributions:
0

Re: SSI instruction error in your file.

Dear kobra,

First of all thanks for replying.
I have contacted my host icodia.fr cause that seemed faster.
Apparently they are so secured that they didn't allow the following text in the /zc_install/.htaccess

<IfModule mod_security.c> SecFilterEngine Off SecFilterScanPOST Off </IfModule>

If for some reason the above doesn't produce the desired results, simply

remove the # from the

following lines:

#SecFilterEngine off
#SecFilterScanPOST Off

As soon as I removed these lines it went to the setup screen.
Hope this helps you understand it a bit. I'm hoping I won't find any of these errors in the further proces.
I will leave a message here tomorrow.

Regards

19 Jan 2010, 12:11 PM
#9
monsterness avatar

monsterness

New Zenner

Join Date:
Oct 2009
Location:
Dutch,
Posts:
25
Plugin Contributions:
0

Re: SSI instruction error in your file.

Bit late eh but better late then never.
Site is online and working,
you can check out an demo of the site here
It's just for show not workin :]