Zen Cart Logo
Forums / General Questions / "client denied by server configuration" when uploading images

"client denied by server configuration" when uploading images

Locked

Views: 2,437

Results 1 to 4 of 4
This thread is locked. New replies are disabled.
13 Jan 2010, 10:41 PM
#1
speedyvespa avatar

speedyvespa

New Zenner

Join Date:
Jun 2004
Posts:
60
Plugin Contributions:
0

"client denied by server configuration" when uploading images

All,

I'm using ZC 1.3.8 plus latest IH2.

Previously my store worked fine. Recently I tried to add more items. When I upload pictures, it sits and spins, eventually timing out. Looking at the error logs in cPanel, I see:

[Wed Jan 13 16:05:52 2010] [error] [client 67.103.220.162] client denied by server configuration: /home/xxxxxx/public_html/shop/includes/templates/classic/images/index.php, referer: http://xxxxxxxxxxxx/shop/index.php?m...=index&cPath=1

Dr. Byte responded in another thread (on another topic):> Meanwhile, I recommend you start a separate thread specific to your problem.

Technically the issue isn't your hosting company.
Apparently you've got something in your template trying to access the index.php file in your template's images folder ... which is naturally forbidden, and should be.

Well - I previously uploaded new images on precisely this version of ZC and IH2, and it worked fine. I know for a fact that the server software (including Apache) was upgraded, so that's what has changed. That said, assuming that my host won't respond to any support requests (changing hosts soon), can anyone suggest how I can work around it?

I am reading all over the web that this is a server configuration involving either the permissions in the virtual host being too restrictive or "mod_dosevasive/mod_evasive" settings. Do I have access to that in cPanel - anyone know?

Or is there another way around this, as Dr. Byte suggests while I arrange another host?

14 Jan 2010, 1:16 AM
#2
kobra avatar

kobra

Black Belt

Join Date:
Aug 2005
Location:
Arizona
Posts:
31,500
Plugin Contributions:
4

Re: "client denied by server configuration" when uploading images

Double check your template images folder for index.php - - As there should be no php files of any kind in the /images folder

/home/xxxxxx/public_html/shop/includes/templates/classic/images/index.php,
14 Jan 2010, 2:13 AM
#3
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: "client denied by server configuration" when uploading images

No no ...

The issue is that you've got something attempting to access includes/templates/classic/images/index.php. Nothing should be trying to access any .php files in an image folder. So ... whatever you've got in your template that's doing that needs to be fixed.

There's nothing wrong with your "virtual host" or anything like that ... because YOU DO NOT WANT ANY .php FILES TO BE LOADED AS IMAGES!!!!!!
The server is doing exactly what it should.

That server errorlog report has NOTHING to do with the ability to upload images via the admin.

14 Jan 2010, 2:58 AM
#4
mattymatt avatar

mattymatt

Zen Follower

Join Date:
Dec 2009
Location:
Pinner
Posts:
234
Plugin Contributions:
1

Re: "client denied by server configuration" when uploading images

There's two issues.

After applying security patches etc...

a) you can't upload images, check that anyone can write to the images folder
b) the cPanel error logs are showing that access was denied to a file in includes. Which is normal ZC security as no-one should directly be able to access the files.

Now the interesting question is, is there a file there in that folder ? because there shouldn't be. The ip address maps to the USA and h-67-103-220-162.sttnwaho.static.covad.net, if that is "you" then something has affected the image uploading facility.