Zen Cart Logo
Forums / Installing on a Windows Server / Timeout Restoring DB to a WAMP localhost

Timeout Restoring DB to a WAMP localhost

Locked

Views: 3,150

Results 1 to 3 of 3
This thread is locked. New replies are disabled.
26 Jan 2010, 3:22 PM
#1
kcb410 avatar

kcb410

Zen Follower

Join Date:
Dec 2008
Location:
Toronto
Posts:
348
Plugin Contributions:
0

Timeout Restoring DB to a WAMP localhost

I'm running WAMP server and had a successful version of Zen cart running a my Window XP computer. I'm trying update my local version with my actual Zen site so that I can test a mods before installing.

I have exported my database using Phpmyadmin and when I select my local database and drop all the tables and import my actual database I get the following error:

Script timeout passed, if you want to finish import, please resubmit same file and import will resume.

I have tried this twice but get the same error. It's stops at zen_products_attributes every time. There is 61014 rows and it completes approx 23458 before timing out.

Can anyone recommend a solution for this?
I appreciate any help!! Thanks.

26 Jan 2010, 6:34 PM
#2
kobra avatar

kobra

Black Belt

Join Date:
Aug 2005
Location:
Arizona
Posts:
31,500
Plugin Contributions:
4

Re: Timeout Restoring DB to a WAMP localhost

There are a couple of things you can try

goto start ...run and type in cmd

or open a cmd session(DOS Box) navigate to the WAMP and run

mysql databasename < backup.sql

Insure that your backup is loaded there and of course the above is generic -
So if your DB name is kobra and your backup is kobra_shop.sql it would take the form of

mysql kobra < kobra_shop.sql

27 Jan 2010, 2:35 AM
#3
kcb410 avatar

kcb410

Zen Follower

Join Date:
Dec 2008
Location:
Toronto
Posts:
348
Plugin Contributions:
0

Re: Timeout Restoring DB to a WAMP localhost

kobra:

There are a couple of things you can try

goto start ...run and type in cmd

or open a cmd session(DOS Box) navigate to the WAMP and run

mysql databasename < backup.sql

Insure that your backup is loaded there and of course the above is generic -
So if your DB name is kobra and your backup is kobra_shop.sql it would take the form of

mysql kobra < kobra_shop.sql

Prior to checking your reply I was able to import my database using SQLyog without any errors.

Thanks for the recommendation Kobra.