Zen Cart Logo
Forums / General Questions / backup and restore

backup and restore

Locked

Views: 1,837

Results 1 to 11 of 11
This thread is locked. New replies are disabled.
7 Feb 2010, 1:38 PM
#1
marketimpact avatar

marketimpact

Zen Follower

Join Date:
Aug 2009
Location:
England
Posts:
93
Plugin Contributions:
0

backup and restore

hi there

i am moving to new hosting servers and i need to backup my shop and then restore it.

i have backed up the store and i have reinstalled the shop on the new servers but i was wondering how do i upload all the products and catagries i had on my old shop and upload to my new shop?

Alex

7 Feb 2010, 2:05 PM
#2
niccol avatar

niccol

Totally Zenned

Join Date:
Apr 2009
Posts:
2,138
Plugin Contributions:
1

Re: backup and restore

You need to copy the database.

You can do this directly using phMYAdmin or you can try using an add-on that is called something like "backup MYSQL"

Be aware that if you copy the entire database all the condiguration options will be copied too. Including, for instance, the admin passwords.

8 Feb 2010, 9:19 AM
#3
marketimpact avatar

marketimpact

Zen Follower

Join Date:
Aug 2009
Location:
England
Posts:
93
Plugin Contributions:
0

Re: backup and restore

ok

i tried doing the backup MYSQL, an error comes up saying "ERROR: Your server's "exec()" command has been disabled. This script cannot run. Ask your host if they are willing to re-enable PHP exec()."

What does it mean? How do I get it to work?

Alex

8 Feb 2010, 9:23 AM
#4
marketimpact avatar

marketimpact

Zen Follower

Join Date:
Aug 2009
Location:
England
Posts:
93
Plugin Contributions:
0

Re: backup and restore

also when i try doing a restore using myphp on the control panel it came up with

Error

SQL query:

--
-- Database: theishop_afbfm


--
-- Table structure for table after_login

CREATE TABLE IF NOT EXISTS after_login (
id int( 11 ) NOT NULL AUTO_INCREMENT ,
nr_days int( 11 ) NOT NULL default '0',
count int( 11 ) NOT NULL default '0',
message longblob NOT NULL ,
active tinyint( 4 ) NOT NULL default '0',
membership varchar( 255 ) NOT NULL default '',
PRIMARY KEY ( id )
) ENGINE = MYISAM DEFAULT CHARSET = latin1 AUTO_INCREMENT =1;

MySQL said: Documentation
#1046 - No database selected

Please help ASAP

Alex

8 Feb 2010, 9:43 AM
#5
schoolboy avatar

schoolboy

Totally Zenned

Join Date:
Jun 2005
Location:
Cumbria, UK
Posts:
10,327
Plugin Contributions:
0

Re: backup and restore

There is no table in zencart called "after_login"... What other programs do you have installed that use a database?

8 Feb 2010, 9:45 AM
#6
schoolboy avatar

schoolboy

Totally Zenned

Join Date:
Jun 2005
Location:
Cumbria, UK
Posts:
10,327
Plugin Contributions:
0

Re: backup and restore

...Or what add-on modules have you installed that may have added this table to the database?

8 Feb 2010, 10:02 AM
#7
marketimpact avatar

marketimpact

Zen Follower

Join Date:
Aug 2009
Location:
England
Posts:
93
Plugin Contributions:
0

Re: backup and restore

i have loads of modules added to my database.

is it easier to upload the modules before i import databases?

8 Feb 2010, 10:16 AM
#8
schoolboy avatar

schoolboy

Totally Zenned

Join Date:
Jun 2005
Location:
Cumbria, UK
Posts:
10,327
Plugin Contributions:
0

Re: backup and restore

Have you managed to make a copy of the database yet - not a BACKUP... but a COPY...

You may find it easier if you have a COPY rather than a BACKUP.

Do you have access to phpMyAdmin through your current C-Panel?

PM me if you're battling with this. I have a bit of time available this morning and may be able to help...

8 Jun 2010, 2:32 PM
#9
mydreams avatar

mydreams

New Zenner

Join Date:
Jul 2009
Posts:
12
Plugin Contributions:
0

Re: backup and restore

dear schoolboy,

i also faced the same problem. can you help me ?

i got this error :
"ERROR: Your server's "exec()" command has been disabled. This script cannot run. Ask your host if they are willing to re-enable PHP exec()."

after add backup mySQL module.

How to handle it ?

thanks in advance

8 Jun 2010, 2:44 PM
#10
niccol avatar

niccol

Totally Zenned

Join Date:
Apr 2009
Posts:
2,138
Plugin Contributions:
1

Re: backup and restore

From the read me file of the mod:

CAVEATS: This tool does not work on servers running in strict safe_mode,

or with open.basedir restrictions in effect, or with restrictions against

using "exec()" commands. There is no way to work around these limitations

without turning off the restrictions on your server. Contact your host

for more information on such possibilities.

The best way round this is to not use the mod and backup the database directly using phpMyAdmin or a similar utility.

25 Aug 2010, 9:28 AM
#11
ztotheetothen avatar

ztotheetothen

Zen Follower

Join Date:
Oct 2006
Location:
Los Angeles
Posts:
111
Plugin Contributions:
0

Re: backup and restore

i get the same error while doing mysql backup:

ERROR: Your server's "exec()" command has been disabled. This script cannot run. Ask your host if they are willing to re-enable PHP exec().

i have a dedicated server so i do have access to all the controls, but do not know where to enable this configuration. thank you for your help.