Zen Cart Logo
Forums / Installing on a Linux/Unix Server / Error moving to live server.

Error moving to live server.

Locked

Views: 1,249

Results 1 to 7 of 7
This thread is locked. New replies are disabled.
16 Feb 2010, 9:12 PM
#1
leg avatar

leg

New Zenner

Join Date:
May 2007
Posts:
36
Plugin Contributions:
0

Error moving to live server.

I have worked on a local server whilst creating my shop and have now attempted to move it to my server. I have followed this thread for this. When I have completed the process (I have done it twice now) I have the error

A file permissions error has occurred. Please check the permissions on the script and the directory it is in and try again.
```I can't seem to find what the problem is. I have noticed that php is implemented as cgi on my Linux server could this be the problem and how do I get around it.
16 Feb 2010, 9:17 PM
#2
leg avatar

leg

New Zenner

Join Date:
May 2007
Posts:
36
Plugin Contributions:
0

Re: Error moving to live server.

Ok sorry for troubling you and forgetting to post the address but it is fixed now anyway and I am not sure what I did to fix it.

16 Feb 2010, 9:43 PM
#3
leg avatar

leg

New Zenner

Join Date:
May 2007
Posts:
36
Plugin Contributions:
0

Re: Error moving to live server.

Well it appears that I do need some advice on this as I have the problem in the admin section. Any ideas what to do to fix it.

17 Feb 2010, 9:23 AM
#4
leg avatar

leg

New Zenner

Join Date:
May 2007
Posts:
36
Plugin Contributions:
0

Re: Error moving to live server.

I have place the debug utility into the admin/extra_configures dir but it doesn't give me anything at all so can't be getting to that point even. So I have looked at the permissions and everything is on 755. I changed index.php (in admin) to 644 but no difference. I will check the logs now I think. has no-one had this before?

17 Feb 2010, 9:43 AM
#5
leg avatar

leg

New Zenner

Join Date:
May 2007
Posts:
36
Plugin Contributions:
0

Re: Error moving to live server.

I see nothing in the error logs about an error accessing the admin area. The access logs shows

"GET /admin HTTP/1.0" 301 306 "-"
```but is always followed by a 

"GET /admin/ HTTP/1.0" 200 123 "-"

A file permissions error has occurred. Please check the permissions on the script and the directory it is in and try again.

17 Feb 2010, 10:21 AM
#6
leg avatar

leg

New Zenner

Join Date:
May 2007
Posts:
36
Plugin Contributions:
0

Re: Error moving to live server.

I have found that php_value directives in .htaccess files are said not to work when php is set as cgi module. I have looked in the admin area but the directives are commented out. Is there a similar affect from the php scripts themselves?

17 Feb 2010, 11:25 AM
#7
leg avatar

leg

New Zenner

Join Date:
May 2007
Posts:
36
Plugin Contributions:
0

Re: Error moving to live server.

Changing the permissions of admin/login.php to 644 has sorted it for me. Subsequently all other files also.