Forums / General Questions / Disabling hotlink protection gives 404 errors on my whole site

Disabling hotlink protection gives 404 errors on my whole site

Locked

Views: 2,160

Results 1 to 7 of 7
This thread is locked. New replies are disabled.
22 Feb 2010, 1:34 PM
#1
faeriescraps avatar

faeriescraps

New Zenner

Join Date:
Feb 2010
Posts:
24
Plugin Contributions:
0

Disabling hotlink protection gives 404 errors on my whole site

Hi

I have a similar problem to a lot of people in that my header doesn't show up in emails, so I looked in the forum and followed the suggestions given. I'm using version 1.3.8a and am on a Linux server.

I have hotlink protection enabled in my cpanel and so I disabled it and the header shows up now, BUT my whole site doesn't work when this is disabled. Every page gives me the following message:-

Not Found

The requested URL /zen-cart-templates-c-2.html was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request. :oops:

I have re-enabled the hotlink protection and my site is working again but of course the header no longer shows up in emails.

Can anyone help me to fix this as I would like to have a working site and the header showing in my emails but right now I have to choose one or the other.

Thanks in advance :smile:

22 Feb 2010, 2:43 PM
#2
schoolboy avatar

schoolboy

Totally Zenned

Join Date:
Jun 2005
Location:
Cumbria, UK
Posts:
10,327
Plugin Contributions:
0

Re: Disabling hotlink protection gives 404 errors on my whole site

This is not the whole story...

You have probably put in a SEO module...

These are a waste of time, and are unnecessary.

My advice is to get rid of it.

20 years a Zencart User

22 Feb 2010, 2:54 PM
#3
faeriescraps avatar

faeriescraps

New Zenner

Join Date:
Feb 2010
Posts:
24
Plugin Contributions:
0

Re: Disabling hotlink protection gives 404 errors on my whole site

OK, I will have to check that as my zen cart was installed by someone else, so I don't know if I have that or not.

Can you tell me where I would find it so that I can get rid of it please?

Thanks :smile:

22 Feb 2010, 3:28 PM
#4
schoolboy avatar

schoolboy

Totally Zenned

Join Date:
Jun 2005
Location:
Cumbria, UK
Posts:
10,327
Plugin Contributions:
0

Re: Disabling hotlink protection gives 404 errors on my whole site

Before further suggestions are made, it is necessary for you to get a FULL, DETAILED REPORT from the person who built your website, indicating what has been added to the standard software, and what customized configurations have been done.

If you paid a person/organization to configure your installation, the least you can expect from them (if they don't offer on-going support) is a document detailing the nature of the work they've done.

In this way, you have a record of the customizations, and can pass this information on to others, who can then make informed judgements as to how to resolve problems.

20 years a Zencart User

22 Feb 2010, 4:26 PM
#5
faeriescraps avatar

faeriescraps

New Zenner

Join Date:
Feb 2010
Posts:
24
Plugin Contributions:
0

Re: Disabling hotlink protection gives 404 errors on my whole site

OK will do

Thanks :smile:

22 Feb 2010, 9:10 PM
#6
faeriescraps avatar

faeriescraps

New Zenner

Join Date:
Feb 2010
Posts:
24
Plugin Contributions:
0

Re: Disabling hotlink protection gives 404 errors on my whole site

I've emailed them and am waiting for a reply.

Thanks :smile:

24 Feb 2010, 2:20 PM
#7
faeriescraps avatar

faeriescraps

New Zenner

Join Date:
Feb 2010
Posts:
24
Plugin Contributions:
0

Re: Disabling hotlink protection gives 404 errors on my whole site

The person who installed the site is also my host and they have fixed everything so thanks for the information you gave me which I passed on to them so they could fix it :smile: