Zen Cart Logo
Forums / General Questions / getting kicked out of my admin area

getting kicked out of my admin area

Locked

Views: 1,721

Results 1 to 14 of 14
This thread is locked. New replies are disabled.
16 Mar 2010, 6:34 PM
#1
nehoward64 avatar

nehoward64

Zen Follower

Join Date:
Mar 2010
Location:
Battle Creek, MI
Posts:
124
Plugin Contributions:
0

getting kicked out of my admin area

Hey folks, I have finally stumbled through my basic setup and have things configured the way I want them(1.3.8a). Ran into a new problem though..... In admin/catalog/catagories and products it allows me to create product catagories just fine, but when I try to create a new product I get kicked completely out of my site and land at my webhosting home page... any ideas or thoughts?

16 Mar 2010, 6:38 PM
#2
kobra avatar

kobra

Black Belt

Join Date:
Aug 2005
Location:
Arizona
Posts:
31,500
Plugin Contributions:
4

Re: getting kicked out of my admin area

Expand upon what changes to the install you have made??

Like security patches or??

Zen-Venom Get Bitten

16 Mar 2010, 6:41 PM
#3
nehoward64 avatar

nehoward64

Zen Follower

Join Date:
Mar 2010
Location:
Battle Creek, MI
Posts:
124
Plugin Contributions:
0

Re: getting kicked out of my admin area

the only add on i have made is an 'environmental handling fee' module from Numinix Technology. Could this be the problem?

16 Mar 2010, 6:47 PM
#4
kobra avatar

kobra

Black Belt

Join Date:
Aug 2005
Location:
Arizona
Posts:
31,500
Plugin Contributions:
4

Re: getting kicked out of my admin area

As this is not normal the quickest way is to reload the files using a "GOOD" FTP client that will report any errors in transfer

You can spend the time and install the debug utility from the downloads area and see what errors are generated

Zen-Venom Get Bitten

16 Mar 2010, 6:53 PM
#5
nehoward64 avatar

nehoward64

Zen Follower

Join Date:
Mar 2010
Location:
Battle Creek, MI
Posts:
124
Plugin Contributions:
0

Re: getting kicked out of my admin area

Filezilla didnt report any transfer errors when I uploaded them. The odd thing is is that I am getting booted as soon as I click on the button to 'add product'. My first suspicion was a permission error somewhere so I globally(i know, bad idea) set everything to 777. It's almost as if something is missing somewhere but I have compared the directory structure and files to my backup and everything is there. I may have to re-install my backup and start from there.

16 Mar 2010, 6:59 PM
#6
kobra avatar

kobra

Black Belt

Join Date:
Aug 2005
Location:
Arizona
Posts:
31,500
Plugin Contributions:
4

Re: getting kicked out of my admin area

My first suspicion was a permission error somewhere so I globally(i know, bad idea) set everything to 777.
Depending upon your server config 777 might not be allowed???

Zen-Venom Get Bitten

16 Mar 2010, 7:09 PM
#7
nehoward64 avatar

nehoward64

Zen Follower

Join Date:
Mar 2010
Location:
Battle Creek, MI
Posts:
124
Plugin Contributions:
0

Re: getting kicked out of my admin area

777 works fine on my server, i've used it many times.

OK, I installed the debug utility in BOTH<grin> folders so I could capture the error no matter where it was coming from, went to the menu option in question and let it boot me. No error log was generated! lol Now I'm really wondering what's up.

Oh, and yes, the cache folder is writable(777).

16 Mar 2010, 7:12 PM
#8
kobra avatar

kobra

Black Belt

Join Date:
Aug 2005
Location:
Arizona
Posts:
31,500
Plugin Contributions:
4

Re: getting kicked out of my admin area

Back to square one - - Post your server details

Zen-Venom Get Bitten

17 Mar 2010, 8:14 PM
#9
nehoward64 avatar

nehoward64

Zen Follower

Join Date:
Mar 2010
Location:
Battle Creek, MI
Posts:
124
Plugin Contributions:
0

Re: getting kicked out of my admin area

Sorry I didnt get back to you yesterday, had a family issue pop up. What do you need or mean by server details?

Server Name server28.000########################
IP Address 216.108.239.4
Apache ver. 2.2.13 (Unix)
PHP version 5.2.*
MySQL ver. 5.0.81-community
Activated On 2010-03-08 10:05
Status Active

If that is what you're looking for I have it!

Anyhow, no matter what I do(even did a fresh install with no add-ons) I get kicked out of my admin area everytime I press the 'new product' button in my catalog area. No error is generated with the debug utility. I'm at a bit of a loss at this point.

Maybe I am barking up the wrong tree here, but, when you click the button to add a 'new product' what does zencart look for or look at as far as database files are concerned? Or... could it be something as simple as Norton 360 blocking something zencart tries to do when you attempt to add a new product?

Silly thoughts....

17 Mar 2010, 9:42 PM
#10
cjpinder avatar

cjpinder

Totally Zenned

Join Date:
Apr 2007
Location:
Herts. UK
Posts:
893
Plugin Contributions:
0

Re: getting kicked out of my admin area

nehoward64:

Anyhow, no matter what I do(even did a fresh install with no add-ons) I get kicked out of my admin area everytime I press the 'new product' button in my catalog area.
When you say 'fresh install' was it a completely new install of ZC1.3.8a with a new file set and a new database?

Regards,
Christian.

17 Mar 2010, 10:04 PM
#11
nehoward64 avatar

nehoward64

Zen Follower

Join Date:
Mar 2010
Location:
Battle Creek, MI
Posts:
124
Plugin Contributions:
0

Re: getting kicked out of my admin area

yes, fresh everything... I just went through every directory and file and verified permissions, still having the problem. I'm going to try shutting off my firewall/popup blocker and see if that makes a difference(dont know why it would).

17 Mar 2010, 10:27 PM
#12
nehoward64 avatar

nehoward64

Zen Follower

Join Date:
Mar 2010
Location:
Battle Creek, MI
Posts:
124
Plugin Contributions:
0

Re: getting kicked out of my admin area

ok, the firewall and popup blocker made no difference. just fyi.

17 Mar 2010, 10:47 PM
#13
cjpinder avatar

cjpinder

Totally Zenned

Join Date:
Apr 2007
Location:
Herts. UK
Posts:
893
Plugin Contributions:
0

Re: getting kicked out of my admin area

Very odd. I can't think of anything that would cause that behaviour on a clean v1.3.8a installation.

Have you had a look at the apache error logs?

Could you try a different browser or different PC just to rule them out?

Regards,
Christian.

17 Mar 2010, 11:00 PM
#14
nehoward64 avatar

nehoward64

Zen Follower

Join Date:
Mar 2010
Location:
Battle Creek, MI
Posts:
124
Plugin Contributions:
0

Re: getting kicked out of my admin area

I'm not able to find the apache error logs, where would those be(i may not have access to them).

As for another computer or browser, nope, locked into this one....