Zen Cart Logo
Forums / Basic Configuration / error logs -> file not found /favicon.ico

error logs -> file not found /favicon.ico

Locked

Views: 3,496

Results 1 to 3 of 3
This thread is locked. New replies are disabled.
14 Apr 2010, 2:22 AM
#1
perfect_concepts avatar

perfect_concepts

New Zenner

Join Date:
Apr 2010
Posts:
12
Plugin Contributions:
0

error logs -> file not found /favicon.ico

Something funky is going on with my error logs
I have just repaired a '404 page not found' issue in my .htaccess by adding```
ErrorDocument 404 /index.php?main_page=page_not_found


This is working fine, but my error logs are now showing up with ' ->file not found   /favicon.ico' 
It appears that users linking to my page are landing on 'http://perfectconcepts.com.au/favicon.ico'
I've done some research on it but can't get my head around it.
Any Ideas?
14 Apr 2010, 2:31 AM
#2
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: error logs -> file not found /favicon.ico

Anytime someone bookmarks your page or a browser attempts to show the favicon in the browser address bar (ie: firefox, opera, etc), there will be a request to your server for the favicon.ico file.

If you don't have one, then you'll see errors in your logs saying it couldn't serve the requested file.

The fix is simple: create one.

14 Apr 2010, 3:49 AM
#3
perfect_concepts avatar

perfect_concepts

New Zenner

Join Date:
Apr 2010
Posts:
12
Plugin Contributions:
0

Re: error logs -> file not found /favicon.ico

Thank you DrByte, it seems to have fixed the problem.