Zen Cart Logo
Forums / Built-in Shipping and Payment Modules / LinkPoint "7 - couldn't connect to host"

LinkPoint "7 - couldn't connect to host"

Locked

Views: 1,687

Results 1 to 3 of 3
This thread is locked. New replies are disabled.
16 Apr 2010, 7:55 PM
#1
mazur19 avatar

mazur19

New Zenner

Join Date:
Apr 2010
Posts:
6
Plugin Contributions:
0

LinkPoint "7 - couldn't connect to host"

Hello, I am having problems getting "Linkpoint/YourPay API" working correctly. Right now I have it installed and configured on Zen Cart version 1.3.8a. When using the testing mode for the api and trying to check out, I get the message: "We apologize for the inconvenience, but we are presently unable to contact the Credit Card company for authorization. Please contact the Store Owner for payment alternatives.". My email error log file gives me this error:

Result: proved>FAILURECould not connect.

Communication Result: 7 - couldn't connect to host
CURL info: Array
(
    [url] => https://secure.linkpt.net:1129/LSGSXML
    [content_type] => 
    [http_code] => 0
    [header_size] => 0
    [request_size] => 0
    [filetime] => -1
    [ssl_verify_result] => 0
    [redirect_count] => 0
    [total_time] => 0
    [namelookup_time] => 0.514247
    [connect_time] => 0
    [pretransfer_time] => 0
    [size_upload] => 0
    [size_download] => 0
    [speed_download] => 0
    [speed_upload] => 0
    [download_content_length] => -1
    [upload_content_length] => -1
    [starttransfer_time] => 0
    [redirect_time] => 0
)

I use Green Geeks for hosting, and according to their support, they have opened for 1129 for me. I have the correct .pem file, I downloaded it directly from my First Data account, removed the default pem file in "includes/modules/patment/linkpoint_api" and uploaded the new .pem file. Does anyone have any suggestions?? This is driving me nuts! Thanks.

16 Apr 2010, 8:24 PM
#2
mazur19 avatar

mazur19

New Zenner

Join Date:
Apr 2010
Posts:
6
Plugin Contributions:
0

Re: LinkPoint "7 - couldn't connect to host"

I ended up fixing it. I have tried re-installing the module a few times, but what fixed it was re-downloadeding my .pem file and after I re-installed the payment api with the re-downloaded file, it worked. So I guess it was just a corrupted .pem file.

16 Apr 2010, 9:55 PM
#3
Kim avatar

Kim

Obaa-san

Join Date:
Jun 2003
Location:
West Coast, North America
Posts:
26,627
Plugin Contributions:
0

Re: LinkPoint "7 - couldn't connect to host"

Thank you for the follow up.