Zen Cart Logo
Forums / Upgrading from 1.3.x to 1.3.9 / 500 Internal Server Error when updating Order Status to "Update [4]"

500 Internal Server Error when updating Order Status to "Update [4]"

Locked

Views: 1,770

Results 1 to 4 of 4
This thread is locked. New replies are disabled.
28 Apr 2010, 1:34 AM
#1
rlexyd avatar

rlexyd

Zen Follower

Join Date:
Nov 2006
Location:
Sydney, Australia
Posts:
465
Plugin Contributions:
0

500 Internal Server Error when updating Order Status to "Update [4]"

Hi All,

I have a Fresh install of Zen-cart 1.3.9a :)

I am in the process of doing dummy orders to test it, I came accross what I think might be a bug, not sure though!

When I change the Status of my order, from Pending to Processing to Delivered..all works as usual :)

However, when I change it from any of above Status to Update I get an Internal 500 Error!

Haven't really done much to the fresh install yet, so don't think this is my fault.

I hope that make sense.

Please advise.

Best Regards,

28 Apr 2010, 2:54 AM
#2
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: 500 Internal Server Error when updating Order Status to "Update [4]"

I can't replicate the problem you describe. Updating order-status to any of the built-in status levels works fine without triggering any 500 errors.

What were you typing into the comments field?

Why are you using the "Update [4]" status anyway?

removing this from the Bug Reports section

28 Apr 2010, 3:07 AM
#3
rlexyd avatar

rlexyd

Zen Follower

Join Date:
Nov 2006
Location:
Sydney, Australia
Posts:
465
Plugin Contributions:
0

Re: 500 Internal Server Error when updating Order Status to "Update [4]"

Hi DrByte,

I inputed random text.
I do use the (update) to add customer comments/feedback etc..
I just tried it again, I noticed that even though I get a 500 internal error when using (update), I click on the order again and the update did however show up on the order page!
It's just that it doesn't work normally, this is the link it directs too (/ADMIN/orders.php?page=1&oID=10&action=update_order).

Not sure why it's doing this?

Best Regards,

28 Apr 2010, 6:09 AM
#4
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: 500 Internal Server Error when updating Order Status to "Update [4]"

Most likely your webserver is flagging the word "update" in the URL due to a mod_security rule that attempts to prevent SQL injection attempts. And, since "update" is a common SQL statement, it's being halted. You'll need to ask your hosting company whether you're allowed to disable mod_security for your admin area via .htaccess, and what statements they'll let you use for that purpose.