Zen Cart Logo
Forums / All Other Contributions/Addons / easy populate 1.2.5.7.csv: Errors i am getting

easy populate 1.2.5.7.csv: Errors i am getting

Locked

Views: 3,255

Results 1 to 18 of 18
This thread is locked. New replies are disabled.
29 Apr 2010, 4:03 PM
#1
delights avatar

delights

Zen Follower

Join Date:
May 2006
Location:
Queensland, Australia
Posts:
254
Plugin Contributions:
0

easy populate 1.2.5.7.csv: Errors i am getting

Greetings;

I am getting the following errors on Easy Populate

1). When i went to install the mod, i clicked on the link up the top that said "Easy Populate Configuration Missing. Please install your configuration by clicking here" the page waited for a few seconds, then come up with the following page. "The website cannot display the page" which is a http 500 Internal Server error.

After that, i checked the menu and the options were there, so i went to set up the "Custom Products Fields

I have a few of them, here is the list...

products_itemlength,products_itemilength,products_itemcir,products_itemdia,products_rated,products_category,products_reversible,products_plussize,products_packingtype,products_dance,products_convertible,products_lightup,products_valueprice

Everytime i click on *Create Complete .csv file in temp dir (Attributes Not Included) *

i keep getting "The website cannot display the page" which is a http 500 Internal Server error.

Anyone have any suggestions on how to get the F*&King mod working ?

29 Apr 2010, 4:05 PM
#2
shane78 avatar

shane78

Banned

Join Date:
Oct 2008
Location:
newcastle upon tyne (UK)
Posts:
876
Plugin Contributions:
0

Re: easy populate 1.2.5.7.csv: Errors i am getting

installed on 138a or 139a?

Delights:

Greetings;

I am getting the following errors on Easy Populate

1). When i went to install the mod, i clicked on the link up the top that said "Easy Populate Configuration Missing. Please install your configuration by clicking here" the page waited for a few seconds, then come up with the following page. "The website cannot display the page" which is a http 500 Internal Server error.

After that, i checked the menu and the options were there, so i went to set up the "Custom Products Fields

I have a few of them, here is the list...

products_itemlength,products_itemilength,products_itemcir,products_itemdia,products_rated,products_category,products_reversible,products_plussize,products_packingtype,products_dance,products_convertible,products_lightup,products_valueprice

Everytime i click on *Create Complete .csv file in temp dir (Attributes Not Included) *

i keep getting "The website cannot display the page" which is a http 500 Internal Server error.

Anyone have any suggestions on how to get the F*&King mod working ?

29 Apr 2010, 4:07 PM
#3
delights avatar

delights

Zen Follower

Join Date:
May 2006
Location:
Queensland, Australia
Posts:
254
Plugin Contributions:
0

Re: easy populate 1.2.5.7.csv: Errors i am getting

Shane78:

installed on 138a or 139a?

Sorry forgot to mension 1.3.9A

29 Apr 2010, 4:08 PM
#4
shane78 avatar

shane78

Banned

Join Date:
Oct 2008
Location:
newcastle upon tyne (UK)
Posts:
876
Plugin Contributions:
0

Re: easy populate 1.2.5.7.csv: Errors i am getting

aye, guessed as much...

doesnt work on 139a...

http://www.zen-cart.com/forum/showpost.php?p=876451&postcount=115

bummer eh! (bummer... haha.. never used that word in my life! im spending far too much time talking to americans!)

29 Apr 2010, 4:10 PM
#5
delights avatar

delights

Zen Follower

Join Date:
May 2006
Location:
Queensland, Australia
Posts:
254
Plugin Contributions:
0

Re: easy populate 1.2.5.7.csv: Errors i am getting

Shane78:

aye, guessed as much...

doesnt work on 139a...

http://www.zen-cart.com/forum/showpost.php?p=876451&postcount=115

bummer eh! (bummer... haha.. never used that word in my life! im spending far too much time talking to americans!)

Crap, didnt see that in the list.

Dont suppose anyone has any ideas on how long before it is working, is there an eta or something ?

29 Apr 2010, 4:12 PM
#6
shane78 avatar

shane78

Banned

Join Date:
Oct 2008
Location:
newcastle upon tyne (UK)
Posts:
876
Plugin Contributions:
0

Re: easy populate 1.2.5.7.csv: Errors i am getting

i did come across one post where one dude (dude!.. im english for crying out loud) has EP1.2.5.5 or 1.2.5.4 working... god knows, there are that many versions of it

29 Apr 2010, 4:15 PM
#7
delights avatar

delights

Zen Follower

Join Date:
May 2006
Location:
Queensland, Australia
Posts:
254
Plugin Contributions:
0

Re: easy populate 1.2.5.7.csv: Errors i am getting

Shane78:

i did come across one post where one dude (dude!.. im english for crying out loud) has EP1.2.5.5 or 1.2.5.4 working... god knows, there are that many versions of it

I am filled with confidence when you say "there is one guy", :D

I hope it dosnt take them too long to re-write the code, in this case, no one (besides that one guy) will be able to update their site with new products until it is done.

29 Apr 2010, 4:18 PM
#8
shane78 avatar

shane78

Banned

Join Date:
Oct 2008
Location:
newcastle upon tyne (UK)
Posts:
876
Plugin Contributions:
0

Re: easy populate 1.2.5.7.csv: Errors i am getting

Delights:

I am filled with confidence when you say "there is one guy", :D

I hope it dosnt take them too long to re-write the code, in this case, no one (besides that one guy) will be able to update their site with new products until it is done.

lol,i think his name was dave...?

29 Apr 2010, 4:21 PM
#9
delights avatar

delights

Zen Follower

Join Date:
May 2006
Location:
Queensland, Australia
Posts:
254
Plugin Contributions:
0

Re: easy populate 1.2.5.7.csv: Errors i am getting

Shane78:

lol,i think his name was dave...?

LOL, so one bloke got it working, we think he's name is dave and we arnt totally sure what version it was that he god working ?

Ill think ill have a beer and wait for them to fix the new version...

3 May 2010, 4:27 PM
#10
design75 avatar

design75

Totally Zenned

Join Date:
Dec 2009
Location:
Amersfoort, The Netherlands
Posts:
2,862
Plugin Contributions:
5

Re: easy populate 1.2.5.7.csv: Errors i am getting

Well i have it working in 1.39b:clap:.
The only problem is the the categories don't have any pictures any more. they are not mentioned in the csv.:wacko:

the file is created in 1.38a and uploaded to 1.39b

3 May 2010, 4:54 PM
#11
delights avatar

delights

Zen Follower

Join Date:
May 2006
Location:
Queensland, Australia
Posts:
254
Plugin Contributions:
0

Re: easy populate 1.2.5.7.csv: Errors i am getting

Design75:

Well i have it working in 1.39b:clap:.
The only problem is the the categories don't have any pictures any more. they are not mentioned in the csv.:wacko:

the file is created in 1.38a and uploaded to 1.39b

do you have the custom fields working ?

3 May 2010, 5:51 PM
#12
design75 avatar

design75

Totally Zenned

Join Date:
Dec 2009
Location:
Amersfoort, The Netherlands
Posts:
2,862
Plugin Contributions:
5

Re: easy populate 1.2.5.7.csv: Errors i am getting

Delights:

do you have the custom fields working ?

Which custom fields you mean ??:oops:

Never mind, already found what you meant. This option is left blank

7 May 2010, 8:01 PM
#13
design75 avatar

design75

Totally Zenned

Join Date:
Dec 2009
Location:
Amersfoort, The Netherlands
Posts:
2,862
Plugin Contributions:
5

Re: easy populate 1.2.5.7.csv: Errors i am getting

You know what the strange thing is ....

1.2.5.4 and 1.2.5.5 are working ok in zencart 1.38a / 1.39b,:lamo: so i think I'll stick with the downgrade and wait for version 1.2.5.8 ?

12 May 2010, 7:15 PM
#14
starksark avatar

starksark

New Zenner

Join Date:
Jul 2009
Posts:
16
Plugin Contributions:
0

Re: easy populate 1.2.5.7.csv: Errors i am getting

Okay, I finally FIXED this! It does work.

If you **do not need **the custom fields, just go into admin>configure>easy populate and delete the custom field box contents.

If, like me, you DO NEED the custom fields, (in the example below, I've used UPC as it's the one that I think is most desperately lacking:

in admin>tools>install SQL patches:

paste the following line:

ALTER TABLE products ADD products_upc varchar(32) NULL default NULL after products_model;

Then, in admin>configure>easy populate>custom fields, insert the field name EXACTLY as it is in the code, in this case products_upc

Presto! a UPC field that you can update in Easy Populate.

Once I get the coding worked out to show the field in the various locations, I'll upload the mod.

Crystal
PS - thanks to everyone who dummied things down for me and to everyone who's apps I borrowed code from.

20 Aug 2010, 10:44 PM
#15
webmc avatar

webmc

New Zenner

Join Date:
Jul 2010
Location:
Kent UK
Posts:
50
Plugin Contributions:
0

Re: easy populate 1.2.5.7.csv: Errors i am getting

starksark:

Okay, I finally FIXED this! It does work.

If you **do not need **the custom fields, just go into admin>configure>easy populate and delete the custom field box contents.

If, like me, you DO NEED the custom fields, (in the example below, I've used UPC as it's the one that I think is most desperately lacking:

in admin>tools>install SQL patches:

paste the following line:

ALTER TABLE products ADD products_upc varchar(32) NULL default NULL after products_model;

> 
> Then, in admin>configure>easy populate>custom fields, insert the field name EXACTLY as it is in the code, in this case products_upc
> 
> Presto! a UPC field that you can update in Easy Populate.
> 
> Once I get the coding worked out to show the field in the various locations, I'll upload the mod.
> 
> Crystal
> PS - thanks to everyone who dummied things down for me and to everyone who's apps I borrowed code from.

You are amazing. Big Kiss:jawdrop::thumbsup::bigups::happybday:smile:

magic 

(Custom fields is what makes this version the best easy populate)
30 Sep 2010, 7:46 PM
#16
webmc avatar

webmc

New Zenner

Join Date:
Jul 2010
Location:
Kent UK
Posts:
50
Plugin Contributions:
0

Re: easy populate 1.2.5.7.csv: Errors i am getting

Ive just noticed I can't download a Complete.csv - I just get blank page...:no:

4 Oct 2010, 2:06 AM
#17
ifsca avatar

ifsca

New Zenner

Join Date:
Jun 2008
Posts:
6
Plugin Contributions:
0

Re: easy populate 1.2.5.7.csv: Errors i am getting

Zen version: v1.3.9f
EP version: 1.2.5.7b

I also am getting an empty file with "Download Complete .csv file to edit". The column headings are the only data in the file.

The "Model/***" downloads work correctly.
The frugal download works correctly.

Products use no custom fields and there is no option in admin/configure/easy populate to remove custom field box contents.

4 Oct 2010, 2:44 PM
#18
webmc avatar

webmc

New Zenner

Join Date:
Jul 2010
Location:
Kent UK
Posts:
50
Plugin Contributions:
0

Re: easy populate 1.2.5.7.csv: Errors i am getting

Its really Wierd - I have tested easypopulate version 1.2.5.4 it allows me to download but not upload large files - but only to the tempEP folder.

This Version allows me to Upload but not download large files with custom fields.

My solution for now has been to install both.
I had to open up easypopulate.php in 1.2.5.7
change the delimiter to $csv_deliminator = "\t"; //tabbed

For all the 1.2.5.4 file i put changed the filenames to have "double_" infront of the filename - eg "double_easypopulate.php"
eg. $za_contents[] = array('text' => BOX_TOOLS_DOUBLE_EASYPOPULATE, 'link' => zen_href_link(FILENAME_DOUBLE_EASYPOPULATE, '', 'NONSSL'));
?>

admin\includes\languages\english\extra_definitions
admin\includes\extra_datafiles
\admin\includes\boxes\extra_boxes\

Open the files here and change content to have "double_" infront of every Easypopulate name reference.

Delete the functions file

-You should now be able to install both. -

for exporting custom fileds from 1.2.5.4 see
http://www.zen-cart.com/forum/showthread.php?t=116061

I have taken it a step further by changing the links in the original easypopulate.php which should be 1.2.5.7 to acess the links in 1.2.5.4 so you can do it all from the 1.2.5.7 page like so;

<a href="double_easypopulate.php?download=tempfile&dltype=modqty">Create <b>Model/Price/Qty/Last Modified/Status</b> .txt file in temp dir</a><br /> //notice it is accessing double_easypopulate from easypopulate page

I have then deleted the html in the double_easypopulate page; to just have a back button <a href="easypopulate.php"><h1 stlye="text-align:center;">Back</h1></a> - because this page loads when you access the links and it uploads the file.

As I say it only seems to let me downoad it in into the TempEP folder - however if you open the filelist.php in the TempEP folder - YOu can enable downloads. Then just right click and save target as.
Its not an ideal solution but it is the only way I personally can get easy populate to work - I have heard stories that 1.2.5.4 works but from my experience with large files it doesnt, so I have had to do it this way....