Zen Cart Logo
Forums / Installing on a Linux/Unix Server / permission denied error

permission denied error

Locked

Views: 2,401

Results 1 to 5 of 5
This thread is locked. New replies are disabled.
5 May 2010, 4:39 AM
#1
muzz avatar

muzz

Totally Zenned

Join Date:
Mar 2009
Location:
Australia
Posts:
604
Plugin Contributions:
0

permission denied error

Hi there,

I had a server admin unzip some ungrades to my zen cart.

All the permissions have been messed up.

I have found some info on permissions for Zen cart but not ALL.

Basically, OTHER than:

All of these to 777 (or 755 if using suPHP: see footnote):
/cache
/pub
/images
/includes/languages/english/html_includes
/admin/backups
/admin/images/graphs

These to 444 or 644
/includes/configure.php
/admin/includes/configure.php

What should the rest of the cart permissions directories, sub directories and files be by default?

5 May 2010, 5:43 AM
#2
muzz avatar

muzz

Totally Zenned

Join Date:
Mar 2009
Location:
Australia
Posts:
604
Plugin Contributions:
0

Re: permission denied error

Getting this error:

Warning: require(includes/application_top.php) [function.require]: failed to open stream: Permission denied in /home/webname/public_html/index.php on line 26

Warning: require(includes/application_top.php) [function.require]: failed to open stream: Permission denied in /home/webname/public_html/index.php on line 26

Fatal error: require() [function.require]: Failed opening required 'includes/application_top.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/webname/public_html/index.php on line 26

From what I read permission issues???

Someone point me to where the ENTIRE permissions for full install of ZENCART are??

yodgee.com.au

I removed the .htaccess file from home dir. Put in test hello world html.. worked no problems.

5 May 2010, 6:37 AM
#3
schoolboy avatar

schoolboy

Totally Zenned

Join Date:
Jun 2005
Location:
Cumbria, UK
Posts:
10,327
Plugin Contributions:
0

Re: permission denied error

In the docs folder, there is a set of html files which give details of what is required during the installation.

Open docs folder and click on index.html

Go through the various set-up requirements. You will see what permissions need to be set for certain folders and files.

Typically, folders are CHMOD to 0755 and files to 0644 (but there are a couple of exceptions).

It could be that you have some faulty files (sometimes corrupted during the FTP process).

It may help to re-send (via FTP) the whole includes folder to the server, to OVER-WRITE the current folder and file sets.

5 May 2010, 7:35 AM
#4
website_rob avatar

website_rob

Inactive

Join Date:
Oct 2006
Location:
Alberta, Canada
Posts:
4,572
Plugin Contributions:
0

Re: permission denied error

Quickest and easiest method is to use your FTP program to re-upload your files. It will automatically use default permissions which are secure; 755 for dir's. and 644 for files. Also, ignore that information you posted above about permissions of 777. Never use 777 unless you are working on your site. After uploading with your FTP program, look at what the permissions are to see the correct settings.

5 May 2010, 10:59 PM
#5
muzz avatar

muzz

Totally Zenned

Join Date:
Mar 2009
Location:
Australia
Posts:
604
Plugin Contributions:
0

Re: permission denied error

Hi there,

Thanks for your input everyone.

I had the server admin correct the permissions for all folders and subfolders 755 and files 644.

Then I edited the required files permissions for files per my initial post.

Thankyou