Zen Cart Logo
Forums / Installing on a Linux/Unix Server / admin page blank but apache 200 ok and no aparent PHP errors or warnings

admin page blank but apache 200 ok and no aparent PHP errors or warnings

Locked

Views: 2,391

Results 1 to 3 of 3
This thread is locked. New replies are disabled.
3 Jun 2010, 8:20 PM
#1
tomgoetals avatar

tomgoetals

New Zenner

Join Date:
Apr 2010
Posts:
2
Plugin Contributions:
0

admin page blank but apache 200 ok and no aparent PHP errors or warnings

Hi,

I have a problem after I update the database of my shop version 1.3.8.a.
In short: Localy I have the shop on an MS vista laptop, and I move it to a virtual server. No prob there ... versions of software are deb2.6 lenny, PHP 5.3, MySQL 5.1 (both PHP and MySQL are versions vrom dotdeb.org but I see no probs there :-) )and apache is 2.2.
However when I update the database using myphpadmin on bothe the MS and *nix platform (dropping all tables, importing the SQL file .... even just copying the SQL file in the SQL execution window in myphpadmin .... using plain shell commands ...) the result is the same ... I get an empty doc ... .
I used the STRICT_ERROR_REPORTING explained in the FAQ (includes/local/configure.php with define(STRICT_ERROR ...., true);
(great tool by the way because it revealed some errors regarding Caps in language modules (dutch in this case) )but no errors regarding the admin/index.php page ...
the httpresponse is 200 ok.
The response headers are below

Date: Thu, 03 Jun 2010 20:11:22 GMT
Server: Apache/2.2.9 (Debian) PHP/5.3.2-0.dotdeb.2 with Suhosin-Patch mod_python/3.3.1 Python/2.5.2 mod_ssl/2.2.9 OpenSSL/0.9.8g mod_perl/2.0.4 Perl/v5.10.0
X-Powered-By: PHP/5.3.2-0.dotdeb.2
Expires: Thu, 19 Nov 1981 08:52:00 GMT
Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
Pragma: no-cache
Vary: Accept-Encoding
Content-Encoding: gzip
Content-Length: 20
Keep-Alive: timeout=15, max=99
Connection: Keep-Alive
Content-Type: text/html

200 OK
<<

Hope I gave enough info regarding the problem ..
Thanx in advance

3 Jun 2010, 9:27 PM
#2
kobra avatar

kobra

Black Belt

Join Date:
Aug 2005
Location:
Arizona
Posts:
31,500
Plugin Contributions:
4

Re: admin page blank but apache 200 ok and no aparent PHP errors or warnings

I have a problem after I update the database of my shop version 1.3.8.a.
In short: Localy I have the shop on an MS vista laptop, and I move it to a virtual server. No prob there ... versions of software are deb2.6 lenny, PHP 5.3,
Have you applied the php 5.3.x patch?
Might be simpler to upgrade to 1.3.9c

4 Jun 2010, 9:33 AM
#3
tomgoetals avatar

tomgoetals

New Zenner

Join Date:
Apr 2010
Posts:
2
Plugin Contributions:
0

Re: admin page blank but apache 200 ok and no aparent PHP errors or warnings

I did indeed apply the php patch (doesn't work at all without it :) )
and am trying 1.3.9d now.
1.3.9c does my head in ... installs fine but going to the index.php after install shoots down apache ... but thats beside the point now and probably covered in another thread