Zen Cart Logo
Forums / Basic Configuration / Admin Login Just Loops

Admin Login Just Loops

Locked

Views: 1,216

Results 1 to 4 of 4
This thread is locked. New replies are disabled.
16 Jun 2010, 9:24 AM
#1
mshultise avatar

mshultise

Zen Follower

Join Date:
Feb 2005
Location:
Captain Cook, Hawaii
Posts:
172
Plugin Contributions:
0

Admin Login Just Loops

A customer called me today. All of a sudden, their Zen-Cart version 1.3.8a on PHP 5.2.13 stopped logging them into Admin. It had been working for months and now just looped when they tried to log in. No errors except that sometimes the bad username/password error would show. After testing I found that sometimes I could get in, sometimes not. Then soon, not again.

I looked in the database because one somewhat similar problem years ago involved the setting for checking to see if a new version is available and the login could hang if the server did not respond. I think that error was finally addressed theough.

Because a number of people access the Admin area, I zapped and rebuilt the Admin table and defaulted the passwords. That didn't help.

Then I saw that my server host may be upgrading this server over the next few weeks. Still, this particular server had recently had upgrades so I kept looking. As I researched this problem in the forums I tried a number of suggestions; none helped. At one point I thought I had it fixed by clearing the Admin Log in the database, clearing sessions and whos-online. Then I could not get in again.

Along the time of problems I also tried the .htaccess file swap and disables, but that also did not help.

I then loaded the PHP debug tool mentioned in a forum and it showed that the system thought it was missing a function called "queryfactory".

This whole time I was fighting a terrific headache.

Finally I found a message talking about PHP versions and so on. One item was that someone suggested they fixed their problem by turning off the APC (The Alternative PHP Cache). THAT seems to have finally fixed things for me!

So my suggestion is that, if you cannot log into Admin and the system just keeps cycling that login screen with no errors, then see if you have access to the APC function in your PHP controls on your host, and try turning that off! It may be just that simple.

Aloha from Hawaii! (its a dirty job, but SOMEBODY has to live here...)

24 Jun 2010, 1:34 AM
#2
taylorh avatar

taylorh

New Zenner

Join Date:
Jun 2010
Posts:
9
Plugin Contributions:
0

Re: Admin Login Just Loops

Hi;

I seem to be having this issue. I can log into admin fone form the server itself, but not from a remote computer on my network.  Since I am running my own server, I am assuming I can turn off the APC, I jsut have no idea how to do that.  Suggestions?
27 Jun 2010, 8:27 PM
#3
craseland avatar

craseland

New Zenner

Join Date:
Jun 2010
Posts:
4
Plugin Contributions:
0

Re: Admin Login Just Loops

I am having the same issues - even with a brand new install after deleting my current cart and database. However, when I look at my php settings (using phpinfo()), I don't see apc listed anywhere. Could it be called something else or is there another issue I should explore?

30 Jun 2010, 8:41 PM
#4
mshultise avatar

mshultise

Zen Follower

Join Date:
Feb 2005
Location:
Captain Cook, Hawaii
Posts:
172
Plugin Contributions:
0

Re: Admin Login Just Loops

TaylorH:

Hi;

I seem to be having this issue. I can log into admin fone form the server itself, but not from a remote computer on my network.  Since I am running my own server, I am assuming I can turn off the APC, I jsut have no idea how to do that.  Suggestions?

In my case, it is a configuration item in the hosting companys control panel. If you are running your own server, you won't have this.

It does not sound as though it is the same problem. Try pinging the server from the other computer. You may have firewall issues, etc.

Aloha from Hawaii! (its a dirty job, but SOMEBODY has to live here...)