Zen Cart Logo

mysql errors

Locked

Views: 3,060

Results 1 to 12 of 12
This thread is locked. New replies are disabled.
1 Jul 2010, 10:34 AM
#1
kitcorsa avatar

kitcorsa

Totally Zenned

Join Date:
Feb 2007
Posts:
1,724
Plugin Contributions:
0

mysql errors

well up to my 4th upgrade so far and now fit a wall!

getting the following error after the database upgrade.

1253 COLLATION 'latin1_general_ci' is not valid for CHARACTER SET 'utf8'
in:
[CREATE TABLE 1uic_counter_history_clean as SELECT * FROM 1uic_counter_history WHERE 1 GROUP BY startdate COLLATE latin1_general_ci;]

copied original database
uploaded new folder with 139d
copied and changfe config files from original zencart install into new 139 folder
run zc_install
fail!

1 Jul 2010, 2:23 PM
#3
kitcorsa avatar

kitcorsa

Totally Zenned

Join Date:
Feb 2007
Posts:
1,724
Plugin Contributions:
0

Re: mysql errors

tried that now i get

1273 Unknown collation: 'uft8_general_ci'
in:
[CREATE TABLE 1uic_counter_history_clean as SELECT * FROM 1uic_counter_history WHERE 1 GROUP BY startdate COLLATE uft8_general_ci;]

1 Jul 2010, 8:43 PM
#4
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: mysql errors

What is the default character set and collation on your database?

2 Jul 2010, 8:10 AM
#5
kitcorsa avatar

kitcorsa

Totally Zenned

Join Date:
Feb 2007
Posts:
1,724
Plugin Contributions:
0

Re: mysql errors

DrByte:

What is the default character set and collation on your database?

not sure... how can i check?

2 Jul 2010, 1:35 PM
#6
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: mysql errors

phpMyAdmin will probably tell you

5 Jul 2010, 9:46 AM
#7
kitcorsa avatar

kitcorsa

Totally Zenned

Join Date:
Feb 2007
Posts:
1,724
Plugin Contributions:
0

Re: mysql errors

would it be uft8_generial_ci

5 Jul 2010, 10:28 PM
#8
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: mysql errors

If it is, then you won't be getting the errors you quoted.

6 Jul 2010, 9:36 AM
#9
kitcorsa avatar

kitcorsa

Totally Zenned

Join Date:
Feb 2007
Posts:
1,724
Plugin Contributions:
0

Re: mysql errors

right i just started from scratch again, download a new zersion copy of the upgrade, uploaded to the server, changed copied the config files from old site over, rand the upgrade and second i do the upgrade i get the error again.

1253 COLLATION 'latin1_general_ci' is not valid for CHARACTER SET 'utf8'
in:
[CREATE TABLE 1uic_counter_history_clean as SELECT * FROM 1uic_counter_history WHERE 1 GROUP BY startdate COLLATE latin1_general_ci;]

6 Jul 2010, 9:40 AM
#10
kitcorsa avatar

kitcorsa

Totally Zenned

Join Date:
Feb 2007
Posts:
1,724
Plugin Contributions:
0

Re: mysql errors

phpmyadmin says the following

  • Server: Localhost via UNIX socket
  • Server version: 5.0.91-community
  • Protocol version: 10
  • User: me
  • MySQL charset: UTF-8 Unicode (utf8)
6 Jul 2010, 9:51 AM
#11
kitcorsa avatar

kitcorsa

Totally Zenned

Join Date:
Feb 2007
Posts:
1,724
Plugin Contributions:
0

Re: mysql errors

tired again from scratch.... this time changed the uft8 again in the install paramas and this time no sql error but i get the following message on the upgrade screen.

  • NOTE: Skipped upgrade statements: 1
    See details at bottom of page for your inspection.
    (Details also logged in the "upgrade_exceptions" table.)
    Note: In most cases, these failed statements can be ignored,
    as they are indications that certain settings may have already been set on your site.
    If all the suggested upgrade steps have been completed (no recommendations left),
    you may proceed to Skip Upgrades and continue configuring your site. more info...
  • Your db prefix of "4gig_" is a potential problem. Database Table-Prefix may only contain letters and numbers and underscores (_).
    and errors at the bottom

SKIPPED: Cannot insert configuration_key "SHOW_SPLIT_TAX_CHECKOUT" because it already exists
SKIPPED: Cannot insert configuration_key "SHOW_SPLIT_TAX_CHECKOUT" because it already exists
SKIPPED: Cannot insert configuration_key "SHOW_SPLIT_TAX_CHECKOUT" because it already exists
SKIPPED: Cannot insert configuration_key "SHOW_SPLIT_TAX_CHECKOUT" because it already exists
SKIPPED: Cannot insert configuration_key "SHOW_SPLIT_TAX_CHECKOUT" because it already exists
SKIPPED: Cannot insert configuration_key "SHOW_SPLIT_TAX_CHECKOUT" because it already exists
SKIPPED: Cannot insert configuration_key "SHOW_SPLIT_TAX_CHECKOUT" because it already exists
SKIPPED: Cannot insert configuration_key "SHOW_SPLIT_TAX_CHECKOUT" because it already exists
SKIPPED: Cannot insert configuration_key "SHOW_SPLIT_TAX_CHECKOUT" because it already exists
SKIPPED: Cannot insert configuration_key "SHOW_SPLIT_TAX_CHECKOUT" because it already exists
SKIPPED: Cannot insert configuration_key "SHOW_SPLIT_TAX_CHECKOUT" because it already exists
SKIPPED: Cannot insert configuration_key "SHOW_SPLIT_TAX_CHECKOUT" because it already exists
SKIPPED: Cannot insert configuration_key "SHOW_SPLIT_TAX_CHECKOUT" because it already exists
SKIPPED: Cannot insert configuration_key "SHOW_SPLIT_TAX_CHECKOUT" because it already exists
SKIPPED: Cannot insert configuration_key "SHOW_SPLIT_TAX_CHECKOUT" because it already exists
SKIPPED: Cannot insert configuration_key "SHOW_SPLIT_TAX_CHECKOUT" because it already exists
SKIPPED: Cannot insert configuration_key "SHOW_SPLIT_TAX_CHECKOUT" because it already exists
SKIPPED: Cannot insert configuration_key "SHOW_SPLIT_TAX_CHECKOUT" because it already exists

6 Jul 2010, 9:59 AM
#12
kitcorsa avatar

kitcorsa

Totally Zenned

Join Date:
Feb 2007
Posts:
1,724
Plugin Contributions:
0

Re: mysql errors

in admin all says 1.3.9d now so i guess this worked?