Forums / Addon Shipping Modules / problem with UPSXML after moving hosting

problem with UPSXML after moving hosting

Locked

Views: 943

Results 1 to 2 of 2
This thread is locked. New replies are disabled.
1 Jul 2010, 5:30 PM
#1
jbartoli avatar

jbartoli

New Zenner

Join Date:
Jun 2010
Posts:
7
Plugin Contributions:
0

problem with UPSXML after moving hosting

not sure if this is the correct area but...

I moved hosting and now I get an error in upsxml.php in admin trying to open the shipping modules page (checkout works). the error has to do with this line:
require ('includes/classes/xmldocument.php');

if I change it to:
require ('../includes/classes/xmldocument.php');

it works but then checkout does not.

I know I'm missing something simple. I tried changing the line to:

try {
require ('includes/classes/xmldocument.php');
}
catch (Exception $e) {
require ('../includes/classes/xmldocument.php');
}

any ideas?

1 Jul 2010, 6:31 PM
#2
jbartoli avatar

jbartoli

New Zenner

Join Date:
Jun 2010
Posts:
7
Plugin Contributions:
0

Re: problem with UPSXML after moving hosting

well, this works:
if (file_exists('includes/classes/xmldocument.php')){
$xmlFile='includes/classes/xmldocument.php';
}else {
$xmlFile='../includes/classes/xmldocument.php';
}
require($xmlFile);

but still not sure why it broke in the first place!