Forums / Installing on a Linux/Unix Server / How to port from local WAMP to Unix/Linux server (shared host)?

How to port from local WAMP to Unix/Linux server (shared host)?

Locked

Views: 2,268

Results 1 to 3 of 3
This thread is locked. New replies are disabled.
21 Jul 2010, 1:52 AM
#1
weilies avatar

weilies

New Zenner

Join Date:
Jul 2010
Posts:
2
Plugin Contributions:
0

How to port from local WAMP to Unix/Linux server (shared host)?

i believe porting from local wamp to server is quite straight forward

move the localhost/zencart/*
to
home/my_account/public_html/*

then change the db setting and path, port the DB over
but after i did everything, it still prompt me for installation...

i hv search through but no luck to find any doc mention bout this issue.

so my question is,

  • what files should i change other than includes/configuration.php, admin/includes/configuration.php?
  • what are the line to change? (i m in ver1.3.8)
  • the correct structure should be
    home/my_account/public_html/
    or
    home/my_account/public_html/zencart
21 Jul 2010, 2:37 AM
#2
frank18 avatar

frank18

Deceased

Join Date:
Nov 2007
Location:
Sunny Coast, Australia
Posts:
3,427
Plugin Contributions:
2

Re: How to port from local WAMP to Unix/Linux server (shared host)?

NOTE: We are sorry that Frank is no longer with us.
We are grateful for all his contributions to the Zen Cart community.

21 Jul 2010, 4:42 AM
#3
weilies avatar

weilies

New Zenner

Join Date:
Jul 2010
Posts:
2
Plugin Contributions:
0

Re: How to port from local WAMP to Unix/Linux server (shared host)?

but as i mentioned, i try to install a FRESH copy
and i hit error "zc_install/index.php" not found

it's impossible, the file is physically there
uploaded to
/home/my_account/public_html/admin/
/home/my_account/public_html/cache/
/home/my_account/public_html/getpath.php
/home/my_account/public_html/index.php
...

then i try https://www.mydomain.com/zc_install/index.php
then i try https://www.mydomain.com/zen/zc_install/index.php
Error: file not found

then i move everything to
/home/my_account/public_html/zen/

then rerun https://www.mydomain.com/zc_install/index.php
then rerun https://www.mydomain.com/zen/zc_install/index.php
Error: file not found

i tried all combination.... any idea? but i dont hv .htaccess, do i need it?