Forums / Installing on a Windows Server / Your database appears to need patching to a higher level. See Admin->Tools->Server In

Your database appears to need patching to a higher level. See Admin->Tools->Server In

Locked

Views: 4,563

Results 1 to 4 of 4
This thread is locked. New replies are disabled.
15 Aug 2010, 3:41 PM
#1
losse avatar

losse

New Zenner

Join Date:
Aug 2010
Posts:
11
Plugin Contributions:
0

Your database appears to need patching to a higher level. See Admin->Tools->Server In

Hi
Just installed ZC. It was running fine on another host and just re-installed it on a new host. Everything worked great except that on the homepage, I see this error:

Your database appears to need patching to a higher level. See Admin->Tools->Server Information to review patch levels.

I read some posts on the forums that suggested I go through the install again but skip everything and go straight to the Database Upgrade but when I select all the patch updates, enter my user and pass I get these 2 errors:

  • mysql SQL Install file does not exist
  • Admin Password required to proceed with upgrade

I checked the folder and the mysql install file is there (folder permission set at 755 and file at 644) and the admin password is correct as I tested it trying to login to my admin area and it worked.

Not sure if there is a root problem for this or if this is 2 seperate issues.

Thanks for the support!

15 Aug 2010, 3:54 PM
#2
kobra avatar

kobra

Black Belt

Join Date:
Aug 2005
Location:
Arizona
Posts:
31,500
Plugin Contributions:
4

Re: Your database appears to need patching to a higher level. See Admin->Tools->Server In

Just installed ZC. It was running fine on another host and just re-installed it on a new host. Everything worked great except that on the homepage, I see this error:
You must not be using the same version files as you had or from a file backup from your other account

See tutorial as principles are the same for moving hosts
https://www.zen-cart.com/tutorials/index.php?article=99

Zen-Venom Get Bitten

15 Aug 2010, 6:02 PM
#3
losse avatar

losse

New Zenner

Join Date:
Aug 2010
Posts:
11
Plugin Contributions:
0

Re: Your database appears to need patching to a higher level. See Admin->Tools->Server In

Well... I'm guessing that when I first installed it on the first (old) host, it was an older version and over the years, new updates have been put in place... that's why I tried the database upgrade which also didn't work.

I read that tutorial prior to moving the site over and also just took quick read at it. nothing on that really talks about what i'm experiencing.

16 Aug 2010, 10:14 PM
#4
losse avatar

losse

New Zenner

Join Date:
Aug 2010
Posts:
11
Plugin Contributions:
0

Re: Your database appears to need patching to a higher level. See Admin->Tools->Server In

Ok. Was able to figure out one of the errors... Now I keep getting this error:

mysql SQL Install file does not exist

which says that it's because the file zc_install/sql/mysql_zencart.sql doesn't exist but it does!?

Any ideas how I can get the patches up?