Zen Cart Logo
Forums / All Other Contributions/Addons / 'Tell a Friend' feature is not working

'Tell a Friend' feature is not working

Locked

Views: 853

Results 1 to 5 of 5
This thread is locked. New replies are disabled.
23 Aug 2010, 12:02 AM
#1
ballyc27 avatar

ballyc27

New Zenner

Join Date:
Sep 2007
Posts:
65
Plugin Contributions:
0

'Tell a Friend' feature is not working

Hi there,

just having trouble with the 'Tell a Friend' functionality.
I have the "Show Product Tell a Friend button field" enabled but when I try to use the feature (i.e. fill in all the required fields), I get a bunch of errors saying:

  • Error: Your name must not be empty.
  • Error: Your email address does not appear to be valid. Please try again.
  • Error: Your friend's name must not be empty.
  • Error: Your friend's email address does not appear to be valid. Please try again.

And of course, the email is not sent.
Anyone have any ideas?

Stores in question (same installation):
store.theebooksale.com
m.theebooksale.com

Thanks,
Richie.

23 Aug 2010, 12:28 AM
#2
kobra avatar

kobra

Black Belt

Join Date:
Aug 2005
Location:
Arizona
Posts:
31,500
Plugin Contributions:
4

Re: 'Tell a Friend' feature is not working

What ZenCart version???
Is this a initial install or has it been upgraded?

Zen-Venom Get Bitten

23 Aug 2010, 12:32 AM
#3
ballyc27 avatar

ballyc27

New Zenner

Join Date:
Sep 2007
Posts:
65
Plugin Contributions:
0

Re: 'Tell a Friend' feature is not working

Hi Kobra,

I'm still on 1.3.8a and I moved server a couple of months back and did a fresh install.

23 Aug 2010, 12:33 AM
#4
kobra avatar

kobra

Black Belt

Join Date:
Aug 2005
Location:
Arizona
Posts:
31,500
Plugin Contributions:
4

Re: 'Tell a Friend' feature is not working

I would start by reloading the tell a friend files

Zen-Venom Get Bitten

25 Aug 2010, 9:03 PM
#5
ballyc27 avatar

ballyc27

New Zenner

Join Date:
Sep 2007
Posts:
65
Plugin Contributions:
0

Re: 'Tell a Friend' feature is not working

Hi Kobra,

just to let you know, the Tell a Friend issue was caused by an old version/out of date file belonging to the Ceon URL Mapping module.
I had updated all the files to version 3.6.3, except for the html_output.php file.
Not sure how I managed to do that but it's fixed now.

Thanks for the help,
Richie.